summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2005-01-06 20:41:01 +0000
committerGuy Martin <gmsoft@gentoo.org>2005-01-06 20:41:01 +0000
commit28f03cf766524f3eb6ef344a7f7b455fec9c094f (patch)
tree89515467552a95a13e7db53cab5a6bf3ee1bb379 /net-misc/hylafax
parentxv support is patched in xine-lib, and it no longer requires the use flag. R... (diff)
downloadgentoo-2-28f03cf766524f3eb6ef344a7f7b455fec9c094f.tar.gz
gentoo-2-28f03cf766524f3eb6ef344a7f7b455fec9c094f.tar.bz2
gentoo-2-28f03cf766524f3eb6ef344a7f7b455fec9c094f.zip
Added -fPIC fix for all arches.
Diffstat (limited to 'net-misc/hylafax')
-rw-r--r--net-misc/hylafax/ChangeLog8
-rw-r--r--net-misc/hylafax/files/hylafax-4.2.0-fPIC.patch48
-rw-r--r--net-misc/hylafax/hylafax-4.2.0-r1.ebuild3
3 files changed, 56 insertions, 3 deletions
diff --git a/net-misc/hylafax/ChangeLog b/net-misc/hylafax/ChangeLog
index e29e42c529e3..0b39b3fd7cc0 100644
--- a/net-misc/hylafax/ChangeLog
+++ b/net-misc/hylafax/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/hylafax
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.45 2004/12/04 08:46:37 nerdboy Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.46 2005/01/06 20:41:01 gmsoft Exp $
+
+ 06 Jan 2005; Guy Martin <gmsoft@gentoo.org> +files/hylafax-4.2.0-fPIC.patch,
+ hylafax-4.2.0-r1.ebuild:
+ Added -fPIC fix for all arches.
04 Dec 2004; Steve Arnold <nerdboy@gentoo.org> hylafax-4.2.0-r1.ebuild:
removed dso-configure patch and set DSO=auto to address bug 72895
diff --git a/net-misc/hylafax/files/hylafax-4.2.0-fPIC.patch b/net-misc/hylafax/files/hylafax-4.2.0-fPIC.patch
new file mode 100644
index 000000000000..adce2801d6ca
--- /dev/null
+++ b/net-misc/hylafax/files/hylafax-4.2.0-fPIC.patch
@@ -0,0 +1,48 @@
+diff -uNr hylafax-4.2.0.orig/configure hylafax-4.2.0/configure
+--- hylafax-4.2.0.orig/configure 2005-01-06 19:56:46.978463856 +0000
++++ hylafax-4.2.0/configure 2005-01-06 19:57:39.141533864 +0000
+@@ -3313,7 +3313,7 @@
+ LIBUTIL=''
+ LIBFAXSERVER='-lfaxserver'
+ FAXD='${DEPTH}/faxd'
+- DSOOPTS='-shared -fpic -Wl,-soname,$@'
++ DSOOPTS='-shared -fPIC -Wl,-soname,$@'
+ LLDOPTS='-L${UTIL} -L${FAXD} -lfaxutil'$USE_RPATH
+ DSO=LINUX
+ CheckCCDSO()
+diff -uNr hylafax-4.2.0.orig/faxd/Makefile.in hylafax-4.2.0/faxd/Makefile.in
+--- hylafax-4.2.0.orig/faxd/Makefile.in 2005-01-06 19:56:47.001460360 +0000
++++ hylafax-4.2.0/faxd/Makefile.in 2005-01-06 20:01:58.837054144 +0000
+@@ -43,6 +43,8 @@
+ SRCDIR = ${DEPTH}/${TOPSRCDIR}/faxd
+ VPATH = ../@SRCDIR@/faxd
+
++OPTIMIZER += -fPIC
++
+ C++FILES=ClassModem.c++ \
+ FaxModem.c++ \
+ Class0.c++ \
+diff -uNr hylafax-4.2.0.orig/regex/Makefile.in hylafax-4.2.0/regex/Makefile.in
+--- hylafax-4.2.0.orig/regex/Makefile.in 2005-01-06 19:56:47.099445464 +0000
++++ hylafax-4.2.0/regex/Makefile.in 2005-01-06 20:00:42.968587904 +0000
+@@ -42,6 +42,8 @@
+ SRCDIR = ${DEPTH}/${TOPSRCDIR}/regex
+ VPATH = ../@SRCDIR@/regex
+
++OPTIMIZER += -fPIC
++
+ CFILES= regexec.c regcomp.c regfree.c regerror.c
+ TARGETS=libregex.a
+
+diff -uNr hylafax-4.2.0.orig/util/Makefile.in hylafax-4.2.0/util/Makefile.in
+--- hylafax-4.2.0.orig/util/Makefile.in 2005-01-06 19:56:47.113443336 +0000
++++ hylafax-4.2.0/util/Makefile.in 2005-01-06 19:58:49.756798712 +0000
+@@ -43,6 +43,8 @@
+ SRCDIR = ${DEPTH}/${TOPSRCDIR}/util
+ VPATH = ../@SRCDIR@/util
+
++OPTIMIZER += -fPIC
++
+ C++FILES=Array.c++ \
+ BoolArray.c++ \
+ Dictionary.c++ \
diff --git a/net-misc/hylafax/hylafax-4.2.0-r1.ebuild b/net-misc/hylafax/hylafax-4.2.0-r1.ebuild
index 8319464b3103..431b6eb67b36 100644
--- a/net-misc/hylafax/hylafax-4.2.0-r1.ebuild
+++ b/net-misc/hylafax/hylafax-4.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.2.0-r1.ebuild,v 1.4 2004/12/04 08:46:37 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.2.0-r1.ebuild,v 1.5 2005/01/06 20:41:01 gmsoft Exp $
inherit eutils
@@ -33,6 +33,7 @@ src_unpack() {
epatch ${FILESDIR}/${P}-faxcron_uid.patch
epatch ${FILESDIR}/${P}-tiff_version.patch
epatch ${FILESDIR}/configure-gcc-3.4.patch
+ epatch ${FILESDIR}/hylafax-4.2.0-fPIC.patch
}
src_compile() {