summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2003-10-31 22:01:34 +0000
committerJason Wever <weeve@gentoo.org>2003-10-31 22:01:34 +0000
commit933e1c647ce1fb0328d8f9c19fedd4d57c56d598 (patch)
treeb5408574b5defc9e3b45137dfc666479ed1395fc /net-misc/jigdo/jigdo-0.7.0.ebuild
parentcap => caps, consulted with a user who says `cap` might be misleading..e.g. b... (diff)
downloadgentoo-2-933e1c647ce1fb0328d8f9c19fedd4d57c56d598.tar.gz
gentoo-2-933e1c647ce1fb0328d8f9c19fedd4d57c56d598.tar.bz2
gentoo-2-933e1c647ce1fb0328d8f9c19fedd4d57c56d598.zip
Added fix for bug #32029. Thanks to robbat2 :)
Diffstat (limited to 'net-misc/jigdo/jigdo-0.7.0.ebuild')
-rw-r--r--net-misc/jigdo/jigdo-0.7.0.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/net-misc/jigdo/jigdo-0.7.0.ebuild b/net-misc/jigdo/jigdo-0.7.0.ebuild
index a02390114394..581675989768 100644
--- a/net-misc/jigdo/jigdo-0.7.0.ebuild
+++ b/net-misc/jigdo/jigdo-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/jigdo-0.7.0.ebuild,v 1.2 2003/09/05 22:01:48 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/jigdo-0.7.0.ebuild,v 1.3 2003/10/31 22:01:32 weeve Exp $
inherit eutils
@@ -10,25 +10,33 @@ SRC_URI="http://home.in.tum.de/~atterer/jigdo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc"
+KEYWORDS="~x86 ~sparc ~ppc"
-IUSE="gtk nls"
+IUSE="gtk nls berkdb"
DEPEND="gtk? ( >=gtk+-2.0.6 )
nls? ( sys-devel/gettext )
+ berkdb? ( =sys-libs/db-3* )
>=libwww-5.3.2"
src_compile() {
-local myconf
+ local myconf
- use nls || myconf="--disable-nls"
- use gtk || myconf="--without-libdb --without-gui"
+ # Fix for bug #32029.
+ if [ `use berkdb` ]; then
+ cd ${S}
+ epatch ${FILESDIR}/jigdo-gentoo-db3.patch
+ fi
+
+ use nls || myconf="${myconf} --disable-nls"
+ use gtk || myconf="${myconf} --without-libdb --without-gui"
+ use berkdb || myconf="${myconf} --without-libdb"
./configure \
--host=${CHOST} \
--prefix=/usr \
--infodir=/usr/share/info \
- --mandir=/usr/share/man $myconf \
+ --mandir=/usr/share/man ${myconf} \
--datadir=/usr/share || die "./configure failed"
# Patch the Makefile so that when jidgo is installed, jigdo-lite has