summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-04-26 22:13:54 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-04-26 22:13:54 +0000
commita245793cd2903064c36158e94535573983afc66c (patch)
treea1906157e93577d41b5ad86c6352184fcf0e5ee6 /net-misc/kiax/kiax-0.8.4.ebuild
parentInitial commit to Gentoo's cvs, huge thanks to Norguhtar <sauronATinfocentr.r... (diff)
downloadgentoo-2-a245793cd2903064c36158e94535573983afc66c.tar.gz
gentoo-2-a245793cd2903064c36158e94535573983afc66c.tar.bz2
gentoo-2-a245793cd2903064c36158e94535573983afc66c.zip
Initial import
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/kiax/kiax-0.8.4.ebuild')
-rw-r--r--net-misc/kiax/kiax-0.8.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/kiax/kiax-0.8.4.ebuild b/net-misc/kiax/kiax-0.8.4.ebuild
new file mode 100644
index 000000000000..b970a13bc705
--- /dev/null
+++ b/net-misc/kiax/kiax-0.8.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/kiax/kiax-0.8.4.ebuild,v 1.1 2005/04/26 22:13:54 stkn Exp $
+
+inherit eutils kde-functions
+
+IUSE=""
+
+DESCRIPTION="QT based IAX (Inter Asterisk eXchange) client"
+HOMEPAGE="http://kiax.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kiax/${P}.tar.bz2"
+
+KEYWORDS="~x86 ~amd64"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=x11-libs/qt-3.2"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-0.8.4-iaxwrapper.patch
+
+ # add prefix for make install
+ sed -i -e "s:\(\$(DEST_PATH)\):\${INSTALL_ROOT}\1:" \
+ bin/Makefile
+}
+
+src_compile() {
+ set-qtdir 3
+
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ make INSTALL_ROOT=${D} install || die "make install failed"
+
+ domenu kiax.desktop
+ dodoc README README.* CHANGELOG COPYING INSTALL INSTALL.*
+}