summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimone Gotti <motaboy@gentoo.org>2004-12-12 13:45:32 +0000
committerSimone Gotti <motaboy@gentoo.org>2004-12-12 13:45:32 +0000
commit7993fe4a6010fff440aea2ff2645da4ce50c2112 (patch)
treeb2f6b7aa648ccf69d69155658415ec07133d5525 /net-misc/kphone/kphone-4.1.0.ebuild
parentadded rblsmtpd-related rules from Andy Dustman (Manifest recommit) (diff)
downloadgentoo-2-7993fe4a6010fff440aea2ff2645da4ce50c2112.tar.gz
gentoo-2-7993fe4a6010fff440aea2ff2645da4ce50c2112.tar.bz2
gentoo-2-7993fe4a6010fff440aea2ff2645da4ce50c2112.zip
Version bump. Closes bug #74024
Diffstat (limited to 'net-misc/kphone/kphone-4.1.0.ebuild')
-rw-r--r--net-misc/kphone/kphone-4.1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/kphone/kphone-4.1.0.ebuild b/net-misc/kphone/kphone-4.1.0.ebuild
new file mode 100644
index 000000000000..efaebaf402db
--- /dev/null
+++ b/net-misc/kphone/kphone-4.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/kphone/kphone-4.1.0.ebuild,v 1.1 2004/12/12 13:45:32 motaboy Exp $
+
+inherit eutils kde
+
+DESCRIPTION="A SIP user agent for Linux, with which you can initiate VoIP connections over the Internet."
+HOMEPAGE="http://www.wirlab.net/kphone/index.html"
+SRC_URI="http://www.wirlab.net/kphone/${P}.tar.gz"
+
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc"
+LICENSE="GPL-2"
+
+IUSE="alsa jack"
+SLOT="0"
+
+S=${WORKDIR}/kphone
+
+DEPEND="alsa? ( media-libs/alsa-lib virtual/alsa )
+ jack? ( media-sound/jack-audio-connection-kit )"
+
+need-kde 3
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-Makefiles.patch
+}
+
+
+src_compile(){
+ # Fix for our kde location
+ myconf="$myconf --with-extra-libs=$KDEDIR/lib --prefix=/usr `use_enable alsa` `use_enable jack`"
+ econf ${myconf} || die "econf failed"
+ emake
+}