summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-07-12 02:36:33 +0000
committerDaniel Goller <morfic@gentoo.org>2004-07-12 02:36:33 +0000
commitfb4046bd526a4442c127194b80e6a2eb55ef9c25 (patch)
tree96abcf294ab5d023ac326ab173f211a56402b642 /net-misc/ksambaplugin/ksambaplugin-0.5f.ebuild
parentFix bug 56662: make filter-flags work properly with globs (diff)
downloadgentoo-2-fb4046bd526a4442c127194b80e6a2eb55ef9c25.tar.gz
gentoo-2-fb4046bd526a4442c127194b80e6a2eb55ef9c25.tar.bz2
gentoo-2-fb4046bd526a4442c127194b80e6a2eb55ef9c25.zip
Closing bug 54391, applied patch for gcc-3.4
Diffstat (limited to 'net-misc/ksambaplugin/ksambaplugin-0.5f.ebuild')
-rw-r--r--net-misc/ksambaplugin/ksambaplugin-0.5f.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/net-misc/ksambaplugin/ksambaplugin-0.5f.ebuild b/net-misc/ksambaplugin/ksambaplugin-0.5f.ebuild
index ff28b2f833a4..d634a3ac3339 100644
--- a/net-misc/ksambaplugin/ksambaplugin-0.5f.ebuild
+++ b/net-misc/ksambaplugin/ksambaplugin-0.5f.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ksambaplugin/ksambaplugin-0.5f.ebuild,v 1.5 2004/07/03 21:21:25 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ksambaplugin/ksambaplugin-0.5f.ebuild,v 1.6 2004/07/12 02:36:33 morfic Exp $
-inherit kde
+inherit kde eutils gcc
S=${WORKDIR}/${P/f/}/${P/f/}
@@ -22,3 +22,15 @@ need-kde 3
use debug && myconf="$myconf --enable-debug --enable-profile"
myconf="$myconf --enable-sso"
+
+kde_src_unpack() {
+
+ unpack ${A}
+ cd ${WORKDIR}/ksambaplugin-0.5/ksambaplugin-0.5/src
+
+ #apply patch to compile with gcc-3.4.0 closing bug #54391
+ if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]
+ then
+ epatch ${FILESDIR}/ksambaplugin-gcc3.4-fix.patch
+ fi
+}