summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-07-06 18:48:48 +0000
committerMike Frysinger <vapier@gentoo.org>2007-07-06 18:48:48 +0000
commit120a173ad05b6664e03dc552de3035f386898d4b (patch)
tree36d1d7f47e3181786ca4cb7b7feb2af536b8340b /net-misc/neon
parentFix for recent linux-headers and exec stack (diff)
downloadgentoo-2-120a173ad05b6664e03dc552de3035f386898d4b.tar.gz
gentoo-2-120a173ad05b6664e03dc552de3035f386898d4b.tar.bz2
gentoo-2-120a173ad05b6664e03dc552de3035f386898d4b.zip
If glibc does not have IUSE=nptl, assume it is enabled as newer versions only support nptl.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'net-misc/neon')
-rw-r--r--net-misc/neon/ChangeLog7
-rw-r--r--net-misc/neon/neon-0.26.1-r1.ebuild6
-rw-r--r--net-misc/neon/neon-0.26.1.ebuild6
-rw-r--r--net-misc/neon/neon-0.26.3.ebuild6
4 files changed, 15 insertions, 10 deletions
diff --git a/net-misc/neon/ChangeLog b/net-misc/neon/ChangeLog
index cd469b3208ba..ce367eaeb912 100644
--- a/net-misc/neon/ChangeLog
+++ b/net-misc/neon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/neon
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.88 2007/06/27 20:02:35 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.89 2007/07/06 18:48:48 vapier Exp $
+
+ 06 Jul 2007; Mike Frysinger <vapier@gentoo.org> neon-0.26.1.ebuild,
+ neon-0.26.1-r1.ebuild, neon-0.26.3.ebuild:
+ If glibc does not have IUSE=nptl, assume it is enabled as newer versions
+ only support nptl.
27 Jun 2007; Lars Weiler <pylon@gentoo.org> neon-0.26.3.ebuild:
Stable on ppc; bug #178264.
diff --git a/net-misc/neon/neon-0.26.1-r1.ebuild b/net-misc/neon/neon-0.26.1-r1.ebuild
index 654f943b8025..a088816f4e3e 100644
--- a/net-misc/neon/neon-0.26.1-r1.ebuild
+++ b/net-misc/neon/neon-0.26.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.26.1-r1.ebuild,v 1.7 2007/04/04 13:53:01 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.26.1-r1.ebuild,v 1.8 2007/07/06 18:48:48 vapier Exp $
inherit eutils libtool versionator
@@ -30,8 +30,8 @@ src_unpack() {
src_compile() {
local myconf=""
if has_version sys-libs/glibc; then
- if built_with_use sys-libs/glibc nptlonly \
- || built_with_use sys-libs/glibc nptl; then
+ if built_with_use --missing true sys-libs/glibc nptlonly \
+ || built_with_use --missing true sys-libs/glibc nptl; then
einfo "Enabling SSL library thread-safety using POSIX threads..."
myconf="${myconf} --enable-threadsafe-ssl=posix"
fi
diff --git a/net-misc/neon/neon-0.26.1.ebuild b/net-misc/neon/neon-0.26.1.ebuild
index a6da173dcbec..fa0eb9a84478 100644
--- a/net-misc/neon/neon-0.26.1.ebuild
+++ b/net-misc/neon/neon-0.26.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.26.1.ebuild,v 1.16 2007/04/04 13:53:01 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.26.1.ebuild,v 1.17 2007/07/06 18:48:48 vapier Exp $
inherit eutils libtool versionator
@@ -31,8 +31,8 @@ src_unpack() {
src_compile() {
local myconf=""
if has_version sys-libs/glibc; then
- if built_with_use sys-libs/glibc nptlonly \
- || built_with_use sys-libs/glibc nptl; then
+ if built_with_use --missing true sys-libs/glibc nptlonly \
+ || built_with_use --missing true sys-libs/glibc nptl; then
einfo "Enabling SSL library thread-safety using POSIX threads..."
myconf="${myconf} --enable-threadsafe-ssl=posix"
fi
diff --git a/net-misc/neon/neon-0.26.3.ebuild b/net-misc/neon/neon-0.26.3.ebuild
index 2d2e3a231d93..19b9ff1253c3 100644
--- a/net-misc/neon/neon-0.26.3.ebuild
+++ b/net-misc/neon/neon-0.26.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.26.3.ebuild,v 1.8 2007/06/27 20:02:35 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.26.3.ebuild,v 1.9 2007/07/06 18:48:48 vapier Exp $
inherit eutils libtool versionator autotools
@@ -30,8 +30,8 @@ src_unpack() {
src_compile() {
local myconf=""
if has_version sys-libs/glibc; then
- if built_with_use sys-libs/glibc nptlonly \
- || built_with_use sys-libs/glibc nptl; then
+ if built_with_use --missing true sys-libs/glibc nptlonly \
+ || built_with_use --missing true sys-libs/glibc nptl; then
einfo "Enabling SSL library thread-safety using POSIX threads..."
myconf="${myconf} --enable-threadsafe-ssl=posix"
fi