summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-09-15 03:24:15 +0000
committerMichael Weber <xmw@gentoo.org>2010-09-15 03:24:15 +0000
commite26b0570ebaf30db3c7d7bb86b395d860a25b2d9 (patch)
tree17ae24d2f1796294b19a7a0da56868625aff758f /net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r3.ebuild
parentStable for HPPA (bug #336381). (diff)
downloadgentoo-2-e26b0570ebaf30db3c7d7bb86b395d860a25b2d9.tar.gz
gentoo-2-e26b0570ebaf30db3c7d7bb86b395d860a25b2d9.tar.bz2
gentoo-2-e26b0570ebaf30db3c7d7bb86b395d860a25b2d9.zip
Revision bump to respect CC/LDFLAGS, add init.d/conf.d script, added ~amd64 keyword
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r3.ebuild')
-rw-r--r--net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r3.ebuild b/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r3.ebuild
new file mode 100644
index 000000000000..eed1f940e839
--- /dev/null
+++ b/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r3.ebuild,v 1.1 2010/09/15 03:24:15 xmw Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Netkit - bootparamd"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+SRC_URI="mirror://debian/pool/main/n/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="!<=net-misc/netkit-bootpd-0.17-r2"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/0.17-jumpstart.patch
+
+ # don't reset LDFLAGS (bug #335457), manpages into /usr/share/man
+ sed -i -e '/^LDFLAGS=/d ; /MANDIR=/s:man:share/man:' configure || die
+
+ sed -i -e 's:install -s:install:' rpc.bootparamd/Makefile || die
+}
+
+src_configure() {
+ # Note this is not an autoconf configure
+ CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" ./configure || die
+}
+
+src_install() {
+ dodir usr/bin usr/sbin usr/share/man/man8 || die
+ emake INSTALLROOT="${D}" install || die
+
+ newconfd "${FILESDIR}"/bootparamd.confd bootparamd || die
+ newinitd "${FILESDIR}"/bootparamd.initd bootparamd || die
+
+ doman rpc.bootparamd/bootparams.5 || die
+ dodoc README ChangeLog || die
+ newdoc rpc.bootparamd/README README.bootparamd || die
+}