summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2008-08-02 16:58:11 +0000
committerNed Ludd <solar@gentoo.org>2008-08-02 16:58:11 +0000
commite35ad2c37601ff9c3288adca0d9bcad5ad9eb3ee (patch)
tree9cc61bddbf6e2c12b285380a7856b69cd6942c39 /net-misc/netkit-telnetd
parentStable for HPPA (bug #233675). (diff)
downloadgentoo-2-e35ad2c37601ff9c3288adca0d9bcad5ad9eb3ee.tar.gz
gentoo-2-e35ad2c37601ff9c3288adca0d9bcad5ad9eb3ee.tar.bz2
gentoo-2-e35ad2c37601ff9c3288adca0d9bcad5ad9eb3ee.zip
- Keeping in sync with debian which is now at patch level 36
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-misc/netkit-telnetd')
-rw-r--r--net-misc/netkit-telnetd/ChangeLog7
-rw-r--r--net-misc/netkit-telnetd/netkit-telnetd-0.17-r9.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/net-misc/netkit-telnetd/ChangeLog b/net-misc/netkit-telnetd/ChangeLog
index 14dabc586cf2..00f21270e396 100644
--- a/net-misc/netkit-telnetd/ChangeLog
+++ b/net-misc/netkit-telnetd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/netkit-telnetd
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-telnetd/ChangeLog,v 1.44 2008/02/05 11:10:40 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-telnetd/ChangeLog,v 1.45 2008/08/02 16:58:11 solar Exp $
+
+*netkit-telnetd-0.17-r9 (02 Aug 2008)
+
+ 02 Aug 2008; <solar@gentoo.org> +netkit-telnetd-0.17-r9.ebuild:
+ - Keeping in sync with debian which is now at patch level 36
05 Feb 2008; Markus Rothe <corsair@gentoo.org>
netkit-telnetd-0.17-r8.ebuild:
diff --git a/net-misc/netkit-telnetd/netkit-telnetd-0.17-r9.ebuild b/net-misc/netkit-telnetd/netkit-telnetd-0.17-r9.ebuild
new file mode 100644
index 000000000000..87ee339f7ee3
--- /dev/null
+++ b/net-misc/netkit-telnetd/netkit-telnetd-0.17-r9.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-telnetd/netkit-telnetd-0.17-r9.ebuild,v 1.1 2008/08/02 16:58:11 solar Exp $
+
+inherit eutils toolchain-funcs
+
+PATCHLEVEL=36
+DESCRIPTION="Standard Linux telnet client and server"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+# http://packages.debian.org/stablesource/netkit-telnet
+# http://packages.debian.org/testing/source/netkit-telnet
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-telnet-${PV}.tar.gz
+ mirror://debian/pool/main/n/netkit-telnet/netkit-telnet_0.17-${PATCHLEVEL}.diff.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2
+ !net-misc/telnet-bsd"
+
+S=${WORKDIR}/netkit-telnet-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Patch: [0]
+ # Gentoo lacks a maintainer for this package right now. And a
+ # security problem arose. While reviewing our options for how
+ # should we proceed with the security bug we decided it would be
+ # better to just stay in sync with debian's own netkit-telnet
+ # package. Lots of bug fixes by them over time which were not in
+ # our telnetd.
+ epatch "${WORKDIR}"/netkit-telnet_0.17-${PATCHLEVEL}.diff
+
+ # Patch: [1]
+ # after the deb patch we need to add a small patch that defines
+ # gnu source. This is needed for gcc-3.4.x (needs to be pushed
+ # back to the deb folk?)
+ epatch "${FILESDIR}"/netkit-telnetd-0.17-cflags-gnu_source.patch
+}
+
+src_compile() {
+ ./configure --prefix=/usr || die
+
+ sed -i \
+ -e "s:-pipe -O2:${CFLAGS}:" \
+ -e "s:-Wpointer-arith::" \
+ -e "s:^CC=.*:CC=$(tc-getCC):" \
+ -e "s:^CXX=.*:CXX=$(tc-getCXX):" \
+ MCONFIG
+
+ make || die
+ cd telnetlogin
+ make || die
+}
+
+src_install() {
+ dobin telnet/telnet || die
+
+ dosbin telnetd/telnetd || die
+ dosym telnetd /usr/sbin/in.telnetd
+ dosbin telnetlogin/telnetlogin || die
+ doman telnet/telnet.1
+ doman telnetd/*.8
+ doman telnetd/issue.net.5
+ dosym telnetd.8 /usr/share/man/man8/in.telnetd.8
+ doman telnetlogin/telnetlogin.8
+ dodoc BUGS ChangeLog README
+ dodoc "${FILESDIR}"/net.issue.sample
+ newdoc telnet/README README.telnet
+ newdoc telnet/TODO TODO.telnet
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/telnetd.xinetd telnetd
+}