summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-11-23 23:51:57 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-11-23 23:51:57 +0000
commit1df7368214979de2eb5cac189a7d7e7d641aafb5 (patch)
tree43e9359e2743dfe084651fc3a27e837551371639 /net-misc/nut
parentfix bugs from #34174, partially based on submitted patch (diff)
downloadgentoo-2-1df7368214979de2eb5cac189a7d7e7d641aafb5.tar.gz
gentoo-2-1df7368214979de2eb5cac189a7d7e7d641aafb5.tar.bz2
gentoo-2-1df7368214979de2eb5cac189a7d7e7d641aafb5.zip
fix bugs from #34174, partially based on submitted patch
Diffstat (limited to 'net-misc/nut')
-rw-r--r--net-misc/nut/ChangeLog7
-rw-r--r--net-misc/nut/Manifest4
-rw-r--r--net-misc/nut/files/digest-nut-1.5.8-r11
-rw-r--r--net-misc/nut/nut-1.5.8-r1.ebuild103
4 files changed, 112 insertions, 3 deletions
diff --git a/net-misc/nut/ChangeLog b/net-misc/nut/ChangeLog
index b4df58bc78b3..cf0a58fe854c 100644
--- a/net-misc/nut/ChangeLog
+++ b/net-misc/nut/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/nut
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nut/ChangeLog,v 1.23 2003/11/21 04:49:45 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nut/ChangeLog,v 1.24 2003/11/23 23:51:54 robbat2 Exp $
+
+*nut-1.5.8-r1 (23 Nov 2003)
+
+ 23 Nov 2003; Robin H. Johnson <robbat2@gentoo.org> nut-1.5.8-r1.ebuild:
+ fix bugs from #34174, partially based on submitted patch
*nut-1.5.8 (20 Nov 2003)
diff --git a/net-misc/nut/Manifest b/net-misc/nut/Manifest
index 53c6e5cb0ae7..d844ae6ad646 100644
--- a/net-misc/nut/Manifest
+++ b/net-misc/nut/Manifest
@@ -5,10 +5,10 @@ MD5 fa6914c5f0e8bd3bdf5cb180cda1a7db nut-1.2.1.ebuild 2920
MD5 78a59e58e70f1e9bfe6aa60ca169f4ed nut-1.3.6.ebuild 3361
MD5 2609435c9197d13e9aa41608ddad8f78 nut-1.5.7.ebuild 2284
MD5 b0b485ebdd80433949e448f5687a57e4 nut-1.2.2.ebuild 3282
-MD5 7e3da5676e68b6a9dd5c0964b98c46d3 nut-1.5.8-r1.ebuild 2740
+MD5 182dbf5ba442ff5655436be8e5705bcf nut-1.5.8-r1.ebuild 2755
MD5 47bd3e43bdb0b893d2ae0801abc2296a nut-1.4.0-r3.ebuild 2283
MD5 47b88ec6b9c1a051634d18ab1f8aeb5e nut-1.2.1-r1.ebuild 3236
-MD5 9991e67c6be5f2fff3833e297b2e657a ChangeLog 3889
+MD5 d26792cdd69fe3637c5d5d2c68ffa396 ChangeLog 3889
MD5 5b93ea4cc6824bb99a84599be7f8c67e nut-1.5.1.ebuild 3365
MD5 d8794a3445cecff78d520364e47a9138 nut-1.5.6-r2.ebuild 2287
MD5 91a159b983332d5ed0fb985cc1fe1b80 metadata.xml 330
diff --git a/net-misc/nut/files/digest-nut-1.5.8-r1 b/net-misc/nut/files/digest-nut-1.5.8-r1
new file mode 100644
index 000000000000..5537ba164580
--- /dev/null
+++ b/net-misc/nut/files/digest-nut-1.5.8-r1
@@ -0,0 +1 @@
+MD5 a40d106bf20d193258842adfc3843bfb nut-1.5.8.tar.gz 488558
diff --git a/net-misc/nut/nut-1.5.8-r1.ebuild b/net-misc/nut/nut-1.5.8-r1.ebuild
new file mode 100644
index 000000000000..0979ca124622
--- /dev/null
+++ b/net-misc/nut/nut-1.5.8-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nut/nut-1.5.8-r1.ebuild,v 1.1 2003/11/23 23:51:54 robbat2 Exp $
+
+inherit fixheadtails
+
+DESCRIPTION="Network-UPS Tools."
+SRC_URI="http://www.exploits.org/nut/development/${PV%.*}/${P}.tar.gz"
+HOMEPAGE="http://www.exploits.org/nut/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE="cgi"
+
+DEPEND=">=sys-apps/sed-4
+ cgi? ( =media-libs/libgd-1* )"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+ sed -e "s/install: install-dirs/install: install-dirs install-conf/" \
+ -i Makefile.in || die "sed failed"
+
+ ht_fix_file configure.in config.guess
+
+ sed -e "s:GD_LIBS.*=.*-L/usr/X11R6/lib \(.*\) -lXpm -lX11:GD_LIBS=\"\1:" \
+ -i configure.in || die "sed failed"
+
+ ebegin "Recreating configure"
+ WANT_AUTOCONF_2_5=1 autoconf || die "autoconf failed"
+ eend $?
+}
+
+src_compile() {
+ local myconf
+ myconf="${myconf} `use_with cgi` `use_with cgi cgipath /usr/share/nut`"
+
+ econf \
+ --with-user=nut \
+ --with-group=nut \
+ --with-drvpath=/lib/nut \
+ --sysconfdir=/etc/nut \
+ --with-logfacility=LOG_DAEMON \
+ --with-statepath=/var/lib/nut \
+ --with-linux-hiddev \
+ ${myconf}
+
+ sed -e "s:= bestups:= hidups bestups:" \
+ -i drivers/Makefile || die "sed failed"
+ sed -e "s:= powercom.8:= hidups.8 powercom.8:" \
+ -i man/Makefile || "sed failed"
+
+ emake || die "compile problem"
+
+ if use cgi; then
+ emake cgi || die "compile cgi problem"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodir /sbin
+ dosym /lib/nut/upsdrvctl /sbin/upsdrvctl
+
+ for i in "${D}"/etc/nut/*.sample ; do
+ mv "${i}" "${i/.sample/}"
+ done
+
+ if use cgi; then
+ make DESTDIR="${D}" install-cgi || die "make install-cgi failed"
+ einfo "CGI monitoring scripts are installed in /usr/share/nut,"
+ einfo "copy them to your web server's ScriptPath to activate."
+ fi
+
+ dodoc CHANGES COPYING CREDITS INSTALL MAINTAINERS NEWS README UPGRADING \
+ docs/{FAQ,*.txt}
+
+ docinto cables
+ dodoc docs/cables/*
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/upsd.rc6" upsd
+ newexe "${FILESDIR}/upsdrv.rc6" upsdrv
+ newexe "${FILESDIR}/upsmon.rc6" upsmon
+
+ keepdir /var/lib/nut
+
+ fperms 0700 /var/lib/nut
+ fperms 0640 /etc/nut/{upsd.conf,upsd.users,upsmon.conf}
+ fowners nut:nut /var/lib/nut
+ fowners root:nut /etc/nut/{upsd.conf,upsd.users,upsmon.conf}
+}
+
+pkg_postinst() {
+ # this is to ensure that everybody that installed old versions still has correct
+ # permissions
+ chown nut:nut ${ROOT}/var/lib/nut 2>/dev/null
+ chmod 0700 ${ROOT}/var/lib/nut 2>/dev/null
+ chown root:nut ${ROOT}/etc/nut/{upsd.conf,upsd.users,upsmon.conf} 2>/dev/null
+ chmod 0640 ${ROOT}/etc/nut/{upsd.conf,upsd.users,upsmon.conf} 2>/dev/null
+}