summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-01-16 10:12:48 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-01-16 10:12:48 +0000
commit0a10244345031227da683a18172efc248dc71226 (patch)
treedb4bfd7aaa43e78797e17083d27d6af743296a50 /net-misc/nxnode
parentMaintenance release version bump (diff)
downloadgentoo-2-0a10244345031227da683a18172efc248dc71226.tar.gz
gentoo-2-0a10244345031227da683a18172efc248dc71226.tar.bz2
gentoo-2-0a10244345031227da683a18172efc248dc71226.zip
Maintenance release version bump
(Portage version: 2.2_rc22/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'net-misc/nxnode')
-rw-r--r--net-misc/nxnode/ChangeLog10
-rw-r--r--net-misc/nxnode/nxnode-3.3.0.11.ebuild116
2 files changed, 124 insertions, 2 deletions
diff --git a/net-misc/nxnode/ChangeLog b/net-misc/nxnode/ChangeLog
index 35c38ec45fdc..cdef2c849624 100644
--- a/net-misc/nxnode/ChangeLog
+++ b/net-misc/nxnode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/nxnode
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxnode/ChangeLog,v 1.36 2008/11/21 10:38:25 voyageur Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxnode/ChangeLog,v 1.37 2009/01/16 10:12:48 voyageur Exp $
+
+*nxnode-3.3.0.11 (16 Jan 2009)
+
+ 16 Jan 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ +nxnode-3.3.0.11.ebuild:
+ Maintenance release version bump
*nxnode-3.3.0.3 (21 Nov 2008)
diff --git a/net-misc/nxnode/nxnode-3.3.0.11.ebuild b/net-misc/nxnode/nxnode-3.3.0.11.ebuild
new file mode 100644
index 000000000000..73d4444c6444
--- /dev/null
+++ b/net-misc/nxnode/nxnode-3.3.0.11.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxnode/nxnode-3.3.0.11.ebuild,v 1.1 2009/01/16 10:12:48 voyageur Exp $
+
+inherit eutils versionator
+
+MAJOR_PV="$(get_version_component_range 1-3)"
+FULL_PV="${MAJOR_PV}-$(get_version_component_range 4)"
+DESCRIPTION="shared components between the different editions of NoMachine's NX Servers"
+HOMEPAGE="http://www.nomachine.com/"
+SRC_URI="amd64? ( http://64.34.161.181/download/${MAJOR_PV}/Linux/nxnode-${FULL_PV}.x86_64.tar.gz )
+ x86? ( http://64.34.161.181/download/${MAJOR_PV}/Linux/nxnode-${FULL_PV}.i386.tar.gz )"
+
+LICENSE="nomachine"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="rdesktop vnc"
+RESTRICT="strip"
+
+DEPEND="!net-misc/nxserver-freenx
+ !<net-misc/nxserver-freeedition-3.0.0"
+
+RDEPEND="=net-misc/nxclient-3.3*
+ x11-libs/libICE
+ x11-libs/libXmu
+ x11-libs/libSM
+ x11-libs/libXt
+ x11-libs/libXaw
+ x11-libs/libXpm
+ x11-apps/xrdb
+ rdesktop? ( net-misc/rdesktop )
+ vnc? ( || ( net-misc/vnc net-misc/tightvnc ) )"
+
+S=${WORKDIR}/NX
+
+pkg_preinst()
+{
+ enewuser nx -1 -1 /usr/NX/home/nx
+}
+
+pkg_setup() {
+ if use vnc; then
+ if has_version net-misc/vnc && ! built_with_use net-misc/vnc server;
+ then
+ die "net-misc/vnc needs to be built with USE=\"server\" for VNC support"
+ fi
+
+ if has_version net-misc/tightvnc && ! built_with_use net-misc/tightvnc server;
+ then
+ die "net-misc/tightvnc needs to be built with USE=\"server\" for VNC support"
+ fi
+ fi
+}
+
+src_unpack()
+{
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/nxnode-3.0.0-setup.patch
+}
+
+src_install()
+{
+ # we install nxnode into /usr/NX, to make sure it doesn't clash
+ # with libraries installed for FreeNX
+
+ into /usr/NX
+ for x in nxagent nxnode nxsensor nxspool nxuexec ; do
+ dobin bin/$x
+ done
+
+ dodir /usr/NX/etc
+ cp etc/node-debian.cfg.sample "${D}"/usr/NX/etc/node-gentoo.cfg.sample || die
+ sed -e 's|COMMAND_FUSER = .*|COMMAND_FUSER = "/usr/bin/fuser"|;' -i "${D}"/usr/NX/etc/node-gentoo.cfg.sample || die
+ cp etc/node.lic.sample "${D}"/usr/NX/etc/node.lic.sample || die
+
+ dodir /usr/NX/lib
+ cp -R lib "${D}"/usr/NX || die
+
+ dodir /usr/NX/scripts
+ cp -R scripts "${D}"/usr/NX || die
+
+ dodir /usr/NX/share
+ cp -R share "${D}"/usr/NX || die
+
+ dodir /usr/NX/var
+ cp -R var "${D}"/usr/NX || die
+
+ dodir /etc/init.d
+ newinitd "${FILESDIR}"/nxnode-3.0.0-init nxsensor
+}
+
+pkg_postinst()
+{
+ # Only install license file if none is found
+ if [ ! -f /usr/NX/etc/node.lic ]; then
+ cp "${ROOT}"/usr/NX/etc/node.lic.sample "${ROOT}"/usr/NX/etc/node.lic || die
+ chmod 0400 "${ROOT}"/usr/NX/etc/node.lic
+ chown nx:0 "${ROOT}"/usr/NX/etc/node.lic
+ fi
+
+ # only run install on the first time
+ if [ -f /usr/NX/etc/node.cfg ]; then
+ einfo "Running NoMachine's update script"
+ "${ROOT}"/usr/NX/scripts/setup/nxnode --update
+ else
+ einfo "Running NoMachine's setup script"
+ "${ROOT}"/usr/NX/scripts/setup/nxnode --install
+ fi
+
+ elog "If you want server statistics, please add nxsensor to your default runlevel"
+ elog
+ elog " rc-update add nxsensor default"
+ elog
+ elog "You will also need to change EnableSensor to 1 in /usr/NX/etc/node.cfg"
+}