summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-03-21 17:42:28 +0000
committerChristoph Mende <angelos@gentoo.org>2010-03-21 17:42:28 +0000
commit58e706a19550a4b16f3bc8058425447a3526f9e5 (patch)
tree91fba3b2177c05ae56453c00cc3afe22518915fe /net-misc/oidentd/oidentd-2.0.8-r3.ebuild
parentVersion bump to 0.9.1 Bug #3104830 (diff)
downloadgentoo-2-58e706a19550a4b16f3bc8058425447a3526f9e5.tar.gz
gentoo-2-58e706a19550a4b16f3bc8058425447a3526f9e5.tar.bz2
gentoo-2-58e706a19550a4b16f3bc8058425447a3526f9e5.zip
Bind to IPv6 as well as IPv4 (bug #308843)
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'net-misc/oidentd/oidentd-2.0.8-r3.ebuild')
-rw-r--r--net-misc/oidentd/oidentd-2.0.8-r3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/oidentd/oidentd-2.0.8-r3.ebuild b/net-misc/oidentd/oidentd-2.0.8-r3.ebuild
new file mode 100644
index 000000000000..ffa3b3b0f842
--- /dev/null
+++ b/net-misc/oidentd/oidentd-2.0.8-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/oidentd/oidentd-2.0.8-r3.ebuild,v 1.1 2010/03/21 17:42:28 angelos Exp $
+
+inherit eutils
+
+DESCRIPTION="Another (RFC1413 compliant) ident daemon"
+HOMEPAGE="http://dev.ojnk.net"
+SRC_URI="mirror://sourceforge/ojnk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ipv6 masquerade"
+
+RDEPEND=""
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-masquerading.patch" \
+ "${FILESDIR}/${P}-bind-to-ipv6-too.patch"
+}
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable masquerade masq) \
+ $(use_enable masquerade nat) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed!"
+
+ dodoc AUTHORS ChangeLog README TODO NEWS \
+ "${FILESDIR}"/${PN}_masq.conf "${FILESDIR}"/${PN}.conf
+
+ newinitd "${FILESDIR}"/${PN}-2.0.7-init ${PN}
+ newconfd "${FILESDIR}"/${PN}-2.0.7-confd ${PN}
+}
+
+pkg_postinst() {
+ echo
+ elog "Example configuration files are in /usr/share/doc/${PF}"
+ echo
+}