summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-01-15 17:39:16 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-01-15 17:39:16 +0000
commit583c4368a9b754185b81b7f8993c7bd66e92ec7b (patch)
treee39c25d18bd25cd5477ec1a8451e1ef915d03c55 /net-misc/radvd
parentOld. (diff)
downloadgentoo-2-583c4368a9b754185b81b7f8993c7bd66e92ec7b.tar.gz
gentoo-2-583c4368a9b754185b81b7f8993c7bd66e92ec7b.tar.bz2
gentoo-2-583c4368a9b754185b81b7f8993c7bd66e92ec7b.zip
version bump for radvd
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'net-misc/radvd')
-rw-r--r--net-misc/radvd/ChangeLog9
-rw-r--r--net-misc/radvd/radvd-1.9.8.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/net-misc/radvd/ChangeLog b/net-misc/radvd/ChangeLog
index 05400def32e4..82ee6bb95145 100644
--- a/net-misc/radvd/ChangeLog
+++ b/net-misc/radvd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/radvd
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/ChangeLog,v 1.113 2013/11/21 18:05:46 prometheanfire Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/ChangeLog,v 1.114 2014/01/15 17:39:16 prometheanfire Exp $
+
+*radvd-1.9.8 (15 Jan 2014)
+
+ 15 Jan 2014; Matthew Thode <prometheanfire@gentoo.org> +radvd-1.9.8.ebuild:
+ version bump for radvd
*radvd-1.9.7 (21 Nov 2013)
diff --git a/net-misc/radvd/radvd-1.9.8.ebuild b/net-misc/radvd/radvd-1.9.8.ebuild
new file mode 100644
index 000000000000..b6563cd28979
--- /dev/null
+++ b/net-misc/radvd/radvd-1.9.8.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/radvd-1.9.8.ebuild,v 1.1 2014/01/15 17:39:16 prometheanfire Exp $
+
+EAPI=4
+
+inherit systemd user eutils
+
+DESCRIPTION="Linux IPv6 Router Advertisement Daemon"
+HOMEPAGE="http://v6web.litech.org/radvd/"
+SRC_URI="http://v6web.litech.org/radvd/dist/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="kernel_FreeBSD selinux"
+
+RDEPEND="dev-libs/libdaemon
+ selinux? ( sec-policy/selinux-radvd )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig"
+
+DOCS=( CHANGES README TODO radvd.conf.example )
+
+pkg_setup() {
+ enewgroup radvd
+ enewuser radvd -1 -1 /dev/null radvd
+
+ # force ownership of radvd user and group (bug #19647)
+ [[ -d ${ROOT}/var/run/radvd ]] && chown radvd:radvd "${ROOT}"/var/run/radvd
+}
+
+src_configure() {
+ econf --with-pidfile=/var/run/radvd/radvd.pid
+}
+
+src_install() {
+ default
+
+ dohtml INTRO.html
+
+ newinitd "${FILESDIR}"/${PN}-1.9.1.init ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf ${PN}
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ if use kernel_FreeBSD ; then
+ sed -i -e \
+ 's/^SYSCTL_FORWARD=.*$/SYSCTL_FORWARD=net.inet6.ip6.forwarding/g' \
+ "${D}"/etc/init.d/${PN} || die
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ elog "Please create a configuratoion ${ROOT}etc/radvd.conf."
+ elog "See ${ROOT}usr/share/doc/${PF} for an example."
+ einfo
+ elog "grsecurity users should allow a specific group to read /proc"
+ elog "and add the radvd user to that group, otherwise radvd may"
+ elog "segfault on startup."
+}