summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-12-04 16:12:38 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-12-04 16:12:38 +0000
commit043f98fcf48981a2a8456a81e7fd100837cb2e32 (patch)
treea531c5d09b2bd9b647e3fb414a450b012acd3a86 /net-misc/stone
parentAllow planner to select specific libgda and fix build with newer glib/gcc, bu... (diff)
downloadgentoo-2-043f98fcf48981a2a8456a81e7fd100837cb2e32.tar.gz
gentoo-2-043f98fcf48981a2a8456a81e7fd100837cb2e32.tar.bz2
gentoo-2-043f98fcf48981a2a8456a81e7fd100837cb2e32.zip
Version bumped. Fixed glibc-2.8 issue, bug #241006.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'net-misc/stone')
-rw-r--r--net-misc/stone/ChangeLog8
-rw-r--r--net-misc/stone/stone-2.2d.ebuild34
-rw-r--r--net-misc/stone/stone-2.3e.ebuild (renamed from net-misc/stone/stone-2.3c.ebuild)25
3 files changed, 21 insertions, 46 deletions
diff --git a/net-misc/stone/ChangeLog b/net-misc/stone/ChangeLog
index bbce3ae27eb3..d5edac2cbd30 100644
--- a/net-misc/stone/ChangeLog
+++ b/net-misc/stone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/stone
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stone/ChangeLog,v 1.14 2008/01/27 16:02:33 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stone/ChangeLog,v 1.15 2008/12/04 16:12:38 matsuu Exp $
+
+*stone-2.3e (04 Dec 2008)
+
+ 04 Dec 2008; MATSUU Takuto <matsuu@gentoo.org> -stone-2.2d.ebuild,
+ -stone-2.3c.ebuild, +stone-2.3e.ebuild:
+ Version bumped. Fixed glibc-2.8 issue, bug #241006. Removed old versions.
*stone-2.3c (27 Jan 2008)
diff --git a/net-misc/stone/stone-2.2d.ebuild b/net-misc/stone/stone-2.2d.ebuild
deleted file mode 100644
index 6a8ed87809f7..000000000000
--- a/net-misc/stone/stone-2.2d.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stone/stone-2.2d.ebuild,v 1.1 2005/01/01 02:19:05 matsuu Exp $
-
-DESCRIPTION="A simple TCP/IP packet repeater"
-HOMEPAGE="http://www.gcd.org/sengoku/stone/"
-SRC_URI="http://www.gcd.org/sengoku/stone/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
-IUSE="ssl"
-
-DEPEND="virtual/libc
- ssl? ( dev-libs/openssl )"
-
-src_compile() {
- if use ssl ; then
- emake \
- CFLAGS="${CFLAGS}" \
- SSL=/usr \
- linux-ssl || die
- else
- emake \
- CFLAGS="${CFLAGS}" \
- linux || die
- fi
-}
-
-src_install() {
- dobin stone
- doman stone.1
- dodoc README*
-}
diff --git a/net-misc/stone/stone-2.3c.ebuild b/net-misc/stone/stone-2.3e.ebuild
index fdc40e245011..6e6cbc7df03c 100644
--- a/net-misc/stone/stone-2.3c.ebuild
+++ b/net-misc/stone/stone-2.3e.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stone/stone-2.3c.ebuild,v 1.1 2008/01/27 16:02:33 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stone/stone-2.3e.ebuild,v 1.1 2008/12/04 16:12:38 matsuu Exp $
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="A simple TCP/IP packet repeater"
HOMEPAGE="http://www.gcd.org/sengoku/stone/"
@@ -15,22 +15,25 @@ IUSE="ssl"
DEPEND="ssl? ( dev-libs/openssl )"
+S="${WORKDIR}/${PN}-2.3d-2.3.2.7"
+
src_compile() {
+ local myargs
+
if use ssl ; then
- emake \
- CC=$(tc-getCC) \
- CFLAGS="${CFLAGS}" \
- SSL=/usr \
- linux-ssl || die
+ myargs="${myconf} SSL=/usr linux-ssl"
else
- emake \
- CFLAGS="${CFLAGS}" \
- linux || die
+ myargs="${myconf} linux"
fi
+
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -D_GNU_SOURCE" \
+ ${myargs} || die
}
src_install() {
dobin stone
- doman stone.1
+ # doman stone.1
dodoc README*
}