summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-03-06 16:42:13 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-03-06 16:42:13 +0000
commit20162a5af4c6ae01934746f2f33da7a749c9a4c2 (patch)
tree8e2eca2707ddce2f16b8d45792851ab8a249a697 /net-misc/stunnel
parentamd64/arm/x86 stable (diff)
downloadgentoo-2-20162a5af4c6ae01934746f2f33da7a749c9a4c2.tar.gz
gentoo-2-20162a5af4c6ae01934746f2f33da7a749c9a4c2.tar.bz2
gentoo-2-20162a5af4c6ae01934746f2f33da7a749c9a4c2.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc/stunnel')
-rw-r--r--net-misc/stunnel/ChangeLog8
-rw-r--r--net-misc/stunnel/stunnel-4.44.ebuild4
-rw-r--r--net-misc/stunnel/stunnel-4.54.ebuild6
-rw-r--r--net-misc/stunnel/stunnel-5.00.ebuild77
4 files changed, 89 insertions, 6 deletions
diff --git a/net-misc/stunnel/ChangeLog b/net-misc/stunnel/ChangeLog
index 8589256d8586..c5ab0bb8f6ae 100644
--- a/net-misc/stunnel/ChangeLog
+++ b/net-misc/stunnel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/stunnel
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/ChangeLog,v 1.156 2014/02/20 20:36:16 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/ChangeLog,v 1.157 2014/03/06 16:42:13 blueness Exp $
+
+*stunnel-5.00 (06 Mar 2014)
+
+ 06 Mar 2014; Anthony G. Basile <blueness@gentoo.org> +stunnel-5.00.ebuild,
+ stunnel-4.44.ebuild, stunnel-4.54.ebuild:
+ Version bump
20 Feb 2014; Agostino Sarubbo <ago@gentoo.org> stunnel-4.56-r2.ebuild:
Stable for x86, wrt bug #499310
diff --git a/net-misc/stunnel/stunnel-4.44.ebuild b/net-misc/stunnel/stunnel-4.44.ebuild
index 7bdfe2c50cf3..e5b83eec69d8 100644
--- a/net-misc/stunnel/stunnel-4.44.ebuild
+++ b/net-misc/stunnel/stunnel-4.44.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-4.44.ebuild,v 1.9 2014/01/08 06:37:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-4.44.ebuild,v 1.10 2014/03/06 16:42:13 blueness Exp $
-EAPI="2"
+EAPI="5"
inherit autotools ssl-cert eutils user
diff --git a/net-misc/stunnel/stunnel-4.54.ebuild b/net-misc/stunnel/stunnel-4.54.ebuild
index ae836dfa1382..55aa1edae35b 100644
--- a/net-misc/stunnel/stunnel-4.54.ebuild
+++ b/net-misc/stunnel/stunnel-4.54.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-4.54.ebuild,v 1.2 2013/02/25 21:36:59 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-4.54.ebuild,v 1.3 2014/03/06 16:42:13 blueness Exp $
-EAPI="4"
+EAPI="5"
inherit autotools ssl-cert eutils user
diff --git a/net-misc/stunnel/stunnel-5.00.ebuild b/net-misc/stunnel/stunnel-5.00.ebuild
new file mode 100644
index 000000000000..5a8f93a46148
--- /dev/null
+++ b/net-misc/stunnel/stunnel-5.00.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-5.00.ebuild,v 1.1 2014/03/06 16:42:13 blueness Exp $
+
+EAPI="5"
+
+inherit ssl-cert eutils systemd user
+
+DESCRIPTION="TLS/SSL - Port Wrapper"
+HOMEPAGE="http://www.stunnel.org/index.html"
+SRC_URI="http://www.stunnel.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ipv6 selinux tcpd xforward listen-queue"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ >=dev-libs/openssl-0.9.8k"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-stunnel )"
+
+pkg_setup() {
+ enewgroup stunnel
+ enewuser stunnel -1 -1 -1 stunnel
+}
+
+src_prepare() {
+ use xforward && epatch "${FILESDIR}/${PN}-4.56-xforwarded-for.patch"
+ use listen-queue && epatch "${FILESDIR}/${PN}-4.56-listen-queue.patch"
+
+ # Hack away generation of certificate
+ sed -i -e "s/^install-data-local:/do-not-run-this:/" \
+ tools/Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable tcpd libwrap) \
+ --with-ssl="${EPREFIX}"/usr \
+ --disable-fips
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -rf "${ED}"/usr/share/doc/${PN}
+ rm -f "${ED}"/etc/stunnel/stunnel.conf-sample "${ED}"/usr/bin/stunnel3 \
+ "${ED}"/usr/share/man/man8/stunnel.{fr,pl}.8
+
+ # The binary was moved to /usr/bin with 4.21,
+ # symlink for backwards compatibility
+ dosym ../bin/stunnel /usr/sbin/stunnel
+
+ dodoc AUTHORS BUGS CREDITS PORTS README TODO ChangeLog
+ dohtml doc/stunnel.html doc/en/VNC_StunnelHOWTO.html tools/ca.html \
+ tools/importCA.html
+
+ insinto /etc/stunnel
+ doins "${FILESDIR}"/stunnel.conf
+ newinitd "${FILESDIR}"/stunnel.initd-start-stop-daemon stunnel
+
+ systemd_dounit "${S}/tools/stunnel.service"
+ systemd_newtmpfilesd "${FILESDIR}"/stunnel.tmpfiles.conf stunnel.conf
+}
+
+pkg_postinst() {
+ if [ ! -f "${EROOT}"/etc/stunnel/stunnel.key ]; then
+ install_cert /etc/stunnel/stunnel
+ chown stunnel:stunnel "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+ chmod 0640 "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+ fi
+
+ einfo "If you want to run multiple instances of stunnel, create a new config"
+ einfo "file ending with .conf in /etc/stunnel/. **Make sure** you change "
+ einfo "\'pid= \' with a unique filename."
+}