summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-11-03 21:44:47 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-11-03 21:44:47 +0000
commitd721c88337e1ba62b4fc01f11067b993ebd28c4c (patch)
tree900b213c055b5beb0614ecadba70f493b240665b /net-misc/tor
parentVersion bump #389429 by poncho. (diff)
downloadgentoo-2-d721c88337e1ba62b4fc01f11067b993ebd28c4c.tar.gz
gentoo-2-d721c88337e1ba62b4fc01f11067b993ebd28c4c.tar.bz2
gentoo-2-d721c88337e1ba62b4fc01f11067b993ebd28c4c.zip
Patch to fix crash of directory servers if geoip data is not present
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/tor')
-rw-r--r--net-misc/tor/ChangeLog8
-rw-r--r--net-misc/tor/files/tor-0.2.2.34_disable-stats-requiring-geoip.patch33
-rw-r--r--net-misc/tor/tor-0.2.2.34-r1.ebuild80
3 files changed, 120 insertions, 1 deletions
diff --git a/net-misc/tor/ChangeLog b/net-misc/tor/ChangeLog
index 6df2afc37387..fcdccd3b0033 100644
--- a/net-misc/tor/ChangeLog
+++ b/net-misc/tor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/tor
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.289 2011/11/02 14:50:01 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.290 2011/11/03 21:44:47 blueness Exp $
+
+*tor-0.2.2.34-r1 (03 Nov 2011)
+
+ 03 Nov 2011; Anthony G. Basile <blueness@gentoo.org> +tor-0.2.2.34-r1.ebuild,
+ +files/tor-0.2.2.34_disable-stats-requiring-geoip.patch:
+ Patch to fix crash of directory servers if geoip data is not present
02 Nov 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> tor-0.2.2.34.ebuild:
x86 stable wrt bug #388769
diff --git a/net-misc/tor/files/tor-0.2.2.34_disable-stats-requiring-geoip.patch b/net-misc/tor/files/tor-0.2.2.34_disable-stats-requiring-geoip.patch
new file mode 100644
index 000000000000..cef31be37598
--- /dev/null
+++ b/net-misc/tor/files/tor-0.2.2.34_disable-stats-requiring-geoip.patch
@@ -0,0 +1,33 @@
+cbec20b5dedd91005dcf64c730c411 Mon Sep 17 00:00:00 2001
+From: Sebastian Hahn <sebastian@torproject.org>
+Date: Wed, 22 Dec 2010 08:34:41 +0100
+Subject: [PATCH] Disable stats requiring geoip info if we have none
+
+In other parts of the code we will otherwise attempt to collect these
+statistics, and that will lead to crashes.
+---
+ src/or/config.c | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/src/or/config.c b/src/or/config.c
+index 78e4336..ca4e71c 100644
+--- a/src/or/config.c
++++ b/src/or/config.c
+@@ -1425,6 +1425,7 @@ options_act(or_options_t *old_options)
+ geoip_dirreq_stats_init(now);
+ print_notice = 1;
+ } else {
++ options->DirReqStatistics = 0;
+ log_notice(LD_CONFIG, "Configured to measure directory request "
+ "statistics, but no GeoIP database found! "
+ "Please specify a GeoIP database using the "
+@@ -1437,6 +1438,7 @@ options_act(or_options_t *old_options)
+ geoip_entry_stats_init(now);
+ print_notice = 1;
+ } else {
++ options->EntryStatistics = 0;
+ log_notice(LD_CONFIG, "Configured to measure entry node "
+ "statistics, but no GeoIP database found! "
+ "Please specify a GeoIP database using the "
+--
+1.7.2.5
diff --git a/net-misc/tor/tor-0.2.2.34-r1.ebuild b/net-misc/tor/tor-0.2.2.34-r1.ebuild
new file mode 100644
index 000000000000..f1f93a20bede
--- /dev/null
+++ b/net-misc/tor/tor-0.2.2.34-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.2.34-r1.ebuild,v 1.1 2011/11/03 21:44:47 blueness Exp $
+
+EAPI=4
+
+inherit autotools eutils flag-o-matic versionator
+
+MY_PV="$(replace_version_separator 4 -)"
+MY_PF="${PN}-${MY_PV}"
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+SRC_URI="http://www.torproject.org/dist/${MY_PF}.tar.gz"
+S="${WORKDIR}/${MY_PF}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc tor-hardening +transparent-proxy threads"
+
+DEPEND="dev-libs/openssl
+ >=dev-libs/libevent-2.0"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/torrc.sample.patch
+ epatch "${FILESDIR}"/${PN}-0.2.2.34_disable-stats-requiring-geoip.patch
+
+ einfo "Regenerating autotools files ..."
+ epatch "${FILESDIR}"/${PN}-0.2.2.24_alpha-respect-CFLAGS.patch
+ eautoreconf
+}
+
+src_configure() {
+ # Upstream isn't sure of all the user provided CFLAGS that
+ # will break tor, but does recommend against -fstrict-aliasing.
+ # We'll filter-flags them here as we encounter them.
+ filter-flags -fstrict-aliasing
+ econf --docdir=/usr/share/doc/${PF} \
+ $(use_enable doc asciidoc) \
+ $(use_enable tor-hardening gcc-hardening) \
+ $(use_enable tor-hardening linker-hardening)\
+ $(use_enable transparent-proxy transparent) \
+ $(use_enable threads)
+}
+
+src_install() {
+ newconfd "${FILESDIR}"/tor.confd tor
+ newinitd "${FILESDIR}"/tor.initd-r6 tor
+ emake DESTDIR="${D}" install
+ keepdir /var/lib/tor
+
+ dodoc README ChangeLog ReleaseNotes \
+ doc/{HACKING,TODO} \
+ doc/spec/README
+
+ fperms 750 /var/lib/tor
+ fowners tor:tor /var/lib/tor
+
+ insinto /etc/tor/
+ newins "${FILESDIR}"/torrc-r1 torrc
+}
+
+pkg_postinst() {
+ elog
+ elog "We created a configuration file for tor, /etc/tor/torrc, but you can"
+ elog "change it according to your needs. Use the torrc.sample that is in"
+ elog "that directory as a guide. Also, to have privoxy work with tor"
+ elog "just add the following line"
+ elog
+ elog "forward-socks4a / localhost:9050 ."
+ elog
+ elog "to /etc/privoxy/config. Notice the . at the end!"
+ elog
+}