summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-10-01 06:41:23 +0000
committerNed Ludd <solar@gentoo.org>2003-10-01 06:41:23 +0000
commitf21872effb3282daaa7949bfd838f0d398222450 (patch)
treeaabbc795adbc97207380597135feb0b5abce2015 /net-misc/vconfig
parentversion bump that adds Updated MAC-VLAN code. Bugs in the code are to be repo... (diff)
downloadgentoo-2-f21872effb3282daaa7949bfd838f0d398222450.tar.gz
gentoo-2-f21872effb3282daaa7949bfd838f0d398222450.tar.bz2
gentoo-2-f21872effb3282daaa7949bfd838f0d398222450.zip
version bump that adds Updated MAC-VLAN code. Bugs in the code are to be reported to the VLAN mailing list per request
Diffstat (limited to 'net-misc/vconfig')
-rw-r--r--net-misc/vconfig/ChangeLog8
-rw-r--r--net-misc/vconfig/Manifest4
-rw-r--r--net-misc/vconfig/files/digest-vconfig-1.81
-rw-r--r--net-misc/vconfig/vconfig-1.8.ebuild46
4 files changed, 56 insertions, 3 deletions
diff --git a/net-misc/vconfig/ChangeLog b/net-misc/vconfig/ChangeLog
index e76e07720c73..9e398aee0269 100644
--- a/net-misc/vconfig/ChangeLog
+++ b/net-misc/vconfig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/vconfig
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vconfig/ChangeLog,v 1.5 2003/09/25 03:02:10 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vconfig/ChangeLog,v 1.6 2003/10/01 06:41:20 solar Exp $
+
+*vconfig-1.8 (01 Oct 2003)
+
+ 01 Oct 2003; <solar@gentoo.org> vconfig-1.8.ebuild:
+ version bump that adds Updated MAC-VLAN code. Bugs in the code are to be
+ reported to the VLAN mailing list per request.
*vconfig-1.7-r2 (24 Sep 2003)
diff --git a/net-misc/vconfig/Manifest b/net-misc/vconfig/Manifest
index fa5d5e96cccd..8eeff5e908d4 100644
--- a/net-misc/vconfig/Manifest
+++ b/net-misc/vconfig/Manifest
@@ -1,9 +1,9 @@
-MD5 b96f62516d3e7af138bfb5dbc3371792 ChangeLog 1124
+MD5 a8e823b71f8f00eb2828a9f35a7c59f2 ChangeLog 1329
MD5 da7c34aae19ef948be141f51591982e0 metadata.xml 497
MD5 569d6383892db7746693491fc483973e vconfig-1.7-r1.ebuild 1320
MD5 5dc5b3ae0c63ea17cc9c68bc351d051c vconfig-1.7.ebuild 965
MD5 1b06a7bcce2c514d29a6eee035568575 vconfig-1.7-r2.ebuild 1426
-MD5 7603671f7fa43084edde0add9c8a2cab vconfig-1.8.ebuild 1476
+MD5 3742df789f45731d55b0c5ece8165520 vconfig-1.8.ebuild 1471
MD5 f2bc7516c2dfe6d1722ef5cc7c546488 files/digest-vconfig-1.7 59
MD5 f2bc7516c2dfe6d1722ef5cc7c546488 files/digest-vconfig-1.7-r1 59
MD5 cab63a6609b92c352b8b8e657587b778 files/digest-vconfig-1.7-r2 135
diff --git a/net-misc/vconfig/files/digest-vconfig-1.8 b/net-misc/vconfig/files/digest-vconfig-1.8
new file mode 100644
index 000000000000..7ed80dc30813
--- /dev/null
+++ b/net-misc/vconfig/files/digest-vconfig-1.8
@@ -0,0 +1 @@
+MD5 1edd81324b4ffc0702c9ff289a342d91 vlan.1.8.tar.gz 161551
diff --git a/net-misc/vconfig/vconfig-1.8.ebuild b/net-misc/vconfig/vconfig-1.8.ebuild
new file mode 100644
index 000000000000..d80f0e18c0a9
--- /dev/null
+++ b/net-misc/vconfig/vconfig-1.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vconfig/vconfig-1.8.ebuild,v 1.1 2003/10/01 06:41:20 solar Exp $
+
+MY_PN="vlan"
+S=${WORKDIR}/${MY_PN}
+
+DESCRIPTION="802.1Q vlan control utility"
+HOMEPAGE="http://www.candelatech.com/~greear/vlan.html"
+SRC_URI="http://www.candelatech.com/~greear/vlan/${MY_PN}.${PV}.tar.gz"
+# mirror://gentoo/vconfig-1.7-gcc33-multiline.patch"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~arm"
+IUSE="static"
+DEPEND=">=sys-kernel/linux-headers-2.4.14"
+RDEPEND=">=virtual/kernel-2.4.14"
+
+src_unpack() {
+ unpack ${MY_PN}.${PV}.tar.gz
+ # patch should be merged in current version
+ # epatch ${DISTDIR}/vconfig-1.7-gcc33-multiline.patch
+}
+
+src_compile() {
+ use static && LDFLAGS="${LDFLAGS} -static"
+ emake CC="${CC}" CCFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ into /
+ dosbin vconfig || die "dosbin error"
+
+ sed -e "s:/usr/local/bin/vconfig:/sbin/vconfig:g" -i vlan_test.pl
+ sed -e "s:/usr/local/bin/vconfig:/sbin/vconfig:g" -i vlan_test2.pl
+
+ doman vconfig.8 || die "doman error"
+ dohtml howto.html vlan.html || die "dohtml error"
+ dodoc CHANGELOG README vlan_test*.pl || die "dodoc error"
+}
+
+pkg_postinst() {
+ einfo "802.1Q VLAN support is now in the linux kernel as of 2.4.14."
+ ewarn "MTU problems exist for many ethernet drivers."
+ ewarn "Reduce the MTU on the interface to 1496 to work around them."
+}