summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-06-26 09:10:46 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-06-26 09:10:46 +0000
commit69fe3917a23ba61353e6a937046585aae6054c60 (patch)
treef0ee40bf56e409f18344af1f18df3db8c4432dc4 /net-misc/vde
parentAdd patch to fix vbi decoding with kernels 2.6.16 and greater. Thanks to Sir ... (diff)
downloadgentoo-2-69fe3917a23ba61353e6a937046585aae6054c60.tar.gz
gentoo-2-69fe3917a23ba61353e6a937046585aae6054c60.tar.bz2
gentoo-2-69fe3917a23ba61353e6a937046585aae6054c60.zip
Take over maintainer and version bump thanks to Lorenzo Grandi <popposoft@gmail.com> in bug 113554 also allows to set a group in the init script, thanks to Jean-François Richard <jean-francois@richard.name> in bug 113482 and works with qemu 0.8, thanks to Tim Redman <tredman1@tampabay.rr.com> and Nico Baggus <mlspamcb@noci.xs4all.nl> in bug 116840, big thanks to Rob M. (Adamant) <thehandoftyr@gmail.com> to notify me of this one in IRC #gentoo-dev-help.
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'net-misc/vde')
-rw-r--r--net-misc/vde/ChangeLog14
-rw-r--r--net-misc/vde/files/digest-vde-2.0.23
-rw-r--r--net-misc/vde/files/vde.conf7
-rw-r--r--net-misc/vde/files/vde.init26
-rw-r--r--net-misc/vde/metadata.xml2
-rw-r--r--net-misc/vde/vde-2.0.2.ebuild30
6 files changed, 80 insertions, 2 deletions
diff --git a/net-misc/vde/ChangeLog b/net-misc/vde/ChangeLog
index 62740d4ed08a..c03613bb6845 100644
--- a/net-misc/vde/ChangeLog
+++ b/net-misc/vde/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for net-misc/vde
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vde/ChangeLog,v 1.4 2006/04/04 02:03:11 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vde/ChangeLog,v 1.5 2006/06/26 09:10:46 genstef Exp $
+
+*vde-2.0.2 (26 Jun 2006)
+
+ 26 Jun 2006; Stefan Schweizer <genstef@gentoo.org> +files/vde.conf,
+ +files/vde.init, metadata.xml, +vde-2.0.2.ebuild:
+ Take over maintainer and version bump thanks to Lorenzo Grandi
+ <popposoft@gmail.com> in bug 113554 also allows to set a group in the init
+ script, thanks to Jean-François Richard <jean-francois@richard.name> in bug
+ 113482 and works with qemu 0.8, thanks to Tim Redman
+ <tredman1@tampabay.rr.com> and Nico Baggus <mlspamcb@noci.xs4all.nl> in bug
+ 116840, big thanks to Rob M. (Adamant) <thehandoftyr@gmail.com> to notify me
+ of this one in IRC #gentoo-dev-help.
04 Apr 2006; <rphillips@gentoo.org> +files/vde-1.5.8-makefile.patch:
Committed halycon's patches from bug #125135
diff --git a/net-misc/vde/files/digest-vde-2.0.2 b/net-misc/vde/files/digest-vde-2.0.2
new file mode 100644
index 000000000000..8e11ac9563ab
--- /dev/null
+++ b/net-misc/vde/files/digest-vde-2.0.2
@@ -0,0 +1,3 @@
+MD5 d97a8dbc72942c57542f50322b538a48 vde-2.0.2.tar.bz2 382162
+RMD160 c15ef9f3743538c2dd1bd0ba99c8078741302100 vde-2.0.2.tar.bz2 382162
+SHA256 05b473815f9706387a3c5eaeb4da2e492f624e0b7783432179454f9d69bb973c vde-2.0.2.tar.bz2 382162
diff --git a/net-misc/vde/files/vde.conf b/net-misc/vde/files/vde.conf
new file mode 100644
index 000000000000..5dd3cde90b0b
--- /dev/null
+++ b/net-misc/vde/files/vde.conf
@@ -0,0 +1,7 @@
+# load the tun module
+VDE_MODPROBE_TUN="yes"
+# virtual tap networking device to be used for vde
+VDE_TAP="tap0"
+# mode and group for the socket
+VDE_SOCK_CHMOD="770"
+VDE_SOCK_CHOWN=":qemu"
diff --git a/net-misc/vde/files/vde.init b/net-misc/vde/files/vde.init
new file mode 100644
index 000000000000..0f55d5805c29
--- /dev/null
+++ b/net-misc/vde/files/vde.init
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vde/files/vde.init,v 1.1 2006/06/26 09:10:46 genstef Exp $
+
+depend() {
+ before net.${VDE_TAP}
+}
+
+
+start() {
+ ebegin "Starting vde"
+ [ "${VDE_MODPROBE_TUN}" == "yes" ] && modprobe tun
+ start-stop-daemon --start --quiet \
+ --exec /usr/bin/vde_switch -- -tap ${VDE_TAP} -daemon
+ chmod -R ${VDE_SOCK_CHMOD} /var/run/vde.ctl
+ chown -R ${VDE_SOCK_CHOWN} /var/run/vde.ctl
+ eend $? "Failed to start vde"
+}
+
+stop() {
+ ebegin "Stopping vde"
+ start-stop-daemon --stop --quiet --exec /usr/bin/vde_switch
+ [ "${VDE_MODPROBE_TUN}" == "yes" ] && modprobe -r tun
+ eend $? "Failed to stop vde"
+}
diff --git a/net-misc/vde/metadata.xml b/net-misc/vde/metadata.xml
index a52f23beba33..c26e4a9d9165 100644
--- a/net-misc/vde/metadata.xml
+++ b/net-misc/vde/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>rphillips@gentoo.org</email>
+ <email>genstef@gentoo.org</email>
</maintainer>
<maintainer>
<email>mlspamcb@noci.xs4all.nl</email>
diff --git a/net-misc/vde/vde-2.0.2.ebuild b/net-misc/vde/vde-2.0.2.ebuild
new file mode 100644
index 000000000000..4e1f007364de
--- /dev/null
+++ b/net-misc/vde/vde-2.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vde/vde-2.0.2.ebuild,v 1.1 2006/06/26 09:10:46 genstef Exp $
+
+DESCRIPTION="vde2 is a virtual distributed ethernet emulator for emulators like qemu, bochs, and uml."
+SRC_URI="mirror://sourceforge/vde/${P}.tar.bz2"
+HOMEPAGE="http://vde.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}"/vde.init vde
+ newconfd "${FILESDIR}"/vde.conf vde
+
+ dodoc INSTALL README
+}
+
+pkg_postinst() {
+ # default group already used in kqemu
+ enewgroup qemu
+ einfo "To start vde automatically add it to the default runlevel:"
+ einfo "# rc-update add vde default"
+ einfo "You need to setup tap0 in /etc/conf.d/net"
+ einfo "To use it as an user be sure to set a group in /etc/conf.d/vde"
+ einfo "Users of the group can then run: $ vdeq qemu -sock /var/run/vde.ctl ..other opts"
+}