summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-04-01 13:14:17 +0000
committerJustin Lecher <jlec@gentoo.org>2013-04-01 13:14:17 +0000
commit65f5ec2bc7d8c2a9525f08212e707513770dd5ee (patch)
tree57ed89b6e17538af9dd243fbd4f1547f93036be2 /net-misc/vpncwatch
parentVersion bump. (diff)
downloadgentoo-2-65f5ec2bc7d8c2a9525f08212e707513770dd5ee.tar.gz
gentoo-2-65f5ec2bc7d8c2a9525f08212e707513770dd5ee.tar.bz2
gentoo-2-65f5ec2bc7d8c2a9525f08212e707513770dd5ee.zip
net-misc/vpncwatch: Version BUmp
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'net-misc/vpncwatch')
-rw-r--r--net-misc/vpncwatch/ChangeLog10
-rw-r--r--net-misc/vpncwatch/files/vpncwatch-1.8.1-Makefile.patch23
-rw-r--r--net-misc/vpncwatch/metadata.xml6
-rw-r--r--net-misc/vpncwatch/vpncwatch-1.8.1.ebuild29
4 files changed, 63 insertions, 5 deletions
diff --git a/net-misc/vpncwatch/ChangeLog b/net-misc/vpncwatch/ChangeLog
index 0755405ccf64..2d7dfe8dba6b 100644
--- a/net-misc/vpncwatch/ChangeLog
+++ b/net-misc/vpncwatch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/vpncwatch
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vpncwatch/ChangeLog,v 1.2 2011/10/07 17:23:06 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vpncwatch/ChangeLog,v 1.3 2013/04/01 13:14:16 jlec Exp $
+
+*vpncwatch-1.8.1 (01 Apr 2013)
+
+ 01 Apr 2013; Justin Lecher <jlec@gentoo.org> +vpncwatch-1.8.1.ebuild,
+ +files/vpncwatch-1.8.1-Makefile.patch, metadata.xml:
+ Version BUmp
*vpncwatch-1.8 (07 Oct 2011)
diff --git a/net-misc/vpncwatch/files/vpncwatch-1.8.1-Makefile.patch b/net-misc/vpncwatch/files/vpncwatch-1.8.1-Makefile.patch
new file mode 100644
index 000000000000..1f982ee76a3f
--- /dev/null
+++ b/net-misc/vpncwatch/files/vpncwatch-1.8.1-Makefile.patch
@@ -0,0 +1,23 @@
+ Makefile | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 901e0ae..599499a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -10,13 +10,13 @@ OBJS = vpncwatch.o proc.o net.o
+ DISTFILES = AUTHORS COPYING README Makefile $(SRCS) $(HDRS) vpnc-watch.py
+
+ CC ?= gcc
+-CFLAGS = -D_GNU_SOURCE -O2 -Wall -Werror
++CFLAGS += -D_GNU_SOURCE -Wall
+
+ # Update version in vpncwatch.h as well
+ TAG = vpncwatch-1.8.1
+
+ vpncwatch: $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $(OBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS)
+
+ .c.o:
+ $(CC) $(CFLAGS) -c -o $@ $<
diff --git a/net-misc/vpncwatch/metadata.xml b/net-misc/vpncwatch/metadata.xml
index c845479d513e..4a00a64b40ae 100644
--- a/net-misc/vpncwatch/metadata.xml
+++ b/net-misc/vpncwatch/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>jlec@gentoo.org</email>
- </maintainer>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/net-misc/vpncwatch/vpncwatch-1.8.1.ebuild b/net-misc/vpncwatch/vpncwatch-1.8.1.ebuild
new file mode 100644
index 000000000000..504c03c7f22c
--- /dev/null
+++ b/net-misc/vpncwatch/vpncwatch-1.8.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vpncwatch/vpncwatch-1.8.1.ebuild,v 1.1 2013/04/01 13:14:16 jlec Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Keepalive daemon for vpnc on Linux systems"
+HOMEPAGE="http://github.com/dcantrell/vpncwatch/"
+SRC_URI="http://github.com/downloads/dcantrell/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-misc/vpnc"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-Makefile.patch"
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README ChangeLog AUTHORS
+}