summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-02 06:58:11 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-02 06:58:11 +0000
commit4f9c54ccebbf2e53c2c41140dfc3fa4399eedfab (patch)
treefed4953188e5f8402c7c70b237b0de711a75b944 /net-misc/wget
parentRevision bump. Add gnutls USE flag and fix ssl issues (bugs #381441 and #3815... (diff)
downloadgentoo-2-4f9c54ccebbf2e53c2c41140dfc3fa4399eedfab.tar.gz
gentoo-2-4f9c54ccebbf2e53c2c41140dfc3fa4399eedfab.tar.bz2
gentoo-2-4f9c54ccebbf2e53c2c41140dfc3fa4399eedfab.zip
Fix the gnutls uselfag to be wrapped around ssl one. Use use_with calls instead of bash conditions.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/ChangeLog7
-rw-r--r--net-misc/wget/wget-1.13.3-r1.ebuild59
-rw-r--r--net-misc/wget/wget-1.13.3-r2.ebuild29
-rw-r--r--net-misc/wget/wget-1.13.3.ebuild65
4 files changed, 16 insertions, 144 deletions
diff --git a/net-misc/wget/ChangeLog b/net-misc/wget/ChangeLog
index b76741e29551..0d4a270acbea 100644
--- a/net-misc/wget/ChangeLog
+++ b/net-misc/wget/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/wget
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.143 2011/09/02 05:16:27 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.144 2011/09/02 06:58:11 scarabeus Exp $
+
+ 02 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org> -wget-1.13.3.ebuild,
+ -wget-1.13.3-r1.ebuild, wget-1.13.3-r2.ebuild:
+ Fix the gnutls uselfag to be wrapped around ssl one. Use use_with calls
+ instead of bash conditions.
*wget-1.13.3-r2 (02 Sep 2011)
diff --git a/net-misc/wget/wget-1.13.3-r1.ebuild b/net-misc/wget/wget-1.13.3-r1.ebuild
deleted file mode 100644
index 47f5663579d3..000000000000
--- a/net-misc/wget/wget-1.13.3-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.13.3-r1.ebuild,v 1.2 2011/09/01 18:33:59 grobian Exp $
-
-EAPI=4
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Network utility to retrieve files from the WWW"
-HOMEPAGE="http://www.gnu.org/software/wget/"
-SRC_URI="mirror://gnu/wget/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug idn ipv6 nls ntlm +ssl static"
-
-RDEPEND="idn? ( net-dns/libidn )
- ssl? ( >=dev-libs/openssl-0.9.6b )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-REQUIRED_USE="ntlm? ( ssl )"
-
-DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.13-static-link-libz.patch
-}
-
-src_configure() {
- # openssl-0.9.8 now builds with -pthread on the BSD's
- use elibc_FreeBSD && use ssl && append-ldflags -pthread
- # fix compilation on Solaris, we need filio.h for FIONBIO as used in
- # the included gnutls -- force ioctl.h to include this header
- [[ ${CHOST} == *-solaris* ]] && append-flags -DBSD_COMP=1
-
- use static && append-ldflags -static
- econf \
- --disable-rpath \
- $(use_with ssl) $(use_enable ssl opie) $(use_enable ssl digest) \
- $(use_enable idn iri) \
- $(use_enable ipv6) \
- $(use_enable nls) \
- $(use_enable ntlm) \
- $(use_enable debug)
-}
-
-src_install() {
- default
-
- use ipv6 && cat "${FILESDIR}"/wgetrc-ipv6 >> "${ED}"/etc/wgetrc
-
- sed -i \
- -e "s:/usr/local/etc:${EPREFIX}/etc:g" \
- "${ED}"/etc/wgetrc \
- "${ED}"/usr/share/man/man1/wget.1 \
- "${ED}"/usr/share/info/wget.info
-}
diff --git a/net-misc/wget/wget-1.13.3-r2.ebuild b/net-misc/wget/wget-1.13.3-r2.ebuild
index 0d141d5a261d..7693492be00c 100644
--- a/net-misc/wget/wget-1.13.3-r2.ebuild
+++ b/net-misc/wget/wget-1.13.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.13.3-r2.ebuild,v 1.1 2011/09/02 05:16:27 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.13.3-r2.ebuild,v 1.2 2011/09/02 06:58:11 scarabeus Exp $
EAPI=4
@@ -16,12 +16,15 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~spar
IUSE="debug gnutls idn ipv6 nls ntlm +ssl static"
RDEPEND="idn? ( net-dns/libidn )
- gnutls? ( net-libs/gnutls )
- !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6b ) )"
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/openssl-0.9.6b )
+ )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
-REQUIRED_USE="ntlm? ( !gnutls ssl )"
+REQUIRED_USE="ntlm? ( !gnutls ssl )
+ gnutls? ( ssl )"
DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
@@ -36,24 +39,12 @@ src_configure() {
# the included gnutls -- force ioctl.h to include this header
[[ ${CHOST} == *-solaris* ]] && append-flags -DBSD_COMP=1
- local myconf
- if use gnutls ; then
- myconf+=" --with-ssl=gnutls"
- elif use ssl ; then
- myconf+=" --with-ssl=openssl"
- else
- myconf+=" --without-ssl"
- fi
-
- if use gnutls || use ssl ; then
- myconf+=" --enable-opie --enable-digest"
- else
- myconf+=" --disable-opie --disable-digest"
- fi
-
use static && append-ldflags -static
econf \
--disable-rpath \
+ $(use_with ssl ssl $(use gnutls && echo "gnutls" || echo "openssl")) \
+ $(use_enable ssl opie) \
+ $(use_enable ssl digest) \
$(use_enable idn iri) \
$(use_enable ipv6) \
$(use_enable nls) \
diff --git a/net-misc/wget/wget-1.13.3.ebuild b/net-misc/wget/wget-1.13.3.ebuild
deleted file mode 100644
index 0e990eca446c..000000000000
--- a/net-misc/wget/wget-1.13.3.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.13.3.ebuild,v 1.1 2011/09/01 09:24:29 chainsaw Exp $
-
-EAPI=4
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Network utility to retrieve files from the WWW"
-HOMEPAGE="http://www.gnu.org/software/wget/"
-SRC_URI="mirror://gnu/wget/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug idn ipv6 nls ntlm +ssl static"
-
-RDEPEND="idn? ( net-dns/libidn )
- ssl? ( >=dev-libs/openssl-0.9.6b )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-REQUIRED_USE="ntlm? ( ssl )"
-
-DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
-
-src_configure() {
- # openssl-0.9.8 now builds with -pthread on the BSD's
- use elibc_FreeBSD && use ssl && append-ldflags -pthread
-
- use static && append-ldflags -static
- econf \
- --disable-rpath \
- $(use_with ssl) $(use_enable ssl opie) $(use_enable ssl digest) \
- $(use_enable idn iri) \
- $(use_enable ipv6) \
- $(use_enable nls) \
- $(use_enable ntlm) \
- $(use_enable debug)
-}
-
-src_install() {
- default
-
- use ipv6 && cat "${FILESDIR}"/wgetrc-ipv6 >> "${ED}"/etc/wgetrc
-
- sed -i \
- -e "s:/usr/local/etc:${EROOT}/etc:g" \
- "${ED}"/etc/wgetrc \
- "${ED}"/usr/share/man/man1/wget.1 \
- "${ED}"/usr/share/info/wget.info
-}
-
-pkg_preinst() {
- ewarn "The /etc/wget/wgetrc file has been relocated to /etc/wgetrc"
- if [[ -e ${EROOT}/etc/wget/wgetrc ]] ; then
- if [[ -e ${EROOT}/etc/wgetrc ]] ; then
- ewarn "You have both /etc/wget/wgetrc and /etc/wgetrc ... you should delete the former"
- else
- einfo "Moving /etc/wget/wgetrc to /etc/wgetrc for you"
- mv "${EROOT}"/etc/wget/wgetrc "${EROOT}"/etc/wgetrc
- rmdir "${EROOT}"/etc/wget 2>/dev/null
- fi
- fi
-}