summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-02-07 22:06:44 +0000
committerMike Gilbert <floppym@gentoo.org>2012-02-07 22:06:44 +0000
commit00f38b6b1af677a4456eb0885815c387461a388d (patch)
treee3c0cecb7be4fbbadf5b0b9795d148428d586190 /net-misc
parentAdded all-gentoo-1.js to FILESDIR (bug #402583). Adjusted dependency on libvpx (diff)
downloadgentoo-2-00f38b6b1af677a4456eb0885815c387461a388d.tar.gz
gentoo-2-00f38b6b1af677a4456eb0885815c387461a388d.tar.bz2
gentoo-2-00f38b6b1af677a4456eb0885815c387461a388d.zip
Python cleanup. Patch by Arfrever.
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gnome-blog/ChangeLog7
-rw-r--r--net-misc/gnome-blog/gnome-blog-0.9.2.ebuild21
2 files changed, 18 insertions, 10 deletions
diff --git a/net-misc/gnome-blog/ChangeLog b/net-misc/gnome-blog/ChangeLog
index ffa17157bde0..567fb6c76345 100644
--- a/net-misc/gnome-blog/ChangeLog
+++ b/net-misc/gnome-blog/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/gnome-blog
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gnome-blog/ChangeLog,v 1.29 2010/10/08 23:08:03 eva Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gnome-blog/ChangeLog,v 1.30 2012/02/07 22:06:44 floppym Exp $
+
+ 07 Feb 2012; Mike Gilbert <floppym@gentoo.org> gnome-blog-0.9.2.ebuild:
+ Python cleanup. Patch by Arfrever.
08 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org>
-gnome-blog-0.9.1.ebuild:
diff --git a/net-misc/gnome-blog/gnome-blog-0.9.2.ebuild b/net-misc/gnome-blog/gnome-blog-0.9.2.ebuild
index f3b10f520451..c876d4466d8a 100644
--- a/net-misc/gnome-blog/gnome-blog-0.9.2.ebuild
+++ b/net-misc/gnome-blog/gnome-blog-0.9.2.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gnome-blog/gnome-blog-0.9.2.ebuild,v 1.4 2010/05/24 17:38:25 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gnome-blog/gnome-blog-0.9.2.ebuild,v 1.5 2012/02/07 22:06:44 floppym Exp $
-EAPI="2"
+EAPI="3"
GCONF_DEBUG="no"
+PYTHON_DEPEND="2"
inherit gnome2 python
@@ -31,24 +32,28 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README TODO"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
gnome2_src_prepare
+ python_convert_shebangs -r 2 .
# Let this file be re-created so the path in the <oaf_server> element is
# correct. See bug #93612.
rm -f GNOME_BlogApplet.server.in || die "rm failed"
- # disable pyc compiling
- mv py-compile py-compile.orig
- ln -s $(type -P true) py-compile
+ python_clean_py-compile_files
}
pkg_postinst() {
gnome2_pkg_postinst
- python_mod_optimize $(python_get_sitedir)/gnomeblog
+ python_mod_optimize gnomeblog
}
pkg_postrm() {
gnome2_pkg_postrm
- python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/gnomeblog
+ python_mod_cleanup gnomeblog
}