summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-09 04:38:49 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-09 04:38:49 +0000
commit15f390bb8e48da54d99ea4f1a40f509ea922b5fd (patch)
treec6b223b6bf6fe319e571a297447b7253f1ec2e20 /net-misc
parentversion bump (diff)
downloadgentoo-2-15f390bb8e48da54d99ea4f1a40f509ea922b5fd.tar.gz
gentoo-2-15f390bb8e48da54d99ea4f1a40f509ea922b5fd.tar.bz2
gentoo-2-15f390bb8e48da54d99ea4f1a40f509ea922b5fd.zip
repoman
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/whois/whois-4.5.28-r1.ebuild29
1 files changed, 15 insertions, 14 deletions
diff --git a/net-misc/whois/whois-4.5.28-r1.ebuild b/net-misc/whois/whois-4.5.28-r1.ebuild
index e2cede83e042..e21ccf6ac671 100644
--- a/net-misc/whois/whois-4.5.28-r1.ebuild
+++ b/net-misc/whois/whois-4.5.28-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-4.5.28-r1.ebuild,v 1.1 2002/07/01 12:04:18 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-4.5.28-r1.ebuild,v 1.2 2002/07/09 04:38:49 seemant Exp $
A=whois_${PV}.tar.gz
S=${WORKDIR}/${P}
@@ -9,16 +9,17 @@ SRC_URI="ftp://ftp.debian.org/debian/pool/main/w/whois/${A}"
HOMEPAGE="http://www.linux.it/~md/software/"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="*"
DEPEND=">=sys-devel/perl-5"
RDEPEND="virtual/glibc"
src_unpack() {
- unpack ${A}
- cd ${S}
- cp Makefile Makefile.orig
- sed \
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed \
-e "s/-O2/$CFLAGS/" \
-e "s:/man/man1/:/share/man/man1/:" \
Makefile.orig > Makefile
@@ -38,19 +39,19 @@ src_unpack() {
src_compile() {
- make || die
- make mkpasswd || die
+ make || die
+ make mkpasswd || die
}
src_install() {
- dodir /usr/bin
- dodir /usr/share/man/man1
- dodir /usr/share/locale
- make BASEDIR=${D} prefix=/usr mandir=/usr/share/man install || die
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ use nls && dodir /usr/share/locale
+ make BASEDIR=${D} prefix=/usr mandir=/usr/share/man install || die
- dobin mkpasswd
- doman mkpasswd.1
- dodoc README TODO debian/changelog debian/copyright
+ dobin mkpasswd
+ doman mkpasswd.1
+ dodoc README TODO debian/changelog debian/copyright
}