summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2011-04-26 08:39:24 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2011-04-26 08:39:24 +0000
commit41c6ed7d21af2921c400dc0492cbee4142e44f05 (patch)
tree4da2e3214ea2dccd2396e89bf95643e69347c550 /net-misc
parent1.x bugfix version bump (diff)
downloadgentoo-2-41c6ed7d21af2921c400dc0492cbee4142e44f05.tar.gz
gentoo-2-41c6ed7d21af2921c400dc0492cbee4142e44f05.tar.bz2
gentoo-2-41c6ed7d21af2921c400dc0492cbee4142e44f05.zip
Version bump wrt #362203. Thanks to Arfrever for reporting
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/pssh/ChangeLog7
-rw-r--r--net-misc/pssh/pssh-2.2.2.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/net-misc/pssh/ChangeLog b/net-misc/pssh/ChangeLog
index c50d93cc9369..5055af3c488b 100644
--- a/net-misc/pssh/ChangeLog
+++ b/net-misc/pssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/pssh
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pssh/ChangeLog,v 1.3 2011/04/05 18:49:16 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pssh/ChangeLog,v 1.4 2011/04/26 08:39:24 ultrabug Exp $
+
+*pssh-2.2.2 (26 Apr 2011)
+
+ 26 Apr 2011; Ultrabug <ultrabug@gentoo.org> +pssh-2.2.2.ebuild:
+ Version bump wrt #362203. Thanks to Arfrever for reporting
05 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pssh-2.1.1.ebuild:
diff --git a/net-misc/pssh/pssh-2.2.2.ebuild b/net-misc/pssh/pssh-2.2.2.ebuild
new file mode 100644
index 000000000000..9b26958edac4
--- /dev/null
+++ b/net-misc/pssh/pssh-2.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pssh/pssh-2.2.2.ebuild,v 1.1 2011/04/26 08:39:24 ultrabug Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*:2.4"
+inherit distutils
+
+DESCRIPTION="This package provides parallel versions of the openssh tools."
+HOMEPAGE="http://code.google.com/p/parallel-ssh/"
+SRC_URI="http://parallel-ssh.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="net-misc/openssh
+ !net-misc/putty"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+# Requires ssh access to run.
+RESTRICT="test"
+
+PYTHON_MODNAME=psshlib
+
+src_prepare() {
+ sed -i -e "s|'man/man1'|'share/man/man1'|g" setup.py
+}
+
+pkg_postinst() {
+ doman "${D}/usr/share/man/man1/pssh.1"
+}