summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-22 23:25:37 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-22 23:25:37 +0000
commit432f41e6c84765fe43bf7a7b8181875f06c871eb (patch)
tree746cc16b05a8b2d5218e8dbcd4b203a12848e409 /net-misc
parentVersion bump #123594 by Rodrigo Severo. (diff)
downloadgentoo-2-432f41e6c84765fe43bf7a7b8181875f06c871eb.tar.gz
gentoo-2-432f41e6c84765fe43bf7a7b8181875f06c871eb.tar.bz2
gentoo-2-432f41e6c84765fe43bf7a7b8181875f06c871eb.zip
Fix static building #123686 by Alexander Skwar and revert most changes.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/proxytunnel/ChangeLog6
-rw-r--r--net-misc/proxytunnel/files/proxytunnel-1.6.0-build.patch18
-rw-r--r--net-misc/proxytunnel/proxytunnel-1.6.0-r1.ebuild11
3 files changed, 31 insertions, 4 deletions
diff --git a/net-misc/proxytunnel/ChangeLog b/net-misc/proxytunnel/ChangeLog
index ccadbb6560d4..a31abfa0d591 100644
--- a/net-misc/proxytunnel/ChangeLog
+++ b/net-misc/proxytunnel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/proxytunnel
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/proxytunnel/ChangeLog,v 1.11 2006/02/22 16:37:52 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/proxytunnel/ChangeLog,v 1.12 2006/02/22 23:25:37 vapier Exp $
+
+ 22 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+ files/proxytunnel-1.6.0-build.patch, proxytunnel-1.6.0-r1.ebuild:
+ Fix static building #123686 by Alexander Skwar and revert most changes.
22 Feb 2006; Stefan Briesenick <sbriesen@gentoo.org>
proxytunnel-1.6.0-r1.ebuild:
diff --git a/net-misc/proxytunnel/files/proxytunnel-1.6.0-build.patch b/net-misc/proxytunnel/files/proxytunnel-1.6.0-build.patch
index bc58a080e5a8..28be4b73c069 100644
--- a/net-misc/proxytunnel/files/proxytunnel-1.6.0-build.patch
+++ b/net-misc/proxytunnel/files/proxytunnel-1.6.0-build.patch
@@ -1,5 +1,23 @@
--- Makefile
+++ Makefile
+@@ -6,7 +6,7 @@
+ CFLAGS ?= -Wall -O2 -g
+ CFLAGS += -DHAVE_GETOPT_LONG -DUSE_SSL
+ CFLAGS += -DSETPROCTITLE -DSPT_TYPE=1
+-LDFLAGS += -lssl -lcrypto
++LDFLAGS += -lssl $(shell pkg-config libcrypto --libs)
+
+ PREFIX =/usr/local
+ BINDIR = $(PREFIX)/bin
+@@ -27,7 +27,7 @@
+ ntlm.o
+
+ proxytunnel: $(OBJ)
+- $(CC) -o $(PROGNAME) $(CFLAGS) $(LDFLAGS) $(OBJ)
++ $(CC) -o $(PROGNAME) $(CFLAGS) $(OBJ) $(LDFLAGS)
+
+ clean:
+ @rm -f $(PROGNAME) $(OBJ)
@@ -34,4 +34,4 @@
install:
diff --git a/net-misc/proxytunnel/proxytunnel-1.6.0-r1.ebuild b/net-misc/proxytunnel/proxytunnel-1.6.0-r1.ebuild
index b200f86ed77e..8e41eb0c0522 100644
--- a/net-misc/proxytunnel/proxytunnel-1.6.0-r1.ebuild
+++ b/net-misc/proxytunnel/proxytunnel-1.6.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/proxytunnel/proxytunnel-1.6.0-r1.ebuild,v 1.2 2006/02/22 16:37:52 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/proxytunnel/proxytunnel-1.6.0-r1.ebuild,v 1.3 2006/02/22 23:25:37 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -15,13 +15,18 @@ IUSE="static"
DEPEND="dev-libs/openssl"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
src_compile() {
use static && append-ldflags -static
emake CC="$(tc-getCC)" || die
}
src_install() {
- dobin proxytunnel
- doman debian/proxytunnel.1
+ make install PREFIX=/usr DESTDIR="${D}" || die
dodoc CHANGES CREDITS KNOWN_ISSUES README
}