summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-18 05:03:11 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-18 05:03:11 +0000
commit4ba3717a60b111ef28213d0d57fc71fce335d181 (patch)
treed03a4fc6d29a8f94eb178e8777466da3d02fac2e /net-misc
parentRespect LDFLAGS (bug #335970), CC. (diff)
downloadgentoo-2-4ba3717a60b111ef28213d0d57fc71fce335d181.tar.gz
gentoo-2-4ba3717a60b111ef28213d0d57fc71fce335d181.tar.bz2
gentoo-2-4ba3717a60b111ef28213d0d57fc71fce335d181.zip
Respect LDFLAGS (bug #335985), CC.
(Portage version: 2.2_rc83/cvs/Linux i686)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/liveice/ChangeLog9
-rw-r--r--net-misc/liveice/liveice-2000530-r1.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/net-misc/liveice/ChangeLog b/net-misc/liveice/ChangeLog
index 9390fa939369..1d58ddeae09c 100644
--- a/net-misc/liveice/ChangeLog
+++ b/net-misc/liveice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/liveice
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/liveice/ChangeLog,v 1.8 2007/05/14 19:45:44 bangert Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/liveice/ChangeLog,v 1.9 2010/09/18 05:03:11 jer Exp $
+
+*liveice-2000530-r1 (18 Sep 2010)
+
+ 18 Sep 2010; Jeroen Roovers <jer@gentoo.org> +liveice-2000530-r1.ebuild:
+ Respect LDFLAGS (bug #335985), CC.
14 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/net-misc/liveice/liveice-2000530-r1.ebuild b/net-misc/liveice/liveice-2000530-r1.ebuild
new file mode 100644
index 000000000000..5c2826632aa8
--- /dev/null
+++ b/net-misc/liveice/liveice-2000530-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/liveice/liveice-2000530-r1.ebuild,v 1.1 2010/09/18 05:03:11 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Live Source Client For IceCast"
+HOMEPAGE="http://star.arm.ac.uk/~spm/software/liveice.html"
+SRC_URI="http://star.arm.ac.uk/~spm/software/liveice.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="media-sound/lame
+ media-sound/mpg123"
+DEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ # cannot use LDFLAGS directly as the Makefile uses it for LIBS
+ sed -i Makefile.in \
+ -e 's|-o liveice|$(LLFLAGS) &|' \
+ || die "sed Makefile.in"
+ tc-export CC
+}
+
+src_compile() {
+ emake LLFLAGS="${LDFLAGS}" || die
+}
+src_install() {
+ dobin liveice || die
+ dodoc liveice.cfg README.liveice README.quickstart README_new_mixer.txt Changes.txt
+}