summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-04-08 17:11:09 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-04-08 17:11:09 +0000
commit4e49f930b209718157e72cc09f3ef77840314247 (patch)
treefeb0782d2c843f62b3cb325c3bac0c014a433cbb /net-misc
parentversion bump (bug #296188) (diff)
downloadgentoo-2-4e49f930b209718157e72cc09f3ef77840314247.tar.gz
gentoo-2-4e49f930b209718157e72cc09f3ef77840314247.tar.bz2
gentoo-2-4e49f930b209718157e72cc09f3ef77840314247.zip
Version bump to fix YouTube issues and other small bug fixes. Re-introduce USE=libextractor for bug 312855
(Portage version: 2.1.7.17/cvs/Linux armv7l)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/mediatomb/ChangeLog8
-rw-r--r--net-misc/mediatomb/mediatomb-0.12.1.ebuild113
2 files changed, 120 insertions, 1 deletions
diff --git a/net-misc/mediatomb/ChangeLog b/net-misc/mediatomb/ChangeLog
index 23e93d8c1bf7..f7f0195542fa 100644
--- a/net-misc/mediatomb/ChangeLog
+++ b/net-misc/mediatomb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/mediatomb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/ChangeLog,v 1.13 2010/04/04 04:44:20 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/ChangeLog,v 1.14 2010/04/08 17:11:09 darkside Exp $
+
+*mediatomb-0.12.1 (08 Apr 2010)
+
+ 08 Apr 2010; Jeremy Olexa <darkside@gentoo.org> +mediatomb-0.12.1.ebuild:
+ Version bump to fix YouTube issues and other small bug fixes. Re-introduce
+ USE=libextractor for bug 312855
04 Apr 2010; Jeremy Olexa <darkside@gentoo.org>
mediatomb-0.12.0-r1.ebuild:
diff --git a/net-misc/mediatomb/mediatomb-0.12.1.ebuild b/net-misc/mediatomb/mediatomb-0.12.1.ebuild
new file mode 100644
index 000000000000..4914bd9ddec3
--- /dev/null
+++ b/net-misc/mediatomb/mediatomb-0.12.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/mediatomb-0.12.1.ebuild,v 1.1 2010/04/08 17:11:09 darkside Exp $
+
+EAPI=2
+inherit eutils linux-info
+
+DESCRIPTION="MediaTomb is an open source UPnP MediaServer"
+HOMEPAGE="http://www.mediatomb.cc/"
+SRC_URI="mirror://sourceforge/mediatomb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug +exif +ffmpeg inotify +javascript lastfm libextractor +mp4 mysql +taglib thumbnail"
+
+DEPEND="
+ mysql? ( virtual/mysql )
+ !mysql? ( >=dev-db/sqlite-3 )
+ javascript? ( dev-lang/spidermonkey )
+ dev-libs/expat
+ taglib? ( media-libs/taglib )
+ !taglib? ( media-libs/id3lib )
+ lastfm? ( >=media-libs/lastfmlib-0.4 )
+ exif? ( media-libs/libexif )
+ libextractor? ( media-libs/libextractor )
+ mp4? ( media-libs/libmp4v2 )
+ ffmpeg? ( media-video/ffmpeg )
+ thumbnail? ( media-video/ffmpegthumbnailer[jpeg] )
+ net-misc/curl
+ sys-apps/file
+ sys-libs/zlib
+ virtual/libiconv"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use inotify; then
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INOTIFY_USER; then
+ ewarn "Please enable Inotify support in your kernel:"
+ ewarn
+ ewarn " File systems --->"
+ ewarn " [*] Inotify support for userspace"
+ ewarn
+ fi
+ fi
+ enewgroup mediatomb
+ enewuser mediatomb -1 -1 /dev/null mediatomb
+}
+
+src_configure() {
+ if use thumbnail; then
+ elog "libextrator does not work with thumbnail, disabling libextrator"
+ myconf="${myconf} --enable-ffmpegthumbnailer --enable-ffmpeg --disable-libextractor"
+ elif ! use thumbnail && use ffmpeg && use libextractor; then
+ elog "libextrator does not work with ffmpeg, disabling libextrator"
+ myconf="${myconf} --disable-ffmpegthumbnailer --enable-ffmpeg --disable-libextractor"
+ else
+ myconf="${myconf} $(use_enable thumbnail ffmpegthumbnailer) $(use_enable ffmpeg) $(use_enable libextractor)"
+ fi
+
+ econf \
+ $(use_enable debug tombdebug) \
+ $(use_enable exif libexif) \
+ $(use_enable inotify) \
+ $(use_enable javascript libjs) \
+ $(use_enable lastfm lastfmlib) \
+ $(use_enable mp4 libmp4v2) \
+ $(use_enable mysql) $(use_enable !mysql sqlite3) \
+ $(use_enable taglib) $(use_enable !taglib id3lib) \
+ --enable-curl \
+ --enable-external-transcoding \
+ --enable-libmagic \
+ --enable-protocolinfo-extension \
+ --enable-youtube \
+ --enable-zlib \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed!"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ sed -e "s:#MYSQL#:$(use mysql && has_version dev-db/mysql[-minimal] && echo "mysql"):" \
+ "${FILESDIR}/${PN}-0.12.0.initd" > "${T}/mediatomb.initd" || die
+ newinitd "${T}/mediatomb.initd" mediatomb || die
+ newconfd "${FILESDIR}/${PN}-0.12.0.confd" mediatomb || die
+
+ insinto /etc/mediatomb
+ newins "${FILESDIR}/${PN}-0.12.0.config" config.xml || die
+ fperms 0600 /etc/mediatomb/config.xml
+ fowners mediatomb:mediatomb /etc/mediatomb/config.xml
+
+ keepdir /var/lib/mediatomb
+ fowners mediatomb:mediatomb /var/lib/mediatomb
+}
+
+pkg_postinst() {
+ if use mysql; then
+ elog "MediaTomb has been built with MySQL support and needs"
+ elog "to be configured before being started."
+ elog "For more information, please consult the MediaTomb"
+ elog "documentation: http://mediatomb.cc/pages/documentation"
+ elog
+ fi
+
+ elog "To configure MediaTomb edit:"
+ elog "/etc/mediatomb/config.xml"
+ elog
+ elog "The MediaTomb web interface can be reached at (after the service is started):"
+ elog "http://localhost:49152/"
+}