summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2003-10-06 10:45:02 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2003-10-06 10:45:02 +0000
commit638e481aa6d182095280aa05407697650654acee (patch)
treeac109aa01d3896af6174023cfab97a72fde8b652 /net-misc
parentInitial import (diff)
downloadgentoo-2-638e481aa6d182095280aa05407697650654acee.tar.gz
gentoo-2-638e481aa6d182095280aa05407697650654acee.tar.bz2
gentoo-2-638e481aa6d182095280aa05407697650654acee.zip
Initial import
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/netcomics-cvs/ChangeLog9
-rw-r--r--net-misc/netcomics-cvs/Manifest5
-rw-r--r--net-misc/netcomics-cvs/files/digest-netcomics-cvs-0.14.10
-rw-r--r--net-misc/netcomics-cvs/metadata.xml16
-rw-r--r--net-misc/netcomics-cvs/netcomics-cvs-0.14.1.ebuild42
5 files changed, 70 insertions, 2 deletions
diff --git a/net-misc/netcomics-cvs/ChangeLog b/net-misc/netcomics-cvs/ChangeLog
new file mode 100644
index 000000000000..a9c02219ed73
--- /dev/null
+++ b/net-misc/netcomics-cvs/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-misc/netcomics-cvs
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netcomics-cvs/ChangeLog,v 1.1 2003/10/06 10:44:56 pyrania Exp $
+
+*netcomics-cvs-0.14.1 (06 Oct 2003)
+
+ 06 Oct 2003; Markus Nigbur <pyrania@gentoo.org> netcomics-cvs-0.14.1.ebuild:
+ Initial import, thanks to Vaclav Slavik (bug 30437).
+
diff --git a/net-misc/netcomics-cvs/Manifest b/net-misc/netcomics-cvs/Manifest
index f3e73bba8c38..213b2f78030c 100644
--- a/net-misc/netcomics-cvs/Manifest
+++ b/net-misc/netcomics-cvs/Manifest
@@ -1,3 +1,4 @@
-MD5 777752e9965ed9530c778a4563001f79 netcomics-cvs-0.14.1.ebuild 1124
-MD5 78b2485684ee80e083bc5b57fed18608 ChangeLog 303
+MD5 f9a246d651f7dc2dd72962b9990b40ce netcomics-cvs-0.14.1.ebuild 1166
+MD5 81558873f6a40662cfcb10601fa056a0 ChangeLog 399
+MD5 0d853c14d9f204860b9944c91b426a93 metadata.xml 628
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-netcomics-cvs-0.14.1 0
diff --git a/net-misc/netcomics-cvs/files/digest-netcomics-cvs-0.14.1 b/net-misc/netcomics-cvs/files/digest-netcomics-cvs-0.14.1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/net-misc/netcomics-cvs/files/digest-netcomics-cvs-0.14.1
diff --git a/net-misc/netcomics-cvs/metadata.xml b/net-misc/netcomics-cvs/metadata.xml
new file mode 100644
index 000000000000..55283f0487aa
--- /dev/null
+++ b/net-misc/netcomics-cvs/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>pYrania@gentoo.org</email>
+ <name>Markus Nigbur</name>
+</maintainer>
+<longdescription>
+ Netcomics is a program that downloads today's comic strips
+ from the Web, and places them in a local directory where they can be
+ retrieved for display. Because each website that carries comic strips
+ chooses how old of strips to show, the comic strips downloaded will
+ actually be from different dates, but they'll always be the latest.
+</longdescription>
+</pkgmetadata>
diff --git a/net-misc/netcomics-cvs/netcomics-cvs-0.14.1.ebuild b/net-misc/netcomics-cvs/netcomics-cvs-0.14.1.ebuild
new file mode 100644
index 000000000000..c1ff701d9ec2
--- /dev/null
+++ b/net-misc/netcomics-cvs/netcomics-cvs-0.14.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netcomics-cvs/netcomics-cvs-0.14.1.ebuild,v 1.1 2003/10/06 10:44:56 pyrania Exp $
+
+inherit cvs perl-module
+
+ECVS_SERVER="cvs.sourceforge.net:/cvsroot/netcomics"
+ECVS_MODULE="netcomics"
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/${PN}"
+S=${WORKDIR}/${ECVS_MODULE}
+
+DESCRIPTION="Program to download daily comics strips from web"
+SRC_URI=""
+HOMEPAGE="http://netcomics.sourceforge.net"
+
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="${DEPEND}
+ dev-perl/libwww-perl
+ dev-perl/HTML-Parser"
+
+src_install () {
+ myinst="TMPDIR=${D}/var/spool/netcomics INSTALLSITELIB=${installvendorlib}"
+ perl-module_src_install
+
+ eval `perl '-V:installvendorlib'`
+ BROKEN_FILES="/usr/bin/comicpage
+ /usr/bin/netcomics
+ /usr/bin/show_comics
+ /usr/man/man1/netcomics.1
+ ${installvendorlib}/Netcomics/Config.pm"
+
+ for f in $BROKEN_FILES ; do
+ # get rid of /var/tmp/portage references:
+ dosed $f
+ # files are installed in vendor_perl, not site_perl, change it too:
+ perl -pi -e "s/site_perl/vendor_perl/" ${D}${f}
+ done
+}