summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-08-08 00:49:16 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-08-08 00:49:16 +0000
commit6d6cccc9ba159731c8a1a2f99edba6f36d73a426 (patch)
tree03fcd267318380dfe77521d286821d188ecd2c94 /net-misc
parentapp-editors/jedit: 5.2.0 (bug #552764) (diff)
downloadgentoo-2-6d6cccc9ba159731c8a1a2f99edba6f36d73a426.tar.gz
gentoo-2-6d6cccc9ba159731c8a1a2f99edba6f36d73a426.tar.bz2
gentoo-2-6d6cccc9ba159731c8a1a2f99edba6f36d73a426.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ipv6calc/ChangeLog10
-rw-r--r--net-misc/ipv6calc/ipv6calc-0.97.4.ebuild4
-rw-r--r--net-misc/ipv6calc/ipv6calc-0.98.0.ebuild66
3 files changed, 76 insertions, 4 deletions
diff --git a/net-misc/ipv6calc/ChangeLog b/net-misc/ipv6calc/ChangeLog
index 83f1e73cd7e1..69ee81894536 100644
--- a/net-misc/ipv6calc/ChangeLog
+++ b/net-misc/ipv6calc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/ipv6calc
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ChangeLog,v 1.81 2014/08/03 23:44:35 blueness Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ChangeLog,v 1.82 2015/08/08 00:49:16 blueness Exp $
+
+*ipv6calc-0.98.0 (08 Aug 2015)
+
+ 08 Aug 2015; Anthony G. Basile <blueness@gentoo.org> +ipv6calc-0.98.0.ebuild,
+ ipv6calc-0.97.4.ebuild:
+ Version bump.
03 Aug 2014; Anthony G. Basile <blueness@gentoo.org>
-files/ipv6calc-fix-configure-opts.patch, -ipv6calc-0.97.2-r1.ebuild:
diff --git a/net-misc/ipv6calc/ipv6calc-0.97.4.ebuild b/net-misc/ipv6calc/ipv6calc-0.97.4.ebuild
index 912556967011..ed82b49e337b 100644
--- a/net-misc/ipv6calc/ipv6calc-0.97.4.ebuild
+++ b/net-misc/ipv6calc/ipv6calc-0.97.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ipv6calc-0.97.4.ebuild,v 1.1 2014/08/03 23:34:19 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ipv6calc-0.97.4.ebuild,v 1.2 2015/08/08 00:49:16 blueness Exp $
EAPI="5"
inherit eutils
diff --git a/net-misc/ipv6calc/ipv6calc-0.98.0.ebuild b/net-misc/ipv6calc/ipv6calc-0.98.0.ebuild
new file mode 100644
index 000000000000..063ad71840a9
--- /dev/null
+++ b/net-misc/ipv6calc/ipv6calc-0.98.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ipv6calc-0.98.0.ebuild,v 1.1 2015/08/08 00:49:16 blueness Exp $
+
+EAPI="5"
+inherit eutils
+
+DESCRIPTION="IPv6 address calculator"
+HOMEPAGE="http://www.deepspace6.net/projects/ipv6calc.html"
+SRC_URI="ftp://ftp.bieringer.de/pub/linux/IPv6/ipv6calc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="geoip test"
+
+RDEPEND="
+ dev-libs/openssl
+ geoip? ( >=dev-libs/geoip-1.4.7 )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Digest-SHA1 )
+"
+
+#dev-perl/URI is needed for web interface, that is not installed now
+
+src_configure() {
+ # These options are broken. You can't disable them. That's
+ # okay because we want then force enabled.
+ # --disable-db-as-registry
+ # --disable-db-cc-registry
+ if use geoip; then
+ myconf=$(use_enable geoip)
+ myconf+=" --with-geoip-db=${EPREFIX}/usr/share/GeoIP"
+ fi
+ econf \
+ --disable-bundled-getopt \
+ --disable-bundled-md5 \
+ --enable-shared \
+ --enable-dynamic-load \
+ --enable-db-ieee \
+ --enable-db-ipv4 \
+ --enable-db-ipv6 \
+ --disable-dbip \
+ --disable-external \
+ --disable-ip2location \
+ ${myconf}
+}
+
+src_compile() {
+ # Disable default CFLAGS (-O2 and -g)
+ emake DEFAULT_CFLAGS=""
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]]; then
+ # Disable tests that fail as root
+ echo true > ipv6logstats/test_ipv6logstats.sh
+ fi
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog CREDITS README TODO USAGE
+}