summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-09-03 14:18:47 +0000
committerJeroen Roovers <jer@gentoo.org>2014-09-03 14:18:47 +0000
commit87d08143efe7fa84b72baf50cc352c60d9a03140 (patch)
tree65d9c4cdb4c202c71b8be3d90b769b353b7ef891 /net-misc
parentVersion bump. (diff)
downloadgentoo-2-87d08143efe7fa84b72baf50cc352c60d9a03140.tar.gz
gentoo-2-87d08143efe7fa84b72baf50cc352c60d9a03140.tar.bz2
gentoo-2-87d08143efe7fa84b72baf50cc352c60d9a03140.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/iperf/ChangeLog7
-rw-r--r--net-misc/iperf/iperf-3.0.7.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/net-misc/iperf/ChangeLog b/net-misc/iperf/ChangeLog
index 9df2357b5da0..452866f13e9b 100644
--- a/net-misc/iperf/ChangeLog
+++ b/net-misc/iperf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/iperf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/ChangeLog,v 1.53 2014/08/06 21:13:56 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/ChangeLog,v 1.54 2014/09/03 14:18:47 jer Exp $
+
+*iperf-3.0.7 (03 Sep 2014)
+
+ 03 Sep 2014; Jeroen Roovers <jer@gentoo.org> +iperf-3.0.7.ebuild:
+ Version bump.
*iperf-3.0.6 (06 Aug 2014)
diff --git a/net-misc/iperf/iperf-3.0.7.ebuild b/net-misc/iperf/iperf-3.0.7.ebuild
new file mode 100644
index 000000000000..07e47ffcaac3
--- /dev/null
+++ b/net-misc/iperf/iperf-3.0.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/iperf-3.0.7.ebuild,v 1.1 2014/09/03 14:18:47 jer Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
+LICENSE="BSD"
+SLOT="3"
+HOMEPAGE="https://github.com/esnet/iperf/"
+SRC_URI="https://codeload.github.com/esnet/${PN}/tar.gz/${PV} -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.0.5-flags.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}