summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2009-02-19 22:18:36 +0000
committerPeter Weller <welp@gentoo.org>2009-02-19 22:18:36 +0000
commit9ed960ce5ee50cde16d56543ce99789d5f89f9aa (patch)
tree865464663374ba08adf3eee4dff22a9e5b0fa7a3 /net-misc
parentUpdate p.mask (diff)
downloadgentoo-2-9ed960ce5ee50cde16d56543ce99789d5f89f9aa.tar.gz
gentoo-2-9ed960ce5ee50cde16d56543ce99789d5f89f9aa.tar.bz2
gentoo-2-9ed960ce5ee50cde16d56543ce99789d5f89f9aa.zip
Bump to 4.0.11
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd/ChangeLog7
-rw-r--r--net-misc/dhcpcd/dhcpcd-4.0.11.ebuild95
2 files changed, 101 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index b4b394b13436..7a27e65d0744 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.237 2009/02/07 14:38:08 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.238 2009/02/19 22:18:36 welp Exp $
+
+*dhcpcd-4.0.11 (19 Feb 2009)
+
+ 19 Feb 2009; <welp@gentoo.org> +dhcpcd-4.0.11.ebuild:
+ Bump to 4.0.11
07 Feb 2009; Raúl Porcel <armin76@gentoo.org> -dhcpcd-4.0.0.ebuild,
-dhcpcd-4.0.1-r1.ebuild, -dhcpcd-4.0.2.ebuild, -dhcpcd-4.0.3.ebuild,
diff --git a/net-misc/dhcpcd/dhcpcd-4.0.11.ebuild b/net-misc/dhcpcd/dhcpcd-4.0.11.ebuild
new file mode 100644
index 000000000000..7dc5e89fdb80
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-4.0.11.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-4.0.11.ebuild,v 1.1 2009/02/19 22:18:36 welp Exp $
+
+EAPI=1
+
+inherit toolchain-funcs eutils
+
+MY_P="${P/_alpha/-alpha}"
+MY_P="${MY_P/_beta/-beta}"
+MY_P="${MY_P/_rc/-rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
+HOMEPAGE="http://roy.marples.name/projects/dhcpcd"
+SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
+LICENSE="BSD-2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+SLOT="0"
+IUSE="+compat zeroconf"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use zeroconf; then
+ elog "Disabling zeroconf support"
+ {
+ echo
+ echo "# dhcpcd ebuild requested no zeroconf"
+ echo "noipv4ll"
+ } >> dhcpcd.conf
+ fi
+
+ if use compat; then
+ elog "dhcpcd-3 command line support enabled"
+ {
+ echo
+ echo "/* User indicated command line compatability */"
+ echo "#define CMDLINE_COMPAT"
+ } >> config.h
+ fi
+}
+
+pkg_setup() {
+ MAKE_ARGS="DBDIR=/var/lib/dhcpcd LIBEXECDIR=/lib/dhcpcd"
+}
+
+src_compile() {
+ [ -z "${MAKE_ARGS}" ] && die "MAKE_ARGS is empty"
+ emake CC="$(tc-getCC)" ${MAKE_ARGS} || die
+}
+
+src_install() {
+ local hooks="50-ntp.conf"
+ use elibc_glibc && hooks="${hooks} 50-yp.conf"
+ use compat && hooks="${hooks} 50-dhcpcd-compat"
+ emake ${MAKE_ARGS} HOOKSCRIPTS="${hooks}" DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ # Upgrade the duid file to the new format if needed
+ local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ local new_duid="${ROOT}"/etc/dhcpcd.duid
+ if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
+ fi
+
+ # Move the duid to /etc, a more sensible location
+ if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
+ cp -p "${old_duid}" "${new_duid}"
+ fi
+
+ if use zeroconf; then
+ elog "You have installed dhcpcd with zeroconf support."
+ elog "This means that it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the -L flag."
+ elog "See the dhcpcd man page for more details."
+ fi
+ if ! use compat; then
+ elog
+ elog "dhcpcd no longer sends a default ClientID for ethernet interfaces."
+ elog "This is so we can re-use the address the kernel DHCP client found."
+ elog "To retain the old behaviour of sending a default ClientID based on the"
+ elog "hardware address for interface, simply add the keyword clientid"
+ elog "to dhcpcd.conf or use commandline parameter -I ''"
+ fi
+}