summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-09-28 11:18:07 +0000
committerPacho Ramos <pacho@gentoo.org>2013-09-28 11:18:07 +0000
commitbb879d292b76056e01a8252c37d5b0abddc72030 (patch)
tree1b53874f9788370a16a7ae75ab98be6d4e613ce7 /net-misc
parentMatch more files in /etc/portage #485602 by Michael Rowell. (diff)
downloadgentoo-2-bb879d292b76056e01a8252c37d5b0abddc72030.tar.gz
gentoo-2-bb879d292b76056e01a8252c37d5b0abddc72030.tar.bz2
gentoo-2-bb879d292b76056e01a8252c37d5b0abddc72030.zip
Version bump, add unit file (#482690 by Yichao Zhou)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/isatapd/ChangeLog11
-rw-r--r--net-misc/isatapd/files/isatapd.service9
-rw-r--r--net-misc/isatapd/isatapd-0.9.7.ebuild34
3 files changed, 51 insertions, 3 deletions
diff --git a/net-misc/isatapd/ChangeLog b/net-misc/isatapd/ChangeLog
index ddd7b3fd7ee3..def8fd688768 100644
--- a/net-misc/isatapd/ChangeLog
+++ b/net-misc/isatapd/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for net-misc/isatapd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/isatapd/ChangeLog,v 1.1 2012/10/19 19:56:28 xmw Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/isatapd/ChangeLog,v 1.2 2013/09/28 11:18:07 pacho Exp $
+
+*isatapd-0.9.7 (28 Sep 2013)
+
+ 28 Sep 2013; Pacho Ramos <pacho@gentoo.org> +files/isatapd.service,
+ +isatapd-0.9.7.ebuild:
+ Version bump, add unit file (#482690 by Yichao Zhou)
*isatapd-0.9.6 (19 Oct 2012)
19 Oct 2012; Michael Weber <xmw@gentoo.org> +isatapd-0.9.6.ebuild,
+metadata.xml:
Initial import (bug 277506)
-
diff --git a/net-misc/isatapd/files/isatapd.service b/net-misc/isatapd/files/isatapd.service
new file mode 100644
index 000000000000..f68264da776b
--- /dev/null
+++ b/net-misc/isatapd/files/isatapd.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=ISATAP Client for Linux
+After=network.target nss-lookup.target
+
+[Service]
+ExecStart=/usr/sbin/isatapd
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-misc/isatapd/isatapd-0.9.7.ebuild b/net-misc/isatapd/isatapd-0.9.7.ebuild
new file mode 100644
index 000000000000..58c18d81ec6b
--- /dev/null
+++ b/net-misc/isatapd/isatapd-0.9.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/isatapd/isatapd-0.9.7.ebuild,v 1.1 2013/09/28 11:18:07 pacho Exp $
+
+EAPI=5
+inherit linux-info systemd
+
+DESCRIPTION="creates and maintains an ISATAP tunnel (rfc5214)"
+HOMEPAGE="http://www.saschahlusiak.de/linux/isatap.htm"
+SRC_URI="http://www.saschahlusiak.de/linux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+CONFIG_CHECK="~TUN"
+ERROR_TUN="CONFIG_TUN is needed for isatapd to work"
+
+src_prepare() {
+ sed -e '/^opts/s:opts:extra_started_commands:' \
+ -i openrc/isatapd.init.d || die
+}
+
+src_install() {
+ default
+
+ newinitd openrc/isatapd.init.d isatapd
+ newconfd openrc/isatapd.conf.d isatapd
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}