summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-02-07 12:49:15 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-02-07 12:49:15 +0000
commitbd101185c5ad7665c282edbaab3234641e2c8b71 (patch)
tree374c20286bafb85ce339089fd323573fbb664fb0 /net-misc
parentFix ChangeLog. Typing error. (diff)
downloadgentoo-2-bd101185c5ad7665c282edbaab3234641e2c8b71.tar.gz
gentoo-2-bd101185c5ad7665c282edbaab3234641e2c8b71.tar.bz2
gentoo-2-bd101185c5ad7665c282edbaab3234641e2c8b71.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/cgminer/ChangeLog7
-rw-r--r--net-misc/cgminer/cgminer-3.12.1.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/net-misc/cgminer/ChangeLog b/net-misc/cgminer/ChangeLog
index 5fa29efcd114..1f19ac9c4e1d 100644
--- a/net-misc/cgminer/ChangeLog
+++ b/net-misc/cgminer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/cgminer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/ChangeLog,v 1.59 2014/01/31 12:41:43 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/ChangeLog,v 1.60 2014/02/07 12:49:15 blueness Exp $
+
+*cgminer-3.12.1 (07 Feb 2014)
+
+ 07 Feb 2014; Anthony G. Basile <blueness@gentoo.org> +cgminer-3.12.1.ebuild:
+ Version bump
*cgminer-3.12.0 (31 Jan 2014)
diff --git a/net-misc/cgminer/cgminer-3.12.1.ebuild b/net-misc/cgminer/cgminer-3.12.1.ebuild
new file mode 100644
index 000000000000..0f4b59de955b
--- /dev/null
+++ b/net-misc/cgminer/cgminer-3.12.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/cgminer-3.12.1.ebuild,v 1.1 2014/02/07 12:49:15 blueness Exp $
+
+EAPI=5
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Bitcoin CPU/GPU/FPGA/ASIC miner in C"
+HOMEPAGE="http://bitcointalk.org/?topic=28402.msg357369 http://github.com/ckolivas/cgminer"
+SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
+#SRC_URI="http://ck.kolivas.org/apps/cgminer/3.10/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc examples udev hardened ncurses
+ avalon bflsc bitforce bitfury drillbit icarus klondike minion modminer"
+
+REQUIRED_USE="|| ( avalon bflsc bitforce bitfury drillbit icarus klondike minion modminer )"
+
+RDEPEND="net-misc/curl
+ dev-libs/jansson
+ ncurses? ( sys-libs/ncurses )
+ avalon? ( virtual/libusb:1 )
+ bflsc? ( virtual/libusb:1 )
+ bitforce? ( virtual/libusb:1 )
+ bitfury? ( virtual/libusb:1 )
+ icarus? ( virtual/libusb:1 )
+ modminer? ( virtual/libusb:1 )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ use hardened && append-cflags "-nopie"
+
+ econf $(use_with ncurses curses) \
+ $(use_enable avalon) \
+ $(use_enable bflsc) \
+ $(use_enable bitforce) \
+ $(use_enable bitfury) \
+ $(use_enable drillbit) \
+ $(use_enable icarus) \
+ $(use_enable klondike) \
+ $(use_enable minion) \
+ $(use_enable modminer)
+ # sanitize directories (is this still needed?)
+ sed -i 's~^\(\#define CGMINER_PREFIX \).*$~\1"'"${EPREFIX}/usr/lib/cgminer"'"~' config.h
+}
+
+src_install() { # How about using some make install?
+ dobin cgminer
+ insinto /lib/udev/rules.d
+ use udev && doins 01-cgminer.rules
+ if use doc; then
+ dodoc AUTHORS NEWS README API-README
+ use icarus || use bitforce || use modminer && dodoc FPGA-README
+ use avalon || use bflsc && dodoc ASIC-README
+ fi
+
+ if use modminer; then
+ insinto /usr/lib/cgminer/modminer
+ doins bitstreams/*.ncd
+ dodoc bitstreams/COPYING_fpgaminer
+ fi
+ if use examples; then
+ docinto examples
+ dodoc api-example.php miner.php API.java api-example.c example.conf
+ fi
+}