summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-08-27 20:51:13 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-08-27 20:51:13 +0000
commitea5a65b59da1adcadb3aa46e222dc18baa0e1299 (patch)
tree404dc098b215204d5f8966d3e6a31453403a503f /net-misc
parentremoved the einfo's at the end of the pkg_install (diff)
downloadgentoo-2-ea5a65b59da1adcadb3aa46e222dc18baa0e1299.tar.gz
gentoo-2-ea5a65b59da1adcadb3aa46e222dc18baa0e1299.tar.bz2
gentoo-2-ea5a65b59da1adcadb3aa46e222dc18baa0e1299.zip
Version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/asterisk-app_ldap/ChangeLog8
-rw-r--r--net-misc/asterisk-app_ldap/asterisk-app_ldap-0.9.9.ebuild48
-rw-r--r--net-misc/asterisk-app_ldap/files/app_ldap-0.9.9-astcfg.diff45
-rw-r--r--net-misc/asterisk-app_ldap/files/digest-asterisk-app_ldap-0.9.91
4 files changed, 101 insertions, 1 deletions
diff --git a/net-misc/asterisk-app_ldap/ChangeLog b/net-misc/asterisk-app_ldap/ChangeLog
index 30089694188e..9e60ce431ae6 100644
--- a/net-misc/asterisk-app_ldap/ChangeLog
+++ b/net-misc/asterisk-app_ldap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/asterisk-app_ldap
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_ldap/ChangeLog,v 1.5 2005/08/27 20:22:26 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_ldap/ChangeLog,v 1.6 2005/08/27 20:51:13 stkn Exp $
+
+*asterisk-app_ldap-0.9.9 (27 Aug 2005)
+
+ 27 Aug 2005; <stkn@gentoo.org> +files/app_ldap-0.9.9-astcfg.diff,
+ +asterisk-app_ldap-0.9.9.ebuild:
+ Version bump.
27 Aug 2005; <stkn@gentoo.org> asterisk-app_ldap-0.9.3.ebuild,
asterisk-app_ldap-0.9.5.ebuild:
diff --git a/net-misc/asterisk-app_ldap/asterisk-app_ldap-0.9.9.ebuild b/net-misc/asterisk-app_ldap/asterisk-app_ldap-0.9.9.ebuild
new file mode 100644
index 000000000000..1044084ff310
--- /dev/null
+++ b/net-misc/asterisk-app_ldap/asterisk-app_ldap-0.9.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_ldap/asterisk-app_ldap-0.9.9.ebuild,v 1.1 2005/08/27 20:51:13 stkn Exp $
+
+inherit eutils
+
+MY_PN="app_ldap"
+
+DESCRIPTION="Asterisk application plugin to do lookups in a LDAP directory"
+HOMEPAGE="http://www.mezzo.net/asterisk/"
+SRC_URI="http://www.mezzo.net/asterisk/${MY_PN}-${PV}.tgz"
+
+IUSE=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+# depends on iconv support
+DEPEND="sys-libs/glibc
+ >=net-nds/openldap-2.0.0
+ >=net-misc/asterisk-1.0.7-r1"
+
+S=${WORKDIR}/${MY_PN}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # use asterisk-config...
+ epatch ${FILESDIR}/${MY_PN}-0.9.9-astcfg.diff
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc CHANGES README ldap.conf.sample
+
+ # fix permissions
+ if [[ -n "$(egetent group asterisk)" ]]; then
+ chown -R root:asterisk ${D}etc/asterisk
+ chmod -R u=rwX,g=rX,o= ${D}etc/asterisk
+ fi
+}
diff --git a/net-misc/asterisk-app_ldap/files/app_ldap-0.9.9-astcfg.diff b/net-misc/asterisk-app_ldap/files/app_ldap-0.9.9-astcfg.diff
new file mode 100644
index 000000000000..efe4d8b5dbf2
--- /dev/null
+++ b/net-misc/asterisk-app_ldap/files/app_ldap-0.9.9-astcfg.diff
@@ -0,0 +1,45 @@
+--- app_ldap/Makefile.orig 2005-08-27 22:47:49.000000000 +0000
++++ app_ldap/Makefile 2005-08-27 22:50:37.000000000 +0000
+@@ -9,20 +9,18 @@
+ NAME=app_ldap
+ CONF=ldap.conf
+
++DESTDIR=
++
+ ifeq ($(shell ./check_has_cid.sh),yes)
+-CFLAGS=-g -Wall -D_REENTRANT -D_GNU_SOURCE -fPIC -DCHANNEL_HAS_CID
++CFLAGS+=-g -Wall -D_REENTRANT -D_GNU_SOURCE -fPIC -DCHANNEL_HAS_CID
+ else
+-CFLAGS=-g -Wall -D_REENTRANT -D_GNU_SOURCE -fPIC
++CFLAGS+=-g -Wall -D_REENTRANT -D_GNU_SOURCE -fPIC
+ endif
+
+ LIBS=-llber -lldap
+ RES=$(shell if [ -f /usr/include/asterisk/channel.h ]; then echo "$(NAME).so"; fi)
+
+-ifeq (${OSARCH},Darwin)
+-SOLINK=-dynamic -bundle -undefined suppress -force_flat_namespace
+-else
+-SOLINK=-shared -Xlinker -x
+-endif
++SOLINK=$(shell /usr/bin/asterisk-config --solink)
+
+ MODULES_DIR=/usr/lib/asterisk/modules
+
+@@ -34,13 +32,9 @@
+ clean:
+ rm -f $(NAME).o $(NAME).so
+
+-install: all
+- if ! [ -f /etc/asterisk/$(CONF) ]; then \
+- install -m 644 $(CONF).sample /etc/asterisk/$(CONF) ; \
+- fi
+- if [ -f $(NAME).so ]; then \
+- install -m 755 $(NAME).so $(MODULES_DIR) ; \
+- fi
++install:
++ install -D -m 644 $(CONF).sample $(DESTDIR)/etc/asterisk/$(CONF)
++ install -D -m 755 $(NAME).so $(DESTDIR)$(MODULES_DIR)
+
+ reload: install
+ asterisk -rx "unload ${RES}"
diff --git a/net-misc/asterisk-app_ldap/files/digest-asterisk-app_ldap-0.9.9 b/net-misc/asterisk-app_ldap/files/digest-asterisk-app_ldap-0.9.9
new file mode 100644
index 000000000000..25f4d0c29966
--- /dev/null
+++ b/net-misc/asterisk-app_ldap/files/digest-asterisk-app_ldap-0.9.9
@@ -0,0 +1 @@
+MD5 f4f361ce5a8de20f802fe552a086cc39 app_ldap-0.9.9.tgz 6009