summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-01-29 12:04:26 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-01-29 12:04:26 +0000
commitef27a9ae4fe9fea8287ea99a2131863c43c42036 (patch)
tree245746ddc353a6356766b7dd6ea86049a04a88dd /net-misc
parentMarking kdesdk-3.5.8 ~ppc64 for bug 207634 (diff)
downloadgentoo-2-ef27a9ae4fe9fea8287ea99a2131863c43c42036.tar.gz
gentoo-2-ef27a9ae4fe9fea8287ea99a2131863c43c42036.tar.bz2
gentoo-2-ef27a9ae4fe9fea8287ea99a2131863c43c42036.zip
Version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd/ChangeLog7
-rw-r--r--net-misc/dhcpcd/dhcpcd-3.2.1.ebuild87
-rw-r--r--net-misc/dhcpcd/files/digest-dhcpcd-3.2.13
3 files changed, 96 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index 0d095e890a59..2b643f9c8a00 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.176 2008/01/26 17:04:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.177 2008/01/29 12:04:25 armin76 Exp $
+
+*dhcpcd-3.2.1 (29 Jan 2008)
+
+ 29 Jan 2008; Raúl Porcel <armin76@gentoo.org> +dhcpcd-3.2.1.ebuild:
+ Version bump
26 Jan 2008; Diego Pettenò <flameeyes@gentoo.org> dhcpcd-3.2.0.ebuild:
Upgrade the duid file to the new format if needed. Proxying for Roy.
diff --git a/net-misc/dhcpcd/dhcpcd-3.2.1.ebuild b/net-misc/dhcpcd/dhcpcd-3.2.1.ebuild
new file mode 100644
index 000000000000..c33830bca2de
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-3.2.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-3.2.1.ebuild,v 1.1 2008/01/29 12:04:25 armin76 Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A DHCP client"
+HOMEPAGE="http://roy.marples.name/dhcpcd"
+SRC_URI="http://roy.marples.name/${PN}/${P}.tar.bz2"
+LICENSE="BSD-2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+SLOT="0"
+IUSE="vram zeroconf"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use zeroconf; then
+ elog "ZeroConf support enabled"
+ else
+ elog "Disabling zeroconf support"
+ {
+ echo
+ echo "/* User indicated no zeroconf support */"
+ echo "#undef ENABLE_IPV4LL"
+ } >> config.h
+ fi
+
+ # Disable DUID support if we have volatile storage.
+ # LiveCD's *should* enable this USE flag
+ if use vram; then
+ elog "Disabling DUID support"
+ {
+ echo
+ echo "/* User indicated volatile ram storage */"
+ echo "#undef ENABLE_DUID"
+ } >> config.h
+ else
+ elog "DUID support enabled"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" INFODIR=/var/lib/dhcpcd || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ # Upgrade the duid file to the new format if needed
+ local duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ if [ -e "${duid}" ] && ! grep -q '..:..:..:..:..:..' "${duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${duid}"
+ fi
+
+ if use zeroconf; then
+ elog "You have installed dhcpcd with zeroconf support."
+ elog "This means that it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the -L flag."
+ elog "See the dhcpcd man page for more details."
+ fi
+
+ if ! use vram; then
+ use zeroconf && echo
+ elog "You have installed dhcpcd with DUID support."
+ elog "This means that we will generate a DUID in /var/lib/dhcpcd/dhcpcd.duid"
+ elog "This is generated from a MAC address of the card and a timestamp."
+ elog "It will be used in every subsequent DHCP transaction, along with a IAID"
+ elog "in the ClientID option. This is required by RFC 4361."
+ echo
+ elog "Some DHCP server implementations require a MAC address only in the"
+ elog "ClientID field. These DHCP servers should be updated to be RFC"
+ elog "conformant. If you cannot do this, you can revert to the old"
+ elog "behaviour by using the -I '' option OR building dhcpcd with the"
+ elog "vram USE flag enabled."
+ fi
+}
diff --git a/net-misc/dhcpcd/files/digest-dhcpcd-3.2.1 b/net-misc/dhcpcd/files/digest-dhcpcd-3.2.1
new file mode 100644
index 000000000000..55cb5b26f937
--- /dev/null
+++ b/net-misc/dhcpcd/files/digest-dhcpcd-3.2.1
@@ -0,0 +1,3 @@
+MD5 5a437882b6b9eb29bde323dc411be4a4 dhcpcd-3.2.1.tar.bz2 43938
+RMD160 c38226c8cb66d99d03103c11ca945585b153baf2 dhcpcd-3.2.1.tar.bz2 43938
+SHA256 493ecb4c3848aec9f3dc31d70d0c63ade86942b75e33ecd72bacbae024256aff dhcpcd-3.2.1.tar.bz2 43938