summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-09-25 01:20:38 +0000
committerDonny Davies <woodchip@gentoo.org>2001-09-25 01:20:38 +0000
commit5e16ff73e5178fc43b1a4f047f365ef2b61e69f3 (patch)
tree5eda0005e81e6747deca8465d6afbf7476c48f7c /net-nds/openldap
parentrc5/rc6 support for net-nds/openldap -- does somebody know why openldap-2 is ... (diff)
downloadgentoo-2-5e16ff73e5178fc43b1a4f047f365ef2b61e69f3.tar.gz
gentoo-2-5e16ff73e5178fc43b1a4f047f365ef2b61e69f3.tar.bz2
gentoo-2-5e16ff73e5178fc43b1a4f047f365ef2b61e69f3.zip
changes to provide rc5/rc6 support. also some syntax beautification :)
Diffstat (limited to 'net-nds/openldap')
-rw-r--r--net-nds/openldap/files/digest-openldap-1.2.12-r61
-rw-r--r--[-rwxr-xr-x]net-nds/openldap/files/slapd.rc5 (renamed from net-nds/openldap/files/slapd)0
-rw-r--r--net-nds/openldap/files/slapd.rc617
-rw-r--r--[-rwxr-xr-x]net-nds/openldap/files/slurpd.rc5 (renamed from net-nds/openldap/files/slurpd)0
-rw-r--r--net-nds/openldap/files/slurpd.rc617
-rw-r--r--net-nds/openldap/openldap-1.2.12-r6.ebuild56
-rw-r--r--net-nds/openldap/openldap-1.2.12.ebuild92
-rw-r--r--net-nds/openldap/openldap-2.0.11-r6.ebuild63
-rw-r--r--net-nds/openldap/openldap-2.0.11.ebuild103
9 files changed, 235 insertions, 114 deletions
diff --git a/net-nds/openldap/files/digest-openldap-1.2.12-r6 b/net-nds/openldap/files/digest-openldap-1.2.12-r6
new file mode 100644
index 000000000000..6014d00d1214
--- /dev/null
+++ b/net-nds/openldap/files/digest-openldap-1.2.12-r6
@@ -0,0 +1 @@
+MD5 93e5113ec65f207a6e5015fdf216c7d2 openldap-1.2.12.tgz
diff --git a/net-nds/openldap/files/slapd b/net-nds/openldap/files/slapd.rc5
index 13e51dea99a7..13e51dea99a7 100755..100644
--- a/net-nds/openldap/files/slapd
+++ b/net-nds/openldap/files/slapd.rc5
diff --git a/net-nds/openldap/files/slapd.rc6 b/net-nds/openldap/files/slapd.rc6
new file mode 100644
index 000000000000..2ac13d9525b0
--- /dev/null
+++ b/net-nds/openldap/files/slapd.rc6
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ldap-server"
+ start-stop-daemon --start --quiet --exec /usr/lib/openldap/slapd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ldap-server"
+ start-stop-daemon --stop --quiet --exec /usr/lib/openldap/slapd
+ eend $?
+}
diff --git a/net-nds/openldap/files/slurpd b/net-nds/openldap/files/slurpd.rc5
index 01824858809e..01824858809e 100755..100644
--- a/net-nds/openldap/files/slurpd
+++ b/net-nds/openldap/files/slurpd.rc5
diff --git a/net-nds/openldap/files/slurpd.rc6 b/net-nds/openldap/files/slurpd.rc6
new file mode 100644
index 000000000000..e822f4d747f2
--- /dev/null
+++ b/net-nds/openldap/files/slurpd.rc6
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting slurpd"
+ start-stop-daemon --start --quiet --exec /usr/lib/openldap/slurpd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping slurpd"
+ start-stop-daemon --stop --quiet --exec /usr/lib/openldap/slurpd
+ eend $?
+}
diff --git a/net-nds/openldap/openldap-1.2.12-r6.ebuild b/net-nds/openldap/openldap-1.2.12-r6.ebuild
new file mode 100644
index 000000000000..760b7942bbb1
--- /dev/null
+++ b/net-nds/openldap/openldap-1.2.12-r6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-1.2.12-r6.ebuild,v 1.1 2001/09/25 01:20:38 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/${P}.tgz"
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+DEPEND="virtual/glibc
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+src_compile() {
+ local myconf
+ use tcpd && myconf="${myconf} --enable-wrappers"
+ use gdbm && myconf="${myconf} --enable-ldbm --with-ldbm-api=gdbm"
+ use gdbm || myconf="${myconf} --disable-ldbm"
+
+ ./configure --host=${CHOST} --enable-passwd --enable-shell --enable-shared \
+ --enable-static --prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib \
+ --mandir=/usr/share/man --libexecdir=/usr/lib/openldap ${myconf}
+ assert "bad configure"
+
+ make depend || die
+ make || die "compile problem"
+ cd tests ; make || die
+}
+
+src_install() {
+ make prefix=${D}/usr sysconfdir=${D}/etc/openldap localstatedir=${D}/var/lib \
+ mandir=${D}/usr/share/man libexecdir=${D}/usr/lib/openldap install
+ assert "install problem"
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc ; dodoc doc/rfc/*.txt
+ docinto devel ; dodoc doc/devel/*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/slapd.rc6 slapd
+ newexe ${FILESDIR}/slurpd.rc6 slurpd
+
+ cd ${D}/etc/openldap
+ for i in *
+ do
+ cp $i $i.orig
+ sed -e "s:${D}::" $i.orig > $i
+ rm $i.orig
+ done
+}
diff --git a/net-nds/openldap/openldap-1.2.12.ebuild b/net-nds/openldap/openldap-1.2.12.ebuild
index f3bfde159d2b..d75e3a44ba8b 100644
--- a/net-nds/openldap/openldap-1.2.12.ebuild
+++ b/net-nds/openldap/openldap-1.2.12.ebuild
@@ -1,70 +1,56 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-1.2.12.ebuild,v 1.2 2001/06/11 10:56:47 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-1.2.12.ebuild,v 1.3 2001/09/25 01:20:38 woodchip Exp $
-A=${P}.tgz
S=${WORKDIR}/${P}
DESCRIPTION="LDAP suite of application and development tools"
-SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/${A}"
-
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/${P}.tgz"
HOMEPAGE="http://www.OpenLDAP.org/"
DEPEND="virtual/glibc
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
- >=sys-libs/ncurses-5.1
- gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
RDEPEND="virtual/glibc
- >=sys-libs/ncurses-5.1
- gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
src_compile() {
- local myconf
- if [ "`use tcpd`" ] ; then
- myconf="--enable-wrappers"
- fi
- if [ "`use gdbm`" ] ; then
- myconf="$myconf --enable-ldbm --with-ldbm-api=gdbm"
- else
- myconf="$myconf --disable-ldbm"
- fi
- ./configure --host=${CHOST} --enable-passwd \
- --enable-shell --enable-shared --enable-static \
- --prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib \
- --mandir=/usr/share/man --libexecdir=/usr/lib/openldap $myconf
- try make depend
- try make
- cd tests
- make
+ local myconf
+ use tcpd && myconf="${myconf} --enable-wrappers"
+ use gdbm && myconf="${myconf} --enable-ldbm --with-ldbm-api=gdbm"
+ use gdbm || myconf="${myconf} --disable-ldbm"
+
+ ./configure --host=${CHOST} --enable-passwd --enable-shell --enable-shared \
+ --enable-static --prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib \
+ --mandir=/usr/share/man --libexecdir=/usr/lib/openldap ${myconf}
+ assert "bad configure"
+
+ make depend || die
+ make || die "compile problem"
+ cd tests ; make || die
}
-src_install() {
- cd ${S}
- make prefix=${D}/usr sysconfdir=${D}/etc/openldap localstatedir=${D}/var/lib \
+src_install() {
+ make prefix=${D}/usr sysconfdir=${D}/etc/openldap localstatedir=${D}/var/lib \
mandir=${D}/usr/share/man libexecdir=${D}/usr/lib/openldap install
-
- dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
- docinto rfc
- dodoc doc/rfc/*.txt
- docinto devel
- dodoc doc/devel/*
-
- dodir /etc/rc.d/init.d
- cp ${O}/files/slapd ${D}/etc/rc.d/init.d
- cp ${O}/files/slurpd ${D}/etc/rc.d/init.d
-
- cd ${D}/etc/openldap
-
- for i in *
- do
- cp $i $i.orig
- sed -e "s:${D}::" $i.orig > $i
- rm $i.orig
- done
+ assert "install problem"
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc ; dodoc doc/rfc/*.txt
+ docinto devel ; dodoc doc/devel/*
+
+ exeinto /etc/rc.d/init.d
+ newexe ${FILESDIR}/slapd.rc5 slapd
+ newexe ${FILESDIR}/slurpd.rc5 slurpd
+
+ cd ${D}/etc/openldap
+ for i in *
+ do
+ cp $i $i.orig
+ sed -e "s:${D}::" $i.orig > $i
+ rm $i.orig
+ done
}
-
-
-
-
-
diff --git a/net-nds/openldap/openldap-2.0.11-r6.ebuild b/net-nds/openldap/openldap-2.0.11-r6.ebuild
new file mode 100644
index 000000000000..c623bb409c4b
--- /dev/null
+++ b/net-nds/openldap/openldap-2.0.11-r6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.11-r6.ebuild,v 1.1 2001/09/25 01:20:38 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/${P}.tgz"
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+DEPEND="virtual/glibc
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+src_compile() {
+ local myconf
+
+ use tcpd && myconf="${myconf} --enable-wrappers"
+ use ssl && myconf="${myconf} --with-tls"
+ use readline && myconf="${myconf} --with-readline"
+ use readline || myconf="${myconf} --without-readline"
+ use gdbm && myconf="${myconf} --enable-ldbm --with-ldbm-api=gdbm"
+ use gdbm || myconf="${myconf} --disable-ldbm"
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ ./configure --host=${CHOST} --enable-passwd --enable-shell \
+ --enable-shared --enable-static --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var/state --mandir=/usr/share/man \
+ --libexecdir=/usr/lib/openldap ${myconf}
+ assert "bad configure"
+
+ make depend || die
+ make || die
+ cd tests ; make || die
+}
+
+src_install() {
+ make prefix=${D}/usr sysconfdir=${D}/etc/openldap \
+ localstatedir=${D}/var/state mandir=${D}/usr/share/man \
+ libexecdir=${D}/usr/lib/openldap install
+ assert "install problem"
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc ; dodoc doc/rfc/*.txt
+ docinto devel ; dodoc doc/devel/*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/slapd.rc6 slapd
+ newexe ${FILESDIR}/slurpd.rc6 slurpd
+
+ cd ${D}/etc/openldap
+ for i in *
+ do
+ dosed $i
+ done
+}
diff --git a/net-nds/openldap/openldap-2.0.11.ebuild b/net-nds/openldap/openldap-2.0.11.ebuild
index fa3a6b3d8c8e..9718462e3895 100644
--- a/net-nds/openldap/openldap-2.0.11.ebuild
+++ b/net-nds/openldap/openldap-2.0.11.ebuild
@@ -1,82 +1,63 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.11.ebuild,v 1.2 2001/06/11 10:56:47 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.11.ebuild,v 1.3 2001/09/25 01:20:38 woodchip Exp $
-A=${P}.tgz
S=${WORKDIR}/${P}
DESCRIPTION="LDAP suite of application and development tools"
-SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/"${A}
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/${P}.tgz"
HOMEPAGE="http://www.OpenLDAP.org/"
DEPEND="virtual/glibc
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
ssl? ( >=dev-libs/openssl-0.9.6 )
readline? ( >=sys-libs/readline-4.1 )
- >=sys-libs/ncurses-5.1
+ >=sys-libs/ncurses-5.1
gdbm? ( >=sys-libs/gdbm-1.8.0 )"
RDEPEND="virtual/glibc
- >=sys-libs/ncurses-5.1
+ >=sys-libs/ncurses-5.1
gdbm? ( >=sys-libs/gdbm-1.8.0 )"
-
src_compile() {
- local myconf
- if [ "`use tcpd`" ] ; then
- myconf="--enable-wrappers"
- fi
- if [ "`use ssl`" ] ; then
- myconf="$myconf --with-tls"
- else
- myconf="$myconf --without-tls"
- fi
- if [ "`use readline`" ] ; then
- myconf="$myconf --with-readline"
- else
- myconf="$myconf --without-readline"
- fi
- if [ "`use gdbm`" ] ; then
- myconf="$myconf --enable-ldbm --with-ldbm-api=gdbm"
- else
- myconf="$myconf --disable-ldbm"
- fi
- try ./configure --host=${CHOST} --enable-passwd \
- --enable-shell --enable-shared --enable-static --enable-ipv6 \
- --prefix=/usr --sysconfdir=/etc --localstatedir=/var/state \
- --mandir=/usr/share/man --libexecdir=/usr/lib/openldap $myconf
- try make depend
- try make
- cd tests
- try make
+ local myconf
+
+ use tcpd && myconf="${myconf} --enable-wrappers"
+ use ssl && myconf="${myconf} --with-tls"
+ use readline && myconf="${myconf} --with-readline"
+ use readline || myconf="${myconf} --without-readline"
+ use gdbm && myconf="${myconf} --enable-ldbm --with-ldbm-api=gdbm"
+ use gdbm || myconf="${myconf} --disable-ldbm"
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ ./configure --host=${CHOST} --enable-passwd --enable-shell \
+ --enable-shared --enable-static --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var/state --mandir=/usr/share/man \
+ --libexecdir=/usr/lib/openldap ${myconf}
+ assert "bad configure"
+
+ make depend || die
+ make || die
+ cd tests ; make || die
}
src_install() {
-
- try make prefix=${D}/usr sysconfdir=${D}/etc/openldap \
- localstatedir=${D}/var/state mandir=${D}/usr/share/man libexecdir=${D}/usr/lib/openldap install
-
- dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
- docinto rfc
- dodoc doc/rfc/*.txt
- docinto devel
- dodoc doc/devel/*
-
- dodir /etc/rc.d/init.d
- cp ${O}/files/slapd ${D}/etc/rc.d/init.d
- cp ${O}/files/slurpd ${D}/etc/rc.d/init.d
-
- cd ${D}/etc/openldap
-
- for i in *
- do
- dosed $i
- done
-
+ make prefix=${D}/usr sysconfdir=${D}/etc/openldap \
+ localstatedir=${D}/var/state mandir=${D}/usr/share/man \
+ libexecdir=${D}/usr/lib/openldap install
+ assert "install problem"
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc ; dodoc doc/rfc/*.txt
+ docinto devel ; dodoc doc/devel/*
+
+ exeinto /etc/rc.d/init.d
+ newexe ${FILESDIR}/slapd.rc5 slapd
+ newexe ${FILESDIR}/slurpd.rc5 slurpd
+
+ cd ${D}/etc/openldap
+ for i in *
+ do
+ dosed $i
+ done
}
-
-
-
-
-
-