summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-01-26 01:02:24 +0000
committerMike Frysinger <vapier@gentoo.org>2012-01-26 01:02:24 +0000
commit87dc9c4c487e8ccfec8052bfe104f65c3bde1edd (patch)
treefdbeb89c45d1cb368492beb4d4d13942c9b93c9b /net-nds/rpcbind
parentBeta channel bump. (diff)
downloadgentoo-2-87dc9c4c487e8ccfec8052bfe104f65c3bde1edd.tar.gz
gentoo-2-87dc9c4c487e8ccfec8052bfe104f65c3bde1edd.tar.bz2
gentoo-2-87dc9c4c487e8ccfec8052bfe104f65c3bde1edd.zip
Add USE=tcpd support #400607 by Tor.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-nds/rpcbind')
-rw-r--r--net-nds/rpcbind/ChangeLog8
-rw-r--r--net-nds/rpcbind/rpcbind-0.2.0.ebuild16
-rw-r--r--net-nds/rpcbind/rpcbind-9999.ebuild14
3 files changed, 25 insertions, 13 deletions
diff --git a/net-nds/rpcbind/ChangeLog b/net-nds/rpcbind/ChangeLog
index 67606c30ca13..77f25a85fd07 100644
--- a/net-nds/rpcbind/ChangeLog
+++ b/net-nds/rpcbind/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-nds/rpcbind
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.17 2011/12/28 15:56:31 swift Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.18 2012/01/26 01:02:24 vapier Exp $
+
+ 26 Jan 2012; Mike Frysinger <vapier@gentoo.org> rpcbind-0.2.0.ebuild,
+ rpcbind-9999.ebuild:
+ Add USE=tcpd support #400607 by Tor.
28 Dec 2011; <swift@gentoo.org> rpcbind-0.2.0.ebuild:
Add selinux dependency for selinux-rpcbind
diff --git a/net-nds/rpcbind/rpcbind-0.2.0.ebuild b/net-nds/rpcbind/rpcbind-0.2.0.ebuild
index 21acb1212e56..3edbae874105 100644
--- a/net-nds/rpcbind/rpcbind-0.2.0.ebuild
+++ b/net-nds/rpcbind/rpcbind-0.2.0.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-0.2.0.ebuild,v 1.12 2011/12/28 15:56:31 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-0.2.0.ebuild,v 1.13 2012/01/26 01:02:24 vapier Exp $
EAPI="2"
inherit autotools
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.infradead.org/~steved/rpcbind.git"
- inherit autotools git
+ inherit autotools git-2
SRC_URI=""
#KEYWORDS=""
else
@@ -20,10 +21,11 @@ HOMEPAGE="http://sourceforge.net/projects/rpcbind/"
LICENSE="BSD"
SLOT="0"
-IUSE="selinux"
+IUSE="selinux tcpd"
RDEPEND="net-libs/libtirpc
- selinux? ( sec-policy/selinux-rpcbind )"
+ selinux? ( sec-policy/selinux-rpcbind )
+ tcpd? ( sys-apps/tcp-wrappers )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
@@ -37,7 +39,9 @@ src_prepare() {
}
src_configure() {
- econf --bindir=/sbin
+ econf \
+ --bindir=/sbin \
+ $(use_enable tcpd libwrap)
}
src_install() {
diff --git a/net-nds/rpcbind/rpcbind-9999.ebuild b/net-nds/rpcbind/rpcbind-9999.ebuild
index a5e2f3f8bb81..a3b2d265b380 100644
--- a/net-nds/rpcbind/rpcbind-9999.ebuild
+++ b/net-nds/rpcbind/rpcbind-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-9999.ebuild,v 1.6 2011/09/21 08:18:29 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-9999.ebuild,v 1.7 2012/01/26 01:02:24 vapier Exp $
EAPI="2"
@@ -19,9 +19,11 @@ HOMEPAGE="http://sourceforge.net/projects/rpcbind/"
LICENSE="BSD"
SLOT="0"
-IUSE=""
+IUSE="selinux tcpd"
-RDEPEND="net-libs/libtirpc"
+RDEPEND="net-libs/libtirpc
+ selinux? ( sec-policy/selinux-rpcbind )
+ tcpd? ( sys-apps/tcp-wrappers )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
@@ -35,7 +37,9 @@ src_prepare() {
}
src_configure() {
- econf --bindir=/sbin
+ econf \
+ --bindir=/sbin \
+ $(use_enable tcpd libwrap)
}
src_install() {