summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-08-11 18:11:56 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-08-11 18:11:56 +0000
commitfad58177ed1e66b8eeebbfbd041ba0d90ea61747 (patch)
tree5de2f2c352c9954fc6ce81a5ec06977902bddf15 /net-nds/ypserv/ypserv-2.18.ebuild
parentPreserve server_name where possible. (diff)
downloadgentoo-2-fad58177ed1e66b8eeebbfbd041ba0d90ea61747.tar.gz
gentoo-2-fad58177ed1e66b8eeebbfbd041ba0d90ea61747.tar.bz2
gentoo-2-fad58177ed1e66b8eeebbfbd041ba0d90ea61747.zip
Version bump. Bug #102137.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-nds/ypserv/ypserv-2.18.ebuild')
-rw-r--r--net-nds/ypserv/ypserv-2.18.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-nds/ypserv/ypserv-2.18.ebuild b/net-nds/ypserv/ypserv-2.18.ebuild
new file mode 100644
index 000000000000..3f81c5b146f0
--- /dev/null
+++ b/net-nds/ypserv/ypserv-2.18.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypserv/ypserv-2.18.ebuild,v 1.1 2005/08/11 18:11:56 eradicator Exp $
+
+DESCRIPTION="Network Information Service server"
+HOMEPAGE="http://www.linux-nis.org/nis/"
+SRC_URI="mirror://kernel/linux/utils/net/NIS/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="slp"
+
+RDEPEND=">=sys-libs/gdbm-1.8.0
+ slp? ( net-libs/openslp )"
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.51"
+
+src_compile() {
+ econf $(use_enable slp) || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS TODO
+
+ insinto /etc
+ doins etc/ypserv.conf etc/netgroup etc/netmasks
+ insinto /var/yp
+ newins etc/securenets securenets.default
+
+ newconfd ${FILESDIR}/ypserv.confd ypserv
+ newconfd ${FILESDIR}/rpc.yppasswdd.confd rpc.yppasswdd
+ newconfd ${FILESDIR}/rpc.ypxfrd.confd rpc.ypxfrd
+
+ newinitd ${FILESDIR}/ypserv ypserv
+ newinitd ${FILESDIR}/rpc.yppasswdd-r1 rpc.yppasswdd
+ newinitd ${FILESDIR}/rpc.ypxfrd rpc.ypxfrd
+
+ # Save the old config into the new package as CONFIG_PROTECT
+ # doesn't work for this package.
+ if [ -f ${ROOT}/var/yp/Makefile ]; then
+ mv ${D}/var/yp/Makefile ${D}/var/yp/Makefile.dist
+ cp ${ROOT}/var/yp/Makefile ${D}/var/yp/Makefile
+ einfo "As you have a previous /var/yp/Makefile, I have added"
+ einfo "this file into the new package and installed the new"
+ einfo "file as /var/yp/Makefile.dist"
+ fi
+}
+
+pkg_postinst() {
+ einfo "To complete setup, you will need to edit /var/yp/securenets,"
+ einfo "/etc/conf.d/ypserv, /etc/ypserv.conf, /etc/conf.d/rpc.yppasswdd"
+ einfo "and possibly /var/yp/Makefile."
+
+ einfo "To start the services at boot, you need to enable ypserv and optionally"
+ einfo "the rpc.yppasswdd and/or rpc.ypxfrd services"
+}