summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-07-28 17:56:36 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-07-28 17:56:36 +0000
commita116b5b9057b9f48af4f1788919bc2f78a11dd3e (patch)
tree8e685b52924c5b4c0e5d5e0ff8c1aa5d2970dbb0 /net-news/pan
parentUpdated ebuilds to require pkgconfig (see Bug #5665). (diff)
downloadgentoo-2-a116b5b9057b9f48af4f1788919bc2f78a11dd3e.tar.gz
gentoo-2-a116b5b9057b9f48af4f1788919bc2f78a11dd3e.tar.bz2
gentoo-2-a116b5b9057b9f48af4f1788919bc2f78a11dd3e.zip
Version bump, added spell support with gtkspell which has been also added as dep if spell is in USE.
Diffstat (limited to 'net-news/pan')
-rw-r--r--net-news/pan/ChangeLog8
-rw-r--r--net-news/pan/files/digest-pan-0.12.911
-rw-r--r--net-news/pan/pan-0.12.91.ebuild64
3 files changed, 72 insertions, 1 deletions
diff --git a/net-news/pan/ChangeLog b/net-news/pan/ChangeLog
index b8322fbefd70..ddb4d3acc67f 100644
--- a/net-news/pan/ChangeLog
+++ b/net-news/pan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-news/pan
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-news/pan/ChangeLog,v 1.13 2002/07/17 09:40:40 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/ChangeLog,v 1.14 2002/07/28 17:56:36 stroke Exp $
+
+*pan-0.12.91 (28 July 2002)
+
+ 28 Jul 2002; Gabriele Giorgetti <stroke@gentoo.org> pan-0.12.91.ebuild:
+ Version bump, added spell support with gtkspell which has been also added
+ as dep if spell is present in USE.
*pan-0.11.4 (17 July 2002)
diff --git a/net-news/pan/files/digest-pan-0.12.91 b/net-news/pan/files/digest-pan-0.12.91
new file mode 100644
index 000000000000..cb68ea7b270c
--- /dev/null
+++ b/net-news/pan/files/digest-pan-0.12.91
@@ -0,0 +1 @@
+MD5 94a35b118f78c2d3c4dfb033924d06c1 pan-0.12.91.tar.bz2 1625392
diff --git a/net-news/pan/pan-0.12.91.ebuild b/net-news/pan/pan-0.12.91.ebuild
new file mode 100644
index 000000000000..5a8c9754a4df
--- /dev/null
+++ b/net-news/pan/pan-0.12.91.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/pan-0.12.91.ebuild,v 1.1 2002/07/28 17:56:36 stroke Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+DESCRIPTION="A newsreader for the Gnome2 desktop"
+SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/SOURCE/${P}.tar.bz2"
+HOMEPAGE="http://pan.rebelbase.com"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ >=x11-libs/gtk+-2.0.5
+ >=dev-libs/libxml2-2.4.22
+ spell? ( >=app-text/gtkspell-2.0.0 )"
+
+DEPEND="$RDEPEND"
+
+export CONFIG_PROTECT_MASK="/etc/gconf"
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="--disable-nls"
+
+ if [ -n "`use gtkspell`" ] ; then
+ myconf="${myconf} --enable-gtkspell=yes"
+ else
+ myconf="${myconf} --enable-gtkspell=no"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --localstatedir=/var/lib \
+ --enable-debug=yes \
+ ${myconf} || die "configure failure"
+
+ emake || die "compile failure"
+}
+
+src_install() {
+ emake prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ localstatedir=${D}/var/lib \
+ install || die "installation failed"
+
+ dodoc ANNOUNCE AUTHORS ChangeLog COPYING CREDITS INSTALL NEWS README TODO
+}
+
+