summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-12-28 19:00:18 +0000
committerMike Frysinger <vapier@gentoo.org>2006-12-28 19:00:18 +0000
commit4010b4a8bed9d7747a15ecdf5c21bdc611c98229 (patch)
tree6e7d0b92f711fe079d9eee735f018d92e9524f2d /net-p2p/bittorrent/bittorrent-4.4.0.ebuild
parentold (diff)
downloadgentoo-2-4010b4a8bed9d7747a15ecdf5c21bdc611c98229.tar.gz
gentoo-2-4010b4a8bed9d7747a15ecdf5c21bdc611c98229.tar.bz2
gentoo-2-4010b4a8bed9d7747a15ecdf5c21bdc611c98229.zip
Cleanup ebuilds and make sure init.d script name matches that of the binaries.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'net-p2p/bittorrent/bittorrent-4.4.0.ebuild')
-rw-r--r--net-p2p/bittorrent/bittorrent-4.4.0.ebuild35
1 files changed, 13 insertions, 22 deletions
diff --git a/net-p2p/bittorrent/bittorrent-4.4.0.ebuild b/net-p2p/bittorrent/bittorrent-4.4.0.ebuild
index fe32bb3880b8..e5b26ecbb138 100644
--- a/net-p2p/bittorrent/bittorrent-4.4.0.ebuild
+++ b/net-p2p/bittorrent/bittorrent-4.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-4.4.0.ebuild,v 1.12 2006/09/30 18:55:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-4.4.0.ebuild,v 1.13 2006/12/28 19:00:17 vapier Exp $
inherit distutils fdo-mime eutils
@@ -17,11 +17,11 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ppc ppc64 s390 sh sparc x86"
IUSE="gtk"
-RDEPEND="gtk? (
+RDEPEND=">=dev-lang/python-2.3
+ gtk? (
>=x11-libs/gtk+-2.6
>=dev-python/pygtk-2.6
)
- >=dev-lang/python-2.3
>=dev-python/pycrypto-2.0
!virtual/bittorrent"
DEPEND="${RDEPEND}
@@ -30,45 +30,36 @@ DEPEND="${RDEPEND}
dev-python/dnspython"
PROVIDE="virtual/bittorrent"
-DOCS="TRACKERLESS.txt LICENSE.txt public.key"
+DOCS="TRACKERLESS.txt public.key credits.txt"
PYTHON_MODNAME="BitTorrent"
src_unpack() {
unpack ${A}
- cd ${S}
-
- # path for documentation is in lowercase (see bug #109743)
+ cd "${S}"
+ # path for documentation is in lowercase #109743
sed -i -r "s:(dp.*appdir):\1.lower():" BitTorrent/platform.py
}
src_install() {
distutils_src_install
- if ! use gtk; then
- rm ${D}/usr/bin/bittorrent
- fi
+ use gtk || rm -f "${D}"/usr/bin/bittorrent
dohtml redirdonate.html
- mv ${S}/{credits-l10n.txt,credits.txt} \
- ${D}/usr/share/doc/${P}
-
if use gtk ; then
- cp ${D}/usr/share/pixmaps/${MY_P}/bittorrent.ico ${D}/usr/share/pixmaps/
- make_desktop_entry "bittorrent" "BitTorrent" \
- /usr/share/pixmaps/bittorrent.ico "Network"
+ doicon images/logo/bittorrent.ico
+ make_desktop_entry "bittorrent" "BitTorrent" bittorrent.ico "Network"
echo "MimeType=application/x-bittorrent" \
- >> ${D}/usr/share/applications/bittorrent-${PN}.desktop
+ >> "${D}"/usr/share/applications/bittorrent-${PN}.desktop
fi
- insinto /etc/conf.d
- newins ${FILESDIR}/bttrack.conf bttrack
-
- exeinto /etc/init.d
- newexe ${FILESDIR}/bttrack.rc bttrack
+ newinitd "${FILESDIR}"/bittorrent-tracker.initd bittorrent-tracker
+ newconfd "${FILESDIR}"/bittorrent-tracker.confd bittorrent-tracker
}
pkg_postinst() {
einfo "Remember that BitTorrent has changed file naming scheme"
einfo "To run BitTorrent just execute /usr/bin/bittorrent"
+ einfo "To run the init.d, please use /etc/init.d/bittorrent-tracker"
distutils_pkg_postinst
fdo-mime_desktop_database_update
}