summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-02-25 14:41:11 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-02-25 14:41:11 +0000
commit36fa8d4a9d63f6c2a18656464d97b2bb5b741ea6 (patch)
tree54786eb8182e6bfd4a62d65b411c615c4610f56a /net-p2p/dbhub/dbhub-0.451.ebuild
parentStable x86, amd64. (diff)
downloadgentoo-2-36fa8d4a9d63f6c2a18656464d97b2bb5b741ea6.tar.gz
gentoo-2-36fa8d4a9d63f6c2a18656464d97b2bb5b741ea6.tar.bz2
gentoo-2-36fa8d4a9d63f6c2a18656464d97b2bb5b741ea6.zip
Version bump, add switch_user USE-flag
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-p2p/dbhub/dbhub-0.451.ebuild')
-rw-r--r--net-p2p/dbhub/dbhub-0.451.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-p2p/dbhub/dbhub-0.451.ebuild b/net-p2p/dbhub/dbhub-0.451.ebuild
new file mode 100644
index 000000000000..623cb1dae555
--- /dev/null
+++ b/net-p2p/dbhub/dbhub-0.451.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dbhub/dbhub-0.451.ebuild,v 1.1 2008/02/25 14:41:10 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="Hub software for Direct Connect, fork of opendchub"
+HOMEPAGE="http://www.dbhub.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="debug perl nls switch_user"
+
+DEPEND="perl? ( dev-lang/perl )
+ switch_user? ( sys-libs/libcap )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-gentoo.patch
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable perl) \
+ $(use_enable switch_user) \
+ $(use_enable debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}