summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-01-10 10:06:05 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-01-10 10:06:05 +0000
commit343896fc11e37b8520bdbcb0e90078616ca7b1e1 (patch)
treecb57ef7f59cd29818557f77405500fb59492aac4 /net-p2p/gnapster/gnapster-1.5.0-r2.ebuild
parentFiltering jikes because it fails to compile this. (diff)
downloadgentoo-2-343896fc11e37b8520bdbcb0e90078616ca7b1e1.tar.gz
gentoo-2-343896fc11e37b8520bdbcb0e90078616ca7b1e1.tar.bz2
gentoo-2-343896fc11e37b8520bdbcb0e90078616ca7b1e1.zip
Cleanup ebuiild and remove gnuconfig eclass, bug 160188
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-p2p/gnapster/gnapster-1.5.0-r2.ebuild')
-rw-r--r--net-p2p/gnapster/gnapster-1.5.0-r2.ebuild26
1 files changed, 7 insertions, 19 deletions
diff --git a/net-p2p/gnapster/gnapster-1.5.0-r2.ebuild b/net-p2p/gnapster/gnapster-1.5.0-r2.ebuild
index 4662d3e9a514..dbffdc6fe5fd 100644
--- a/net-p2p/gnapster/gnapster-1.5.0-r2.ebuild
+++ b/net-p2p/gnapster/gnapster-1.5.0-r2.ebuild
@@ -1,8 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnapster/gnapster-1.5.0-r2.ebuild,v 1.15 2006/11/18 04:39:10 compnerd Exp $
-
-inherit gnuconfig
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnapster/gnapster-1.5.0-r2.ebuild,v 1.16 2007/01/10 10:06:05 armin76 Exp $
IUSE="nls"
@@ -17,30 +15,20 @@ KEYWORDS="x86 ppc amd64"
DEPEND="=x11-libs/gtk+-1.2*"
src_compile() {
- gnuconfig_update
-
local myconf
- use nls || myconf="${myconf} --disable-nls"
-
myconf="${myconf} --disable-gnome"
myconf="${myconf} --disable-gdk-pixbuf --disable-gtktest"
+ econf \
+ $(use_enable nls) \
+ ${myconf} || die "econf failed"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- ${myconf} || die
-
- emake || die
+ emake || die "emake failed"
}
src_install () {
- make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- install || die
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS COPYING README* TODO NEWS
}