summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2010-05-05 21:47:39 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2010-05-05 21:47:39 +0000
commitfefeb784783d7c1a5198abbd92f6d33e0f38aeaa (patch)
tree86a7954b9b4f5fd5da2b5edffe95fffb2cb81916 /net-p2p/lince
parentChange work directory fixing bug #317627 (diff)
downloadgentoo-2-fefeb784783d7c1a5198abbd92f6d33e0f38aeaa.tar.gz
gentoo-2-fefeb784783d7c1a5198abbd92f6d33e0f38aeaa.tar.bz2
gentoo-2-fefeb784783d7c1a5198abbd92f6d33e0f38aeaa.zip
Version bump. Dropped optional useflag (changed to hard dep)
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'net-p2p/lince')
-rw-r--r--net-p2p/lince/ChangeLog10
-rw-r--r--net-p2p/lince/lince-1.2.ebuild35
2 files changed, 43 insertions, 2 deletions
diff --git a/net-p2p/lince/ChangeLog b/net-p2p/lince/ChangeLog
index 01b2f7c1248d..828cef3cb2e1 100644
--- a/net-p2p/lince/ChangeLog
+++ b/net-p2p/lince/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/lince
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/lince/ChangeLog,v 1.18 2009/10/25 17:15:01 tove Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/lince/ChangeLog,v 1.19 2010/05/05 21:47:39 sochotnicky Exp $
+
+*lince-1.2 (05 May 2010)
+
+ 05 May 2010; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ +lince-1.2.ebuild:
+ Version bump. Dropped optional useflag (changed to hard dep)
25 Oct 2009; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove coldwind from metadata.xml (#181764)
diff --git a/net-p2p/lince/lince-1.2.ebuild b/net-p2p/lince/lince-1.2.ebuild
new file mode 100644
index 000000000000..a2bb2f3ce65d
--- /dev/null
+++ b/net-p2p/lince/lince-1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/lince/lince-1.2.ebuild,v 1.1 2010/05/05 21:47:39 sochotnicky Exp $
+
+EAPI="1"
+
+DESCRIPTION="A light, powerful and full-featured gtkmm bittorrent client"
+SRC_URI="mirror://sourceforge/lincetorrent/${P}.tar.gz"
+HOMEPAGE="http://lincetorrent.sourceforge.net"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="dbus"
+
+RDEPEND="dev-cpp/gtkmm:2.4
+ dev-cpp/cairomm
+ >=dev-cpp/glibmm-2.16
+ >=net-libs/rb_libtorrent-0.13
+ >=dev-libs/boost-1.36
+ dev-libs/libxml2
+ sys-devel/gettext
+ dbus? ( dev-libs/dbus-glib )
+ x11-libs/libnotify"
+DEPEND="${RDEPEND}
+ dev-util/intltool"
+
+src_compile() {
+ econf $(use_with dbus)
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}