summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2009-08-17 18:19:01 +0000
committerRobert Buchholz <rbu@gentoo.org>2009-08-17 18:19:01 +0000
commitd4fb85cbfd12a05b7ac68e07e78c3bec786162d0 (patch)
tree58296ea9f4963caaecc2d5e22889ae8bb717895d /net-p2p/mktorrent
parentstable x86, security bug 278186 (diff)
downloadgentoo-2-d4fb85cbfd12a05b7ac68e07e78c3bec786162d0.tar.gz
gentoo-2-d4fb85cbfd12a05b7ac68e07e78c3bec786162d0.tar.bz2
gentoo-2-d4fb85cbfd12a05b7ac68e07e78c3bec786162d0.zip
0.4: amd64 stable, 0.7: version bump
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/mktorrent')
-rw-r--r--net-p2p/mktorrent/ChangeLog10
-rw-r--r--net-p2p/mktorrent/metadata.xml4
-rw-r--r--net-p2p/mktorrent/mktorrent-0.4.ebuild7
-rw-r--r--net-p2p/mktorrent/mktorrent-0.7.ebuild34
4 files changed, 50 insertions, 5 deletions
diff --git a/net-p2p/mktorrent/ChangeLog b/net-p2p/mktorrent/ChangeLog
index e76f4aae5d83..a3b287fce8d4 100644
--- a/net-p2p/mktorrent/ChangeLog
+++ b/net-p2p/mktorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/mktorrent
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/ChangeLog,v 1.5 2008/01/29 12:24:25 drac Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/ChangeLog,v 1.6 2009/08/17 18:19:01 rbu Exp $
+
+*mktorrent-0.7 (17 Aug 2009)
+
+ 17 Aug 2009; Robert Buchholz <rbu@gentoo.org> metadata.xml,
+ mktorrent-0.4.ebuild, +mktorrent-0.7.ebuild:
+ 0.4: amd64 stable, 0.7: version bump
29 Jan 2008; Samuli Suominen <drac@gentoo.org> mktorrent-0.4.ebuild:
Link to libcrypto instead of libssl for required symbols. Keyword ~amd64 wrt
diff --git a/net-p2p/mktorrent/metadata.xml b/net-p2p/mktorrent/metadata.xml
index aa0f3664825f..f4ec5e826b1e 100644
--- a/net-p2p/mktorrent/metadata.xml
+++ b/net-p2p/mktorrent/metadata.xml
@@ -2,4 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>net-p2p</herd>
+<use>
+ <flag name='openssl'>Use OpenSSL for md5 and sha1 support</flag>
+ <flag name='largefile'>Enable largefile support on 32 bit systems</flag>
+</use>
</pkgmetadata>
diff --git a/net-p2p/mktorrent/mktorrent-0.4.ebuild b/net-p2p/mktorrent/mktorrent-0.4.ebuild
index 190b6637ae10..6114c58e847b 100644
--- a/net-p2p/mktorrent/mktorrent-0.4.ebuild
+++ b/net-p2p/mktorrent/mktorrent-0.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/mktorrent-0.4.ebuild,v 1.3 2008/01/29 12:24:25 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/mktorrent-0.4.ebuild,v 1.4 2009/08/17 18:19:01 rbu Exp $
inherit toolchain-funcs
@@ -10,10 +10,11 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 x86"
+KEYWORDS="amd64 x86"
IUSE=""
RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}
diff --git a/net-p2p/mktorrent/mktorrent-0.7.ebuild b/net-p2p/mktorrent/mktorrent-0.7.ebuild
new file mode 100644
index 000000000000..494f1bdbdf2b
--- /dev/null
+++ b/net-p2p/mktorrent/mktorrent-0.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/mktorrent-0.7.ebuild,v 1.1 2009/08/17 18:19:01 rbu Exp $
+
+EAPI=1
+inherit toolchain-funcs
+
+DESCRIPTION="Simple command line utility to create BitTorrent metainfo files"
+HOMEPAGE="http://mktorrent.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="threads +largefile +openssl debug"
+
+RDEPEND="openssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ tc-export CC
+ MAKEPARAM="USE_LONG_OPTIONS=1 DONT_STRIP=1"
+ use debug && MAKEPARAM="${MAKEPARAM} DEBUG=1"
+ use largefile && MAKEPARAM="${MAKEPARAM} USE_LARGE_FILES=1"
+ use openssl && MAKEPARAM="${MAKEPARAM} USE_OPENSSL=1"
+ use threads && MAKEPARAM="${MAKEPARAM} USE_PTHREADS=1"
+
+ emake ${MAKEPARAM} || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}