summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-06-28 22:31:59 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-06-28 22:31:59 +0000
commit136549e0097192cb246dcb81a9b6bcbf3b9d0feb (patch)
tree225f2471f1985ed8c8b8f07de173b9018d21a5a1 /net-p2p/nicotine+
parentAdd missing \ on econf, was preventing any backends but berkdb from being ena... (diff)
downloadgentoo-2-136549e0097192cb246dcb81a9b6bcbf3b9d0feb.tar.gz
gentoo-2-136549e0097192cb246dcb81a9b6bcbf3b9d0feb.tar.bz2
gentoo-2-136549e0097192cb246dcb81a9b6bcbf3b9d0feb.zip
Bump to subversion snapshot, r705.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r3 x86_64)
Diffstat (limited to 'net-p2p/nicotine+')
-rw-r--r--net-p2p/nicotine+/ChangeLog8
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.10_pre705.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/net-p2p/nicotine+/ChangeLog b/net-p2p/nicotine+/ChangeLog
index 1503ef55521d..6850ba4e7e7e 100644
--- a/net-p2p/nicotine+/ChangeLog
+++ b/net-p2p/nicotine+/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/nicotine+
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.28 2008/03/31 14:24:54 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.29 2008/06/28 22:31:59 coldwind Exp $
+
+*nicotine+-1.2.10_pre705 (28 Jun 2008)
+
+ 28 Jun 2008; Santiago M. Mola <coldwind@gentoo.org>
+ +nicotine+-1.2.10_pre705.ebuild:
+ Bump to subversion snapshot, r705.
*nicotine+-1.2.9-r1 (31 Mar 2008)
diff --git a/net-p2p/nicotine+/nicotine+-1.2.10_pre705.ebuild b/net-p2p/nicotine+/nicotine+-1.2.10_pre705.ebuild
new file mode 100644
index 000000000000..5c2008e5bbe0
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-1.2.10_pre705.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.10_pre705.ebuild,v 1.1 2008/06/28 22:31:59 coldwind Exp $
+
+inherit distutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="http://nicotine-plus.sourceforge.net"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="geoip spell vorbis"
+
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2
+ vorbis? ( >=dev-python/pyvorbis-1.4-r1
+ >=dev-python/pyogg-1 )
+ geoip? ( >=dev-python/geoip-python-0.2.0
+ >=dev-libs/geoip-1.2.1 )
+ spell? ( dev-python/sexy-python )
+ !net-p2p/nicotine"
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ distutils_src_compile
+
+ cd "${S}"/trayicon/
+ sed -i -e "s:/lib/:/$(get_libdir)/:" \
+ Makefile.in || die "sed failed"
+ ./autogen.py
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ distutils_python_version
+ distutils_src_install --install-lib \
+ /usr/$(get_libdir)/python${PYVER}/site-packages
+
+ cd "${S}"/trayicon/
+ emake DESTDIR="${D}" install || die "emake install failed"
+}