summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-03-03 22:41:00 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-03-03 22:41:00 +0000
commit1f07e65abcd86a8a4d92b842611ed427983e355e (patch)
treee7bf9665a419cfddba9bde71746d854c7ac67405 /net-p2p/nicotine+
parentVersion bump and clean up old 0.6 slot revisions. (diff)
downloadgentoo-2-1f07e65abcd86a8a4d92b842611ed427983e355e.tar.gz
gentoo-2-1f07e65abcd86a8a4d92b842611ed427983e355e.tar.bz2
gentoo-2-1f07e65abcd86a8a4d92b842611ed427983e355e.zip
Version bump. Use python.eclass.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/nicotine+')
-rw-r--r--net-p2p/nicotine+/ChangeLog10
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.12.ebuild31
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.15.ebuild (renamed from net-p2p/nicotine+/nicotine+-1.2.13.ebuild)22
3 files changed, 20 insertions, 43 deletions
diff --git a/net-p2p/nicotine+/ChangeLog b/net-p2p/nicotine+/ChangeLog
index ce929b7f271b..0f96bbf211d3 100644
--- a/net-p2p/nicotine+/ChangeLog
+++ b/net-p2p/nicotine+/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/nicotine+
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.42 2009/11/21 18:50:26 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.43 2010/03/03 22:41:00 dirtyepic Exp $
+
+*nicotine+-1.2.15 (03 Mar 2010)
+
+ 03 Mar 2010; Ryan Hill <dirtyepic@gentoo.org> -nicotine+-1.2.12.ebuild,
+ -nicotine+-1.2.13.ebuild, +nicotine+-1.2.15.ebuild:
+ Version bump. Use python.eclass.
21 Nov 2009; nixnut <nixnut@gentoo.org> nicotine+-1.2.14.ebuild:
ppc stable #292338
diff --git a/net-p2p/nicotine+/nicotine+-1.2.12.ebuild b/net-p2p/nicotine+/nicotine+-1.2.12.ebuild
deleted file mode 100644
index 2724195d94db..000000000000
--- a/net-p2p/nicotine+/nicotine+-1.2.12.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.12.ebuild,v 1.3 2009/10/07 17:34:06 nixnut Exp $
-
-inherit distutils multilib toolchain-funcs
-
-DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
-HOMEPAGE="http://nicotine-plus.sourceforge.net"
-SRC_URI="http://www.nicotine-plus.org/files/${P}.tar.bz2"
-
-LICENSE="GPL-3 LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-IUSE="geoip spell"
-
-RDEPEND="virtual/python
- >=dev-python/pygtk-2.10
- media-libs/mutagen
- geoip? ( >=dev-python/geoip-python-0.2.0
- >=dev-libs/geoip-1.2.1 )
- spell? ( dev-python/sexy-python )
- !net-p2p/nicotine"
-
-DEPEND="${RDEPEND}"
-
-src_install() {
- distutils_python_version
- distutils_src_install \
- --install-lib /usr/$(get_libdir)/python${PYVER}/site-packages
- dosym nicotine.py /usr/bin/nicotine
-}
diff --git a/net-p2p/nicotine+/nicotine+-1.2.13.ebuild b/net-p2p/nicotine+/nicotine+-1.2.15.ebuild
index 5331109b60de..3d49275619b5 100644
--- a/net-p2p/nicotine+/nicotine+-1.2.13.ebuild
+++ b/net-p2p/nicotine+/nicotine+-1.2.15.ebuild
@@ -1,21 +1,22 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.13.ebuild,v 1.1 2009/09/27 05:31:59 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.15.ebuild,v 1.1 2010/03/03 22:41:00 dirtyepic Exp $
-inherit distutils multilib toolchain-funcs
+EAPI=2
+SUPPORT_PYTHON_ABIS=1
+
+inherit distutils python
DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
HOMEPAGE="http://nicotine-plus.sourceforge.net"
-#SRC_URI="http://www.nicotine-plus.org/files/${P}.tar.bz2"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
+SRC_URI="mirror://sourceforge/nicotine-plus/${P}.tar.bz2"
LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE="geoip spell"
-RDEPEND="virtual/python
- >=dev-python/pygtk-2.10
+RDEPEND=">=dev-python/pygtk-2.12
media-libs/mutagen
geoip? ( >=dev-python/geoip-python-0.2.0
>=dev-libs/geoip-1.2.1 )
@@ -24,9 +25,10 @@ RDEPEND="virtual/python
DEPEND="${RDEPEND}"
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+
src_install() {
- distutils_python_version
- distutils_src_install \
- --install-lib /usr/$(get_libdir)/python${PYVER}/site-packages
+ distutils_src_install
dosym nicotine.py /usr/bin/nicotine
}