summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-06-26 19:16:09 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-06-26 19:16:09 +0000
commit7491bebae159b9e1acb6b10729958e1d21c90c55 (patch)
treedfc5d5c09516dd949ff7f263c9590d1257a4653c /net-p2p/qbittorrent
parent[bump] dev-perl/PadWalker-1.940.0 (diff)
downloadgentoo-2-7491bebae159b9e1acb6b10729958e1d21c90c55.tar.gz
gentoo-2-7491bebae159b9e1acb6b10729958e1d21c90c55.tar.bz2
gentoo-2-7491bebae159b9e1acb6b10729958e1d21c90c55.zip
Version bump
(Portage version: 2.1.11/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/ChangeLog10
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.9.10.ebuild (renamed from net-p2p/qbittorrent/qbittorrent-3.0.0_beta2.ebuild)2
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.0.0_beta4.ebuild62
3 files changed, 71 insertions, 3 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 42612915fd83..073bdf1e7101 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.188 2012/05/23 19:02:58 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.189 2012/06/26 19:16:09 hwoarang Exp $
+
+*qbittorrent-3.0.0_beta4 (26 Jun 2012)
+*qbittorrent-2.9.10 (26 Jun 2012)
+
+ 26 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +qbittorrent-2.9.10.ebuild,
+ +qbittorrent-3.0.0_beta4.ebuild, -qbittorrent-3.0.0_beta2.ebuild:
+ Version bump
*qbittorrent-3.0.0_beta2 (23 May 2012)
*qbittorrent-2.9.9 (23 May 2012)
@@ -1043,4 +1050,3 @@
08 Jan 2007; Raúl Porcel (armin76) <armin76@gentoo.org>
+qbittorrent-0.8.0.ebuild:
New ebuild for bug 148696
-
diff --git a/net-p2p/qbittorrent/qbittorrent-3.0.0_beta2.ebuild b/net-p2p/qbittorrent/qbittorrent-2.9.10.ebuild
index 4ed523975834..9b63239b4514 100644
--- a/net-p2p/qbittorrent/qbittorrent-3.0.0_beta2.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-2.9.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-3.0.0_beta2.ebuild,v 1.1 2012/05/23 19:02:58 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.9.10.ebuild,v 1.1 2012/06/26 19:16:09 hwoarang Exp $
EAPI="2"
PYTHON_DEPEND="2"
diff --git a/net-p2p/qbittorrent/qbittorrent-3.0.0_beta4.ebuild b/net-p2p/qbittorrent/qbittorrent-3.0.0_beta4.ebuild
new file mode 100644
index 000000000000..b63224e23902
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.0.0_beta4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-3.0.0_beta4.ebuild,v 1.1 2012/06/26 19:16:09 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit python qt4-r2 versionator
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus +X geoip"
+
+QT_MIN="4.6.1"
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ >=x11-libs/qt-core-${QT_MIN}:4
+ X? ( >=x11-libs/qt-gui-${QT_MIN}:4 )
+ dbus? ( >=x11-libs/qt-dbus-${QT_MIN}:4 )
+ dev-libs/boost"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ geoip? ( dev-libs/geoip )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use dbus || myconf+=" --disable-qt-dbus"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}