summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-06-03 10:44:16 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-06-03 10:44:16 +0000
commita8d911a42ca3bf78cd4d163c8415d08635770ee2 (patch)
tree407b36df53b6a938b524f592243d7f95ca79cf6d /net-p2p/qbittorrent
parentNew snapshot (diff)
downloadgentoo-2-a8d911a42ca3bf78cd4d163c8415d08635770ee2.tar.gz
gentoo-2-a8d911a42ca3bf78cd4d163c8415d08635770ee2.tar.bz2
gentoo-2-a8d911a42ca3bf78cd4d163c8415d08635770ee2.zip
Version bump, fix qt4 split dependencies, bug #217181
(Portage version: 2.1.5.3)
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/ChangeLog8
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild8
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.1.0_beta1.ebuild49
3 files changed, 61 insertions, 4 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index ced514c0d178..a7b56f2e8463 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.35 2008/04/19 17:13:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.36 2008/06/03 10:44:16 armin76 Exp $
+
+*qbittorrent-1.1.0_beta1 (03 Jun 2008)
+
+ 03 Jun 2008; Raúl Porcel <armin76@gentoo.org> qbittorrent-1.0.0.ebuild,
+ +qbittorrent-1.1.0_beta1.ebuild:
+ Version bump, fix qt4 split dependencies, bug #217181
19 Apr 2008; Raúl Porcel <armin76@gentoo.org> qbittorrent-0.9.3.ebuild,
qbittorrent-1.0.0.ebuild:
diff --git a/net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild b/net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild
index fc26e21f7012..665ddb01a596 100644
--- a/net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild,v 1.2 2008/04/19 17:13:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild,v 1.3 2008/06/03 10:44:16 armin76 Exp $
+
+EAPI="1"
inherit eutils qt4 multilib
@@ -16,8 +18,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">=net-libs/rb_libtorrent-0.13
- $(qt4_min_version 4.2)
+DEPEND="|| ( x11-libs/qt-gui:4 >=x11-libs/qt-4.2:4 )
+ >=net-libs/rb_libtorrent-0.13
dev-libs/boost
net-misc/curl
dev-cpp/commoncpp2"
diff --git a/net-p2p/qbittorrent/qbittorrent-1.1.0_beta1.ebuild b/net-p2p/qbittorrent/qbittorrent-1.1.0_beta1.ebuild
new file mode 100644
index 000000000000..9fad25a1aa35
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-1.1.0_beta1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.1.0_beta1.ebuild,v 1.1 2008/06/03 10:44:16 armin76 Exp $
+
+EAPI="1"
+
+inherit eutils qt4 multilib
+
+MY_P="${P/_/}"
+
+DESCRIPTION="BitTorrent client in C++ and Qt."
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="|| ( x11-libs/qt-gui:4 >=x11-libs/qt-4.3:4 )
+ >=net-libs/rb_libtorrent-0.13_p2335
+ dev-libs/boost
+ net-misc/curl
+ dev-cpp/commoncpp2"
+RDEPEND="${DEPEND}
+ >=dev-lang/python-2.3"
+
+pkg_setup() {
+ # We need boost built with threads
+ if ! built_with_use --missing true "dev-libs/boost" threads; then
+ eerror "${PN} needs dev-libs/boost built with threads USE flag"
+ die "dev-libs/boost is built without threads USE flag"
+ fi
+}
+
+src_compile() {
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr \
+ --with-libtorrent-inc=/usr/include \
+ --with-libtorrent-lib=/usr/$(get_libdir) \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc AUTHORS Changelog NEWS README TODO
+}