summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-10-02 20:17:29 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-10-02 20:17:29 +0000
commitec37b63b91c1b5ee39cf7dc1169a256c21bebb8b (patch)
treeeb9ee4ce30a21a435e3375343b6735506e8059f2 /net-p2p/qbittorrent
parentAdded release candidate (diff)
downloadgentoo-2-ec37b63b91c1b5ee39cf7dc1169a256c21bebb8b.tar.gz
gentoo-2-ec37b63b91c1b5ee39cf7dc1169a256c21bebb8b.tar.bz2
gentoo-2-ec37b63b91c1b5ee39cf7dc1169a256c21bebb8b.zip
Version bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/ChangeLog8
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.1.10.ebuild57
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild4
3 files changed, 66 insertions, 3 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 5c41d99ab0b1..224017da5487 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.230 2014/05/24 22:53:34 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.231 2014/10/02 20:17:29 hwoarang Exp $
+
+*qbittorrent-3.1.10 (02 Oct 2014)
+
+ 02 Oct 2014; Markos Chandras <hwoarang@gentoo.org> +qbittorrent-3.1.10.ebuild,
+ qbittorrent-9999.ebuild:
+ Version bump
*qbittorrent-3.1.9.2-r1 (24 May 2014)
diff --git a/net-p2p/qbittorrent/qbittorrent-3.1.10.ebuild b/net-p2p/qbittorrent/qbittorrent-3.1.10.ebuild
new file mode 100644
index 000000000000..6234cc17539c
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.1.10.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-3.1.10.ebuild,v 1.1 2014/10/02 20:17:29 hwoarang Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit python-r1 qt4-r2
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+MY_P=${P/_}
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE="dbus debug geoip +X"
+
+# geoip and python are runtime deps only (see INSTALL file)
+CDEPEND="
+ dev-libs/boost:=
+ dev-qt/qtcore:4
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[X?]
+ >=net-libs/rb_libtorrent-0.16.10
+ dbus? ( dev-qt/qtdbus:4 )
+ X? ( dev-qt/qtgui:4 )
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}
+ geoip? ( dev-libs/geoip )
+"
+
+S=${WORKDIR}/${MY_P}
+DOCS=(AUTHORS Changelog README.md TODO)
+
+src_configure() {
+ # Custom configure script, econf fails
+ local myconf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --with-libboost-inc="${EPREFIX}/usr/include/boost"
+ --with-qtsingleapplication=system
+ $(use dbus || echo --disable-qt-dbus)
+ $(use debug && echo --enable-debug)
+ $(use geoip || echo --disable-geoip-database)
+ $(use X || echo --disable-gui)
+ )
+
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die "configure failed"
+ eqmake4
+}
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index ed46c12010d6..4bb6fdb65178 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.16 2014/05/24 22:53:34 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.17 2014/10/02 20:17:29 hwoarang Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -34,7 +34,7 @@ RDEPEND="${CDEPEND}
geoip? ( dev-libs/geoip )
"
-DOCS=(AUTHORS Changelog README TODO)
+DOCS=(AUTHORS Changelog README.md TODO)
src_configure() {
# Custom configure script, econf fails