summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2015-06-04 18:19:35 +0000
committerDavide Pesavento <pesa@gentoo.org>2015-06-04 18:19:35 +0000
commitf603314da8bb37d57af02edcb86890eb28fe50d6 (patch)
tree05efb94e5fc7403038294b4a32de4ad33f6d289f /net-p2p/qbittorrent
parentremove old versions (diff)
downloadgentoo-2-f603314da8bb37d57af02edcb86890eb28fe50d6.tar.gz
gentoo-2-f603314da8bb37d57af02edcb86890eb28fe50d6.tar.bz2
gentoo-2-f603314da8bb37d57af02edcb86890eb28fe50d6.zip
Add missing dep wrt bug #550480
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xDADED6B2671CB57D!)
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/ChangeLog6
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.2.0.ebuild21
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild23
3 files changed, 32 insertions, 18 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index fbf64d57fb99..05959c58cf9a 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.249 2015/05/17 09:21:39 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.250 2015/06/04 18:19:35 pesa Exp $
+
+ 04 Jun 2015; Davide Pesavento <pesa@gentoo.org> qbittorrent-3.2.0.ebuild,
+ qbittorrent-9999.ebuild:
+ Add missing dep wrt bug #550480
*qbittorrent-3.2.0 (17 May 2015)
diff --git a/net-p2p/qbittorrent/qbittorrent-3.2.0.ebuild b/net-p2p/qbittorrent/qbittorrent-3.2.0.ebuild
index 015219075f2f..96e771914711 100644
--- a/net-p2p/qbittorrent/qbittorrent-3.2.0.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-3.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-3.2.0.ebuild,v 1.1 2015/05/17 09:21:39 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-3.2.0.ebuild,v 1.2 2015/06/04 18:19:35 pesa Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -9,11 +9,11 @@ inherit eutils python-r1 qt4-r2
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="http://www.qbittorrent.org/"
+
MY_P=${P/_}
if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
- KEYWORDS=""
else
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
@@ -22,25 +22,30 @@ fi
LICENSE="GPL-2"
SLOT="0"
IUSE="+dbus debug +qt4 qt5 webui +X"
-REQUIRED_USE="^^ ( qt4 qt5 )
- dbus? ( X )"
+REQUIRED_USE="
+ ^^ ( qt4 qt5 )
+ dbus? ( X )
+"
CDEPEND="
dev-libs/boost:=
>=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt4?,qt5?,X?]
>=net-libs/rb_libtorrent-1.0.0
sys-libs/zlib
- qt4? ( dev-qt/qtcore:4
+ qt4? (
+ dev-qt/qtcore:4
dbus? ( dev-qt/qtdbus:4 )
X? ( dev-qt/qtgui:4 )
- )
- qt5? ( dev-qt/qtcore:5
+ )
+ qt5? (
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
dev-qt/qtnetwork:5
dev-qt/qtxml:5
dbus? ( dev-qt/qtdbus:5 )
X? ( dev-qt/qtgui:5
dev-qt/qtwidgets:5 )
- )
+ )
"
DEPEND="${CDEPEND}
virtual/pkgconfig
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index 45b4d835f1a9..8f0ac6c6e261 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.24 2015/05/10 13:12:13 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.25 2015/06/04 18:19:35 pesa Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -9,38 +9,43 @@ inherit eutils python-r1 qt4-r2
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="http://www.qbittorrent.org/"
+
MY_P=${P/_}
if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
- KEYWORDS=""
else
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~x86"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
fi
LICENSE="GPL-2"
SLOT="0"
IUSE="+dbus debug +qt4 qt5 webui +X"
-REQUIRED_USE="^^ ( qt4 qt5 )
- dbus? ( X )"
+REQUIRED_USE="
+ ^^ ( qt4 qt5 )
+ dbus? ( X )
+"
CDEPEND="
dev-libs/boost:=
>=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt4?,qt5?,X?]
>=net-libs/rb_libtorrent-1.0.0
sys-libs/zlib
- qt4? ( dev-qt/qtcore:4
+ qt4? (
+ dev-qt/qtcore:4
dbus? ( dev-qt/qtdbus:4 )
X? ( dev-qt/qtgui:4 )
- )
- qt5? ( dev-qt/qtcore:5
+ )
+ qt5? (
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
dev-qt/qtnetwork:5
dev-qt/qtxml:5
dbus? ( dev-qt/qtdbus:5 )
X? ( dev-qt/qtgui:5
dev-qt/qtwidgets:5 )
- )
+ )
"
DEPEND="${CDEPEND}
virtual/pkgconfig