summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-06-08 07:06:18 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-06-08 07:06:18 +0000
commit0bebe147e4fbe1016019431ebb11c11c4adbc4a5 (patch)
treeb313fde2a3ebd3133830e8ca5848586877270424 /net-p2p/rtorrent
parentAdded latest upstream version. Removed pre-split versions. (diff)
downloadgentoo-2-0bebe147e4fbe1016019431ebb11c11c4adbc4a5.tar.gz
gentoo-2-0bebe147e4fbe1016019431ebb11c11c4adbc4a5.tar.bz2
gentoo-2-0bebe147e4fbe1016019431ebb11c11c4adbc4a5.zip
Added latest upstream version (with notice about new configuration file).
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/ChangeLog7
-rw-r--r--net-p2p/rtorrent/Manifest2
-rw-r--r--net-p2p/rtorrent/files/digest-rtorrent-0.2.41
-rw-r--r--net-p2p/rtorrent/rtorrent-0.2.4.ebuild46
4 files changed, 55 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 79eeb0447b4a..21fce7de5fe1 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.4 2005/05/31 07:58:43 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.5 2005/06/08 07:06:18 flameeyes Exp $
+
+*rtorrent-0.2.4 (08 Jun 2005)
+
+ 08 Jun 2005; Diego Pettenò <flameeyes@gentoo.org> +rtorrent-0.2.4.ebuild:
+ Added latest upstream version (with notice about new configuration file).
31 May 2005; David Holm <dholm@gentoo.org> rtorrent-0.2.3.ebuild:
Added to ~ppc.
diff --git a/net-p2p/rtorrent/Manifest b/net-p2p/rtorrent/Manifest
index d8a8b94c88cd..745f0eceaa19 100644
--- a/net-p2p/rtorrent/Manifest
+++ b/net-p2p/rtorrent/Manifest
@@ -2,6 +2,8 @@ MD5 50a137a3d6dc9c34cb7ff79e6e2d0b5d ChangeLog 806
MD5 dc4336d6e768b550ef6da8f6c965d234 metadata.xml 374
MD5 66412490eca4e94e378b9ce96fbc83b6 rtorrent-0.2.2.ebuild 803
MD5 4dd2be5d17f162ae982a14923b8fad2e rtorrent-0.2.3.ebuild 880
+MD5 6ad4e92d4a6fd54d94cd7ec92add085f rtorrent-0.2.4.ebuild 1094
MD5 a7fbf9f684955a67ccd3c2218c4c26f1 files/digest-rtorrent-0.2.2 66
MD5 d70cef26cab83ad7a36ef78c77b69123 files/digest-rtorrent-0.2.3 66
MD5 070b0554790fa378ce49cbf22f43e7fb files/rtorrent-0.2.3-fix.patch 731
+MD5 4f2a4166407519efdcaf059209a593bd files/digest-rtorrent-0.2.4 66
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.2.4 b/net-p2p/rtorrent/files/digest-rtorrent-0.2.4
new file mode 100644
index 000000000000..4a5210176530
--- /dev/null
+++ b/net-p2p/rtorrent/files/digest-rtorrent-0.2.4
@@ -0,0 +1 @@
+MD5 ad4624050cfe9440e48cc2188da2cb6e rtorrent-0.2.4.tar.gz 181098
diff --git a/net-p2p/rtorrent/rtorrent-0.2.4.ebuild b/net-p2p/rtorrent/rtorrent-0.2.4.ebuild
new file mode 100644
index 000000000000..ac306c82bb9a
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.2.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.2.4.ebuild,v 1.1 2005/06/08 07:06:18 flameeyes Exp $
+
+inherit eutils
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND=">=net-libs/libtorrent-0.6.4
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.12
+ sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-0.2.3-fix.patch
+}
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ einfo "rtorrent now supports a configuration file."
+ einfo "A sample configuration file for rtorrent is can be found"
+ einfo "in ${ROOT}usr/share/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}