summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-01-27 15:12:20 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-01-27 15:12:20 +0000
commitd9f32d3eee9828560275d7c918b469a89f13da67 (patch)
treea9bf817857b1f4c31f20ff779e26d480a1cdceca /net-p2p/rtorrent
parentVersion bump (diff)
downloadgentoo-2-d9f32d3eee9828560275d7c918b469a89f13da67.tar.gz
gentoo-2-d9f32d3eee9828560275d7c918b469a89f13da67.tar.bz2
gentoo-2-d9f32d3eee9828560275d7c918b469a89f13da67.zip
Version bump
(Portage version: 2.1.2-r4)
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/ChangeLog7
-rw-r--r--net-p2p/rtorrent/files/digest-rtorrent-0.7.23
-rw-r--r--net-p2p/rtorrent/rtorrent-0.7.2.ebuild52
3 files changed, 61 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 61f33ddf1e48..021a2ecd30bf 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.74 2007/01/05 20:47:10 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.75 2007/01/27 15:12:20 drizzt Exp $
+
+*rtorrent-0.7.2 (27 Jan 2007)
+
+ 27 Jan 2007; Timothy Redaelli <drizzt@gentoo.org> +rtorrent-0.7.2.ebuild:
+ Version bump
05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> rtorrent-0.6.4.ebuild,
rtorrent-0.7.1.ebuild:
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.7.2 b/net-p2p/rtorrent/files/digest-rtorrent-0.7.2
new file mode 100644
index 000000000000..0d15fb03b749
--- /dev/null
+++ b/net-p2p/rtorrent/files/digest-rtorrent-0.7.2
@@ -0,0 +1,3 @@
+MD5 e010458b6c316d867de5da08f03bea0c rtorrent-0.7.2.tar.gz 439030
+RMD160 fed1a84bcb5a2bdd27915cae8eeb15701edbe643 rtorrent-0.7.2.tar.gz 439030
+SHA256 0997f70858be064461e765595ccf2c7c68b4ff0c1bb0288ac7eb327c3b28b56e rtorrent-0.7.2.tar.gz 439030
diff --git a/net-p2p/rtorrent/rtorrent-0.7.2.ebuild b/net-p2p/rtorrent/rtorrent-0.7.2.ebuild
new file mode 100644
index 000000000000..f19b310f811f
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.7.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.7.2.ebuild,v 1.1 2007/01/27 15:12:20 drizzt Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=net-libs/libtorrent-0.11.2
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.12
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ sys-devel/bc"
+
+src_compile() {
+ replace-flags -Os -O2
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+
+ # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
+ # it could be safer to fallback to -O1, but with the high use of STL in
+ # rtorrent, that could make it too slow.
+ [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
+ fi
+
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ elog "rtorrent now supports a configuration file."
+ elog "A sample configuration file for rtorrent is can be found"
+ elog "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}